Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > X Series > X5 E53 (1999 - 2006)

X5 E53 (1999 - 2006)
The X5 SAV Forum

Reply
 
Thread Tools Display Modes
  #1  
Old 07-13-2011, 10:42 AM
RachaelsX5 RachaelsX5 is offline
Registered User
Location: Austin TX
 
Join Date: Apr 2009
Posts: 83
Mein Auto: X5 4.4i
Exclamation Nav/computer screen question

So my display seems to want to not work more then it wants to work anymore. Sometimes I fire up the X5 and all is normal. But, more often the screen tries to initialize it shows the time and goes black, or will come on then freeze and eventually go black to maybe flash back up 20 minutes later for a short period. When I scroll thru the menu all my read outs work under the speedo so the computer is still working. Is this a problem with the display or firmware. I never use the NAV because the CD's are from 01 and the maps are ancient but I would like my screen to work. Any suggestions?
Reply With Quote
Ads by Google
  #2  
Old 07-13-2011, 04:05 PM
Porando Porando is offline
Officially Welcomed to the 'Fest
Location: South OC
 
Join Date: Jul 2011
Posts: 555
Mein Auto: 2011 335i, 2004 X5 4.4L
sounds like problems with the Nav /display head unit..... tough one..
Reply With Quote
  #3  
Old 07-22-2011, 06:13 AM
Brandon500 Brandon500 is offline
Registered User
Location: Worthing, UK
 
Join Date: Jul 2011
Posts: 7
Mein Auto: X5 2004 3.0d
Hi,
This might be due to the ribbon cable into the rear of the screen having worked it's way loose over time and only making contact intermittantly. Worth taking a look below and trying this before spending money.

http://www.xdrivers.co.uk/forum/view...hp?f=22&t=2273
Reply With Quote
  #4  
Old 10-26-2012, 05:09 PM
Tourque Junkie Tourque Junkie is offline
Registered User
Location: Massachusetts
 
Join Date: Oct 2011
Posts: 32
Mein Auto: Acura TL
I just followed the process in the link above. Fixed.

Thanks boys
Reply With Quote
Reply

Bookmarks

Tags
nav, screen, x5


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > X Series > X5 E53 (1999 - 2006)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 08:23 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms