Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 5 Series > E60 (2004 - 2010)

E60 (2004 - 2010)
BMW 5-Series (E60 chassis) was first seen in the Unites States in the fall of 2003 with a 2004 Model Year designation. The E60 is now available as a 528i, 528xi, 535i, 535xi, 550i and a 535xi sports wagon! -- View the E60 Wiki

 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
  #1  
Old 10-27-2012, 11:35 PM
racooper3 racooper3 is offline
BMW Master Wannabe
Location: Tampa
 
Join Date: Aug 2011
Posts: 344
Mein Auto: 2005 BMW 545i
Angry 2F44 and 2F45 fault codes, DME/EWS issue

I have been having intermittent starting situation with my 2005 545 auto, with only 54K miles. Seems the car will start with either key, but only if the car is completely cold. I paid for a diagnostic $161 to have them check out the car. Prior to that it was a $75 fee to check alternator and battary checked. Those 2 items got a clean bill of healh. The Alternator is Valeo air cooled replaced in 4/10/12. The battery was replaced in May/2012, from a PB lead battery to new higher engery cranking amps AGM battery. I had Fields BMW Lakeland reset the battery to AGM style and register the battery specs for H8-AGM battery from Autozone. Since battery was replaced in April the car and starter has been running flawelessly. I have since personally replaced valve cover and timing cover gaskets and all o-ring and seals on top of engine. I did part of work on cyl 5-8 and had my local indy mechanic do cyl 1-4 as alternator need to be dropped and I didn't have a lift to get under the car. All electrical work had the battery disengaged on negative terminal. I am happy to say that I have no fluid leaks whatsoever, except A/C evaporator sucking out the moisture in the cockpit, which is a good thing in humid Tampa, FL.

My delimna is that car ran fine 3 weeks after the gasket and seal changes on top half motor for 3+ weeks with no issues whatsoever. I had no prior bad behavior from the car starting at all. On last Friday I drove home and then loaded up car with kids to run some errands. The car wouldn't start. Not even a click. I can hear the car wake up and fuel pump start up. Both key sets have plenty of power and I can turn on/off alarm repeated times to wake up car. I did notice that car appears to be going to sleep just fine. We have charged battery to full power on a couple of occasions to make sure this beast has plenty of power to the electrical system.

When the car is cold the engine would start just fine. When the engine is warmed or run for a lenghy drive, the car will not start again after turning off ignition. After a 6+ hour cool down, the car would start. I took the car to Fields BMW in Lakeland on a Sat morning and Cody could only run the alternator and battery test. They checked out fine. I humbly paid the $75 checkout fee and they asked if I wanted comp car wash; sure, thanks. After the porter pulled the car around to front I paid my bill and loaded up the car to head home. The car wouldn't start again. S.A. had Cody come out and check in parking lot and he stated it needed more diagnostic. I agreed to $165 diag charge for Monday AM and left the car over the weekend.

I got a call on Monday AM from Fields S.A., Mike Adkins, stating it was the starter that needed replacing. I asked how much and it was going to be, $2200 to replace a $400 Bosch starter. I told him that was outrageous and that my indy mechanic, who works on mechanical components on Euro cars and could do it for less than half that. We agreed to have me attempt to start car after cool down and on Monday AM I drove 30 miles back to my local indy garage. They went by the Fields BMW diaganosis of bad starter and they replaced it with original Bosch BMW starter. He cut me a huge break on the labor rate vs. dealer labor rates.

After my mechanic finished replacing the starter and putting car back together, the car wouldn't immediately start. They decided to let car cool down and then they were able to get car to start one time after clearing DME OBDII memory fault codes, post starter replacement. They then attempted to research the issue through their online support resources and discovered a few things. They checked all the fault codes and came up with 2F44 and 2F45. Those are the only fault codes being registered in the DME OBDII memory. The codes have to do with communication from DME to EWS/CAS modules. At the suggestion of a BMW Master mechanic I personally know, he suggested checking to see if the OBDII memory fault codes could be cleared out and if that would allow the engine to start again to drive back to Fields. My mechanic tried this procedure on multiple occasions and still not able to get the known good keys to start the engine. The keys have plenty of battery power as they both can enable/disable alarm system and lock/unlock all the doors and open trunk. The key in the ignition will turn on the electrical components, like Computer screen, lights, instrument cluster, and A/C system. There were no CB errors reported on the screen. When you turn key and press brake, the engine will not start.

I challenged my Fields BWM S.A. to cough up the Fault codes from the 1 hour diagnostic I paid for last Monday AM. To this date, a week later, they cannot provide me with the codes. Since the symptoms are the same pre and post install of new starter, I have to believe the 2F44 and 2F45 codes were in the memory when they wiped it. Why those codes were ignored or not reported by Fields diagnostic Tech and S.A. are quite disturbing. This could have possibly saved me a expensive starter repair bill. Had I agreed to have the starter replaced at Fields, it would have resulted in an unnecessary $2200 repair bill. Taking it to my indy mechanic to replace it minimized the out of pocket to $979, for the Fields mis-diagnosis. I firmly believe those other fault codes were there but the Fields Tech just didn't think through the information presented to him on the GT1/DIS diagnostic tool, assuming they even plugged it in. At one point prior, I even had the S.A. tell me it could be ignition module, but we will put the diagnostic tool on it and find out what is causing it. No sense in guessing until we have the data. Well we aren't getting any codes suggesting that ignition module is the case. Everything points to the EWS/CAS and/or DME not being in sync or partial failure of one or both of the modules.

I have read that calibrating/programming the 2 units with the keys will possibly address this issue, but requires some programming of the DME and CAS modules. I have also read that the antenna ring around the key ignition switch can go bad and may need to be relaced. It is possible it isn't able to pickup the unique ID code in the keys, which could trigger the EWS/CAS module to "immoblilze" the ignition system.

Based on previous feedback from the original owner of the car, he stated he reported to Pembroke Pines S.A, Ft Lauderdale BMW dealership this exact issue, intermittent start. Their diagnosis was a complete engine wiring harness replacement. The previous owner put in $4000 repair bill back in 4/10/12 with Pembroke Pines to resolve this very same issue and even they couldn't fix it. I thought I was getting a car that was well taken care of. Apparently they couldn't even get the diagnosis correct either.

I have been forced to learn more about the electrical operations of my car than many of the average ASE certified techs who are trained to work on these cars. I am a computer guru guy so I know how all this communication between modules can impact the overall operation of a car like this. It is a complete sham that BMW USA doesn't do a better job of training/certification of the techs that work on these cars. I suspect the Dealers have a lot to do with the level of training they send their techs to get certified and that learning on the job is the least expensive method of getting a good tech trained in 5 to 10 years, and then being able to retain them I hear are common problems. Unfortunately that leads to many unsatisfied customer repair bills outside of warranty for their Loyal BMW drivers/customers. High tech turnover also can leave a BMW dealership with less than adequate tech experience to fix these complex cars.

I have attempted to engage the Service Manager at Fields Lakeland, John Elmendorf, and he has yet to call me back after a full week has gone by. My car is still stranded 30 miles away with and DME to EWS/CAS communication issue. After 2 days of waiting for John's call, I engaged the General Manager for Fields Auto Group Lakeland (BMW and Mercedes), Gary Gordon, and he assured me that he would speak to John and have some sort of response to my situation and the $970 I am now out for a failed diagnostic, plus the $161 I paid for them to prove it was the Starter. I have yet to hear back from either John Elmendorf or Gary Gordon.

I will update this post, positive or negative, and plan to move the issue up to Fields Corporate offices and then to BMW NA in NJ or SC, if I don't get a satisfactory response that they will put their best electrical/programming tech on it to resolve these problems. I suspect that Pembroke Pines in Ft. Lauderdale has some culpability in all this, as they they took $4000 from previous owner to repair this problem and even they didn't get it right.

I love my BMW 545 and it is a pure blast to drive to work every day. Once these issues are resolved I am going to be forced (wife) to sell the car and unfortunately I'll likely end up driving a Hyundai SUV. I have been driving BMW for 16+ years and I am going to miss having one in my driveway. I don't know if I'll ever get another one after this experience.

racooper3@verizon.net


Last edited by racooper3; 11-02-2012 at 11:05 AM. Reason: Typos and grammer
Reply With Quote
Advertisement
 

Bookmarks

Tags
2f44, 2f45, 545, cas, dme/ews, ews, fields


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 5 Series > E60 (2004 - 2010)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 01:59 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms