Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 7 Series / 8 Series > 7 Series - E38 (1995 - 2001)

7 Series - E38 (1995 - 2001)

Reply
 
Thread Tools Display Modes
  #1  
Old 11-06-2012, 01:15 PM
Celthorseman Celthorseman is offline
Registered User
Location: La Grange, CA
 
Join Date: May 2012
Posts: 16
Send a message via Yahoo to Celthorseman Send a message via Skype™ to Celthorseman
Mein Auto: 740i
Radio Issues

Ok this is driving me nuts. My radio works part of the time, but me CD player works all the time. Here is what I mean, I start me car in the morning and I have AM/FM and tape, but once it warms up all I have is CD. Even if I am listening to the radio and it goes out I change the channel and it works again, but only for a little while. The LD and SB or little up, but the SB is dimmer than the LD on the tape area. Also with that I just put a new tape player in the car. I am thinking of going with an after market set up, but I really like the look of the factory system, so that is a last resort. Any thoughts on what I might be able to do to make the radio work all the time?
Reply With Quote
Advertisement
  #2  
Old 11-06-2012, 07:31 PM
BMWFatherFigure's Avatar
BMWFatherFigure BMWFatherFigure is offline
Old School
Location: Perth, Western Australia
 
Join Date: Aug 2012
Posts: 2,711
Mein Auto: E23;E30;E38;E32;E34 +
Remove the ignition switch electrical part. Drown it in switch cleaner and work the switch through its range. Wash again and dry. Refit. Should fix it. Full reasons on other of my posts
__________________
Good - Fast - Cheap: Pick any two.
Current:
E23 735i; E32 735iL (X 2 - 1 Alpine White and 1 Glacier Blue); E34 535i; E38 735iL; R50 Cooper; R55 Cooper Clubman.
Previous:
E21 318i; E30 318i; E32 735iL; E34 535i; E38 730iL; E53 4.4i
Reply With Quote
  #3  
Old 11-07-2012, 09:00 AM
Celthorseman Celthorseman is offline
Registered User
Location: La Grange, CA
 
Join Date: May 2012
Posts: 16
Send a message via Yahoo to Celthorseman Send a message via Skype™ to Celthorseman
Mein Auto: 740i
What is the other post that you talk about this fix in. I must say it sounds weird to me to fix this issue this way. Then again I have seen stranger things in the past.

Sent from my DROID3 using Bimmer App
Reply With Quote
  #4  
Old 11-21-2012, 04:11 PM
740lman 740lman is offline
Registered User
Location: Minnesota
 
Join Date: Nov 2012
Posts: 2
Mein Auto: 740iL
Are you saying remove the switch assembly? Or can you drowned the key switch (where the key goes)? I my case the radio seeming to stop and the screen seems to lock up. I just bought the car and I am still learning all the gadgets.
Reply With Quote
  #5  
Old 11-22-2012, 06:24 AM
chrisn7 chrisn7 is offline
Officially Welcomed to the 'Fest
Location: Huddersfield, West Yorks
 
Join Date: Oct 2011
Posts: 556
Mein Auto: 750iL
You remove the switch assembly from the steering column, dis-assemble and clean. Its a straightforward job and there are fewer parts inside the switch than you might imagine.
Reply With Quote
  #6  
Old 11-24-2012, 01:50 AM
BMWFatherFigure's Avatar
BMWFatherFigure BMWFatherFigure is offline
Old School
Location: Perth, Western Australia
 
Join Date: Aug 2012
Posts: 2,711
Mein Auto: E23;E30;E38;E32;E34 +
The switch has a volt only signal to several componemts. contacts oxidise because of low current. cleaning fixes. DONT squirt switch cleaner down the key hole. Where did you get that?
__________________
Good - Fast - Cheap: Pick any two.
Current:
E23 735i; E32 735iL (X 2 - 1 Alpine White and 1 Glacier Blue); E34 535i; E38 735iL; R50 Cooper; R55 Cooper Clubman.
Previous:
E21 318i; E30 318i; E32 735iL; E34 535i; E38 730iL; E53 4.4i
Reply With Quote
  #7  
Old 11-24-2012, 09:43 AM
chrisn7 chrisn7 is offline
Officially Welcomed to the 'Fest
Location: Huddersfield, West Yorks
 
Join Date: Oct 2011
Posts: 556
Mein Auto: 750iL
Agreed. The contacts inside have small amounts of grease to ease their movment. The last thing you want to do is spread that around via switch cleaner. The contacts are similar to, though smaller, than the old contact breaker points for those who remember such things....
Reply With Quote
  #8  
Old 12-08-2012, 11:35 PM
bmw2qnj2le bmw2qnj2le is offline
BMW740i
Location: TEXAS
 
Join Date: Jan 2012
Posts: 27
Mein Auto: 740i
Arrow 2001 740i. Lost Multifunction display

2001 740i. New with the E38/740i car.
I lose my NAV/Radio/Multifunction display after disconnecting my battery for replacing the oil cover gasket.
When I reconnected the battery back, my display was blank. I called for help. Helper is not familiar with BMW. I could not started my car b/c I set the security code. After reading the manual, I could start my car again but still no display. Radio only works for ~3 min then stops.
1. Any thing I can do to bring back the multifunction display back? (the back light does work)
2. Do I need to take to dealer to fix it? or just any simple fuse or reset somewhere in the car that I could do?

Any help is greatly appreciated. Many thanks in advance.

bmw2qnj2le
Reply With Quote
  #9  
Old 01-13-2013, 10:09 PM
740beemer 740beemer is offline
Registered User
Location: Cedar hill tx
 
Join Date: Jan 2013
Posts: 4
Mein Auto: 1996 bmw 740il
I have a couple of questions, i just got a 1996 740il and the radio wont work i dont know what it is i thought it was the speakers so i replaced them but it still did not work i dont know if its the radio or the dsp, the dsp will not turn on but the radio does, can someone help me?
Reply With Quote
  #10  
Old 01-13-2013, 11:22 PM
BMWFatherFigure's Avatar
BMWFatherFigure BMWFatherFigure is offline
Old School
Location: Perth, Western Australia
 
Join Date: Aug 2012
Posts: 2,711
Mein Auto: E23;E30;E38;E32;E34 +
Not a problem I have come across - sorry
__________________
Good - Fast - Cheap: Pick any two.
Current:
E23 735i; E32 735iL (X 2 - 1 Alpine White and 1 Glacier Blue); E34 535i; E38 735iL; R50 Cooper; R55 Cooper Clubman.
Previous:
E21 318i; E30 318i; E32 735iL; E34 535i; E38 730iL; E53 4.4i
Reply With Quote
  #11  
Old 01-14-2013, 12:04 PM
740beemer 740beemer is offline
Registered User
Location: Cedar hill tx
 
Join Date: Jan 2013
Posts: 4
Mein Auto: 1996 bmw 740il
Thanks anyways
Reply With Quote
  #12  
Old 02-20-2013, 03:05 PM
HneDog HneDog is offline
Registered User
Location: illinois & missouri
 
Join Date: Feb 2013
Posts: 61
Mein Auto: 1998 740il & 2010 750li
i got similar problems with my 98 740il with no nav. my cd work great but my radio doesnt. everything turns on and when i try to find a station for am and fm it cant lock onto a channel.

Reply With Quote
  #13  
Old 02-20-2013, 05:22 PM
740beemer 740beemer is offline
Registered User
Location: Cedar hill tx
 
Join Date: Jan 2013
Posts: 4
Mein Auto: 1996 bmw 740il
Well i found out the problem to why my radio was not working, there was no amp and i was thinking about buying a oem amp but i just decided to buy a after market radio and now i can listen to my music. First off is there noise coming from the speakers and second is the antena conected
Reply With Quote
  #14  
Old 02-21-2013, 01:58 PM
HneDog HneDog is offline
Registered User
Location: illinois & missouri
 
Join Date: Feb 2013
Posts: 61
Mein Auto: 1998 740il & 2010 750li
Quote:
Originally Posted by 740beemer View Post
Well i found out the problem to why my radio was not working, there was no amp and i was thinking about buying a oem amp but i just decided to buy a after market radio and now i can listen to my music. First off is there noise coming from the speakers and second is the antena conected
if i turn it up all the way i can hear white noise. and isnt the antenna on the back of the head unit ( cassette player )???

where is this stubborn piece of garbage in the car?
Reply With Quote
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 7 Series / 8 Series > 7 Series - E38 (1995 - 2001)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



Forum Jump


All times are GMT -7. The time now is 12:38 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms