Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 5 Series > E34 (1989 - 1995)

E34 (1989 - 1995)

Reply
 
Thread Tools Display Modes
  #1  
Old 11-07-2012, 06:07 PM
muddypunk muddypunk is offline
Registered User
Location: Coupeville, Wa
 
Join Date: Aug 2010
Posts: 44
Mein Auto: 95 xj,88xj and 1989 525i
Stranger things happening

So to start off I hardly ride or drive the bimmer but it needed a oil change and to have the tires rotated.After I finished I took it for a drive and the Power steering was very Heavy and did not like to turn untill warm. When I returned home I checked to see if the pump was working by taking the cap off and turning the wheel and nothing happend the fluid is Dark and murky its always been a little rough but seems to have gone way down hill over the past year thinking maybe I need to replace the Rack and pump.The Strange thing is the Dash has been yelling wierd things numbers parts of words and numbers mixed looks like some form of Data like the car is trying to tell us something. Any help would be very AWESOME also the car is a 1989 525i automatic

So I cleaned the steering res and the flat style filter and the steering is much better. But Im still wondering what the strange brew script running on the dash is cause by is this something the Stomp test could help with? is there a way to clear the memory and see if it will help it.

Last edited by muddypunk; 11-07-2012 at 06:11 PM. Reason: Cleaned re this week I posted this last week in the wrong forum and NO BOD would move it.
Reply With Quote
Advertisement
  #2  
Old 11-07-2012, 07:37 PM
1995i540's Avatar
1995i540 1995i540 is offline
Founder @ Maintenr
Location: New York
 
Join Date: Apr 2007
Posts: 717
Mein Auto: 1995 540I/6
Did you put engine oil in your power-steering?
__________________


///////////////////////////////////////////// E34 Addicts


Founder @ Maintenr. Take control of your vehicle maintenance.
Reply With Quote
  #3  
Old 11-07-2012, 08:27 PM
robertobaggio20 robertobaggio20 is offline
Banned
Location: earth
 
Join Date: Oct 2009
Posts: 3,403
Mein Auto: car
Your ps oil clearly sounds dirty. Try draining and filling with dexron 3. Check the troubleshooting chart for ps in the bentley manual.

Last edited by robertobaggio20; 11-07-2012 at 08:29 PM.
Reply With Quote
  #4  
Old 11-08-2012, 06:50 AM
muddypunk muddypunk is offline
Registered User
Location: Coupeville, Wa
 
Join Date: Aug 2010
Posts: 44
Mein Auto: 95 xj,88xj and 1989 525i
Did anyone read that the steering is better Im more concerned with the dash that must have smoked crack in its lifetime because its Wacked out.I drained P/S fluid and put in new DEX/III and Ive done that twice now in a week and it feels great but the Im still thinking of changing the res because its like 25$ and maybe the pump because the pulley is kinda wonky I can move it in and out. We dont have a book but I take it the bentley is the one to have ?
Reply With Quote
  #5  
Old 11-08-2012, 07:29 AM
robertobaggio20 robertobaggio20 is offline
Banned
Location: earth
 
Join Date: Oct 2009
Posts: 3,403
Mein Auto: car
Unclamp your ecu for 5 minutes. This deletes all error codes. See if that fixes your dash. If it doesnt your instrument cluster is probably defective. What you describe is not normal. Before you get another however unclamp your battery this cuts all power and also deletes codes. Fix it back after ten minutes and see if youve got joy.

Google for the download of the manual.
Reply With Quote
  #6  
Old 11-08-2012, 08:46 AM
1995i540's Avatar
1995i540 1995i540 is offline
Founder @ Maintenr
Location: New York
 
Join Date: Apr 2007
Posts: 717
Mein Auto: 1995 540I/6
Quote:
Originally Posted by muddypunk View Post
Did anyone read that the steering is better Im more concerned with the dash that must have smoked crack in its lifetime because its Wacked out.I drained P/S fluid and put in new DEX/III and Ive done that twice now in a week and it feels great but the Im still thinking of changing the res because its like 25$ and maybe the pump because the pulley is kinda wonky I can move it in and out. We dont have a book but I take it the bentley is the one to have ?
You are all over the place with your problems. Ignore robertobaggio20 he will ruin your car as he does not have a clue what he is talking about.

Your dash problem sounds like LMK issue (light control module) but it's hard to tell, try replacing that off Ebay and see if that resolves your issue otherwise you might have bad circuits in your dash.
__________________


///////////////////////////////////////////// E34 Addicts


Founder @ Maintenr. Take control of your vehicle maintenance.
Reply With Quote
  #7  
Old 11-09-2012, 07:03 AM
muddypunk muddypunk is offline
Registered User
Location: Coupeville, Wa
 
Join Date: Aug 2010
Posts: 44
Mein Auto: 95 xj,88xj and 1989 525i
1995i540 Thanks but is there a way to wipe the codes so I can see whats really wrong ? I mean if I wipe codes and new ones should show up if there is something really wrong.I will look at replacing the light control module.
Reply With Quote
  #8  
Old 11-09-2012, 07:16 AM
1995i540's Avatar
1995i540 1995i540 is offline
Founder @ Maintenr
Location: New York
 
Join Date: Apr 2007
Posts: 717
Mein Auto: 1995 540I/6
Do you have check engine light on? If not, you do not have any codes that are active. If you have wierd text in your dash that makes no sense it's most likely LKM.

Also your P.S pulley should move VERY little when you pull it forward and back, this is normal.
__________________


///////////////////////////////////////////// E34 Addicts


Founder @ Maintenr. Take control of your vehicle maintenance.
Reply With Quote
  #9  
Old 11-09-2012, 08:27 AM
robertobaggio20 robertobaggio20 is offline
Banned
Location: earth
 
Join Date: Oct 2009
Posts: 3,403
Mein Auto: car
Quote:
Originally Posted by muddypunk View Post
1995i540 thanks but is there a way to wipe the codes so i can see whats really wrong ?

lol!

Invest in an obd1 code reader or take your car to a mechanic, then.

Last edited by robertobaggio20; 11-09-2012 at 08:57 AM.
Reply With Quote
  #10  
Old 11-09-2012, 11:05 AM
south26 south26 is offline
Officially Welcomed to the 'Fest
Location: Dayton, OH
 
Join Date: May 2009
Posts: 784
Mein Auto: 535i 1989
I have a good LKM for 25 plus shipping.



Andy
Reply With Quote
  #11  
Old 11-09-2012, 05:08 PM
muddypunk muddypunk is offline
Registered User
Location: Coupeville, Wa
 
Join Date: Aug 2010
Posts: 44
Mein Auto: 95 xj,88xj and 1989 525i
So what I was just reading the LKM works headlights and foglights the problem we are having comes and goes also this car does not have the OBD 1 I have a code reader for my Jeeps and but the Bimmer has a funny like 12 point plug thes like 1.5 inch around unless the plug is elsewhere.Cool about the pulley and if I have to repair the LKM Ill do it just fine I work on cars for a halfass job so I never take anything to another guy to fix! that would be like saying hey man you wanna bone my wife Im feeling lazy lol....
Reply With Quote
  #12  
Old 11-09-2012, 06:22 PM
robertobaggio20 robertobaggio20 is offline
Banned
Location: earth
 
Join Date: Oct 2009
Posts: 3,403
Mein Auto: car
Quote:
Originally Posted by muddypunk View Post
So what I was just reading the LKM works headlights and foglights the problem we are having comes and goes also this car does not have the OBD 1 I have a code reader for my Jeeps and but the Bimmer has a funny like 12 point plug thes like 1.5 inch around unless the plug is elsewhere.Cool about the pulley and if I have to repair the LKM Ill do it just fine I work on cars for a halfass job so I never take anything to another guy to fix! that would be like saying hey man you wanna bone my wife Im feeling lazy lol....
Oh, are you saying that the lkm does not affect the instrument cluster ?

You delete your codes by unclamping your ecu for a few minutes. There is no need to remove battery terminals, and touch them to each other for 5 minutes, or anything. Do this if the stomp test does not work on your car.

And you do have OBD1 on your m20 and it is the circular port that's located next to your fusebox. Google and youtube are your friends here.



rgds,
Roberto

Last edited by robertobaggio20; 11-09-2012 at 06:25 PM.
Reply With Quote
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 5 Series > E34 (1989 - 1995)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 05:58 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms