Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 5 Series > E39 (1997 - 2003)

E39 (1997 - 2003)
The BMW 5-Series (E39 chassis) was introduced in the United States as a 1997 model year car and lasted until the 2004 when the E60 chassis was released. The United States saw several variations including the 525i, 528i, 530i and 540i. -- View the E39 Wiki

Reply
 
Thread Tools Display Modes
  #1  
Old 11-13-2012, 10:47 PM
e39540iv8 e39540iv8 is offline
Officially Welcomed to the 'Fest
Location: Australia
 
Join Date: May 2012
Posts: 141
Mein Auto: 2000 BMW 540iA
E39 540i Electrical Issues

Hey guys, just need some help on the enigma aka my 540i.

I came to start the car 3 days ago and the car started weirdly and the cluster didn't work. I also heard weird noises so I turned it off. I tried starting it a few hours later and the car wouldn't turn over, only "click". Now the battery is pretty old, over 3 years but the little button thing on it doesn't show white which means replace. I know that it's not accurate but could this be a battery issue? I say this because now the interior lights, seats and general electrics work sometimes and sometimes they don't. So like I open the door, the interior lights up but I come to do it maybe an hour later it doesn't. Then after say 4-5 hours it works again and then it just doesn't.

The cluster didn't work while the car was running the last time I turned it on which led me to believe the cluster had blown but then the electrics started acting weird and now I just don't know what's going on. Car mechanics show no sympathy either, they charge so much for such little work. I've spent over $3k on this car already and it hasn't gotten better. It's not that I don't have money to spend it's that I don't wanna spend a fortune on this thing. This is by far the most unreliable car I've driven.

Anyways does anybody have any clues I'd really appreciate it.
Reply With Quote
Ads by Google
  #2  
Old 11-13-2012, 11:14 PM
e39540iv8 e39540iv8 is offline
Officially Welcomed to the 'Fest
Location: Australia
 
Join Date: May 2012
Posts: 141
Mein Auto: 2000 BMW 540iA
Plus there's something I found on the drivers side floor. It looks like a piece of metal that's broken off but it's really light. It might not even be a part of the car but if anybody knows what it is would you mind telling me. Thanks

http://farm9.staticflickr.com/8070/8...75f87248_k.jpg

http://farm9.staticflickr.com/8482/8...a8155737_k.jpg

http://farm9.staticflickr.com/8205/8...35944e2c_k.jpg

http://farm9.staticflickr.com/8205/8...5c056d2a_k.jpg

http://farm9.staticflickr.com/8340/8...97e7a0a8_k.jpg

http://farm9.staticflickr.com/8209/8...059f5b82_k.jpg
Reply With Quote
  #3  
Old 11-14-2012, 03:26 AM
Euromanonly Euromanonly is online now
Stw***281;
Location: Hermiston
 
Join Date: Oct 2012
Posts: 48
Mein Auto: 99 Bmw 528it, Bmw e30 M3
To me it looks like a piece of a motor mount bracket or a piece of the engine block "corner of it"..
Reply With Quote
  #4  
Old 11-14-2012, 04:05 AM
vavet5308 vavet5308 is offline
NADAVAN
Location: Mechanicsville, VA
 
Join Date: Dec 2005
Posts: 503
Mein Auto: 2002 525it
Do you have a voltmeter? It would be nice to see the battery voltage before, during, and after your attempted cranking.
I was first thinking a problem with the battery, but with your description of the flaky electronics, I wonder if the ignition switch is failing. It can cause some flaky behavior. It's fairly easy to replace.

Take a look at #2 in this picture. #6 is the lock cylinder where your key goes. The end of the lock cylinder meshes with the ignition switch.
http://www.realoem.com/bmw/showparts...03&hg=32&fg=30
Reply With Quote
  #5  
Old 11-14-2012, 04:10 AM
e39540iv8 e39540iv8 is offline
Officially Welcomed to the 'Fest
Location: Australia
 
Join Date: May 2012
Posts: 141
Mein Auto: 2000 BMW 540iA
Are you serious? It came from under the steering wheel. It was inside the car on the driver's side.
Reply With Quote
  #6  
Old 11-14-2012, 03:08 PM
JimLev JimLev is online now
Officially Welcomed to the 'Fest
Location: MA
 
Join Date: Dec 2003
Posts: 3,629
Mein Auto: 540/6, S60 Volvo, Tribeca
Sounds like a bad battery. Get this one charged and a volt meter to see if the alternator is really charging the battery properly.
__________________

2000 540/6 Slightly tweeked...everywhere
Reply With Quote
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 5 Series > E39 (1997 - 2003)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 05:16 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms