Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 7 Series / 8 Series > 7 Series - E38 (1995 - 2001)

7 Series - E38 (1995 - 2001)

Reply
 
Thread Tools Display Modes
  #1  
Old 11-08-2012, 10:15 AM
rrtec's Avatar
rrtec rrtec is offline
Bored Worker
Location: TN 37174
 
Join Date: Sep 2008
Posts: 819
Mein Auto: 540i/6 4/99
Misfires with thermostat 139 INPA code

The last two mornings my 1997 740i has thrown a code and the temp guage has only been at the 10 oclock position. I plugged up the INPA and the car was throwing misfires on all cyls as well as a 139 thermostat output code. As soon as I clear the codes the temp guage reads normal and stays good until the next cold start the following day.

The car runs well although sounds cammed when first started so I understand the misfire codes, I am assuming that my sparkplug wells have some oil in them as my VCG need replacing and I have dealt with that before. But the 139 code puzzles me. Is this the sensor ontop of the housing or is the thermostat bad? The fact that when I clear the error the guage goes to normal makes me think its the sensor and not the thermostat itself.

I have attached the pages from the initial start up of the Smoothness and then when fully warmed up as well as a shot of the 139 error.. Sorry for the poor cell phone quality pics. Any help would be much appreciated.


Start Up:



After up to temp:



139 Error:

Attached Thumbnails
Click image for larger version

Name:	smooth1.jpg
Views:	780
Size:	220.3 KB
ID:	348769   Click image for larger version

Name:	smooth.jpg
Views:	754
Size:	175.0 KB
ID:	348770   Click image for larger version

Name:	error.jpg
Views:	752
Size:	186.1 KB
ID:	348771  
__________________
2001 740il Sport- Needs maintenance.. Parts ordered..
2006 Volvo XC90- Kid Hauler
FC3S LS1/6Speed
1992 BMW K75s Cafe build

Last edited by rrtec; 11-08-2012 at 10:32 AM.
Reply With Quote
Ads by Google
  #2  
Old 11-09-2012, 05:38 AM
rrtec's Avatar
rrtec rrtec is offline
Bored Worker
Location: TN 37174
 
Join Date: Sep 2008
Posts: 819
Mein Auto: 540i/6 4/99
I put in the temp sensor from my 540i and then cleared codes and reset the adaptations. The service engine soon light does not come on for the 139 thermostat code apparently as it was still present after reset but did not trip the light.... A new code came up today as well 35 Lambda sensor but I think that was because the car was idling a little rough... I cleared all codes and reset adaptations.. I would like to know what to replace.. Frustrating, not sure why I thought that the INPA would be a little easier to deciefer.

The car is taking a long time to warm up, I am wondering if the thermostat is stuck open?

Also My total air consumption HLM is off the charts, as well as the needed air i.s. controller..

Any help would be appreciated.
__________________
2001 740il Sport- Needs maintenance.. Parts ordered..
2006 Volvo XC90- Kid Hauler
FC3S LS1/6Speed
1992 BMW K75s Cafe build
Reply With Quote
  #3  
Old 11-09-2012, 06:11 AM
joyism5's Avatar
joyism5 joyism5 is offline
Officially Welcomed to the 'Fest
Location: USA
 
Join Date: Jan 2011
Posts: 1,270
Mein Auto: '99 740IL, K75RT
I know nothing about the inpa code but the thermostat error and missfires + the lamba code make a little sense to me. I think that the heating element inside the thermostat went bad and the engine can't keep up with the setting for the temperature, which is controlled by DME. This thermostat should open at 103 C degrees (100 is the boiling point for water), and I think that if does not open when supposed to, all the air-fuel ratio is messed up. This would be my explanation for the misfire. There ways that you can test the thermostat. I remember a talk about that long time ago.
http://www.bimmerfest.com/forums/sho...ght=thermostat
__________________
JOY = BMW
Reply With Quote
  #4  
Old 11-09-2012, 05:32 PM
chrisn7 chrisn7 is offline
Officially Welcomed to the 'Fest
Location: Huddersfield, West Yorks
 
Join Date: Oct 2011
Posts: 511
Mein Auto: 750iL
You need to replace the thermostat, which is rated at 105C. When you remove the plug to the stat, check for corrosion of the pins. Coolant eventually leaks out of the connection point on the stat, and will, given time, follow the harness by capilliary action all the way back to the e box, to do even more damage. Sounds improbable, but it happens.

You won't notice any difference under normal conditions when the job is done, as the purpose of the system is to open the stat more under very high ambient temperatures, or high engine loads. This why it gets missed or ignored
Reply With Quote
  #5  
Old 11-11-2012, 08:35 AM
rrtec's Avatar
rrtec rrtec is offline
Bored Worker
Location: TN 37174
 
Join Date: Sep 2008
Posts: 819
Mein Auto: 540i/6 4/99
I have swapped out the thermostat from my 540i to see if that makes a difference. I need to finish bleeding the system out and see how it does. I need another cold morning to be 100% sure. My thermostat form the 740i appeared normal, but I haven't ohmed it out to see if it really failed. When I started the car last night there was no CEL or misfires so confidence is high.
__________________
2001 740il Sport- Needs maintenance.. Parts ordered..
2006 Volvo XC90- Kid Hauler
FC3S LS1/6Speed
1992 BMW K75s Cafe build
Reply With Quote
  #6  
Old 11-11-2012, 11:39 AM
rrtec's Avatar
rrtec rrtec is offline
Bored Worker
Location: TN 37174
 
Join Date: Sep 2008
Posts: 819
Mein Auto: 540i/6 4/99
No Codes pulled this morning, the car did not misfire on startup, apparently the thermostat was the failure. Here is to hoping.
__________________
2001 740il Sport- Needs maintenance.. Parts ordered..
2006 Volvo XC90- Kid Hauler
FC3S LS1/6Speed
1992 BMW K75s Cafe build
Reply With Quote
  #7  
Old 11-15-2012, 02:03 PM
rrtec's Avatar
rrtec rrtec is offline
Bored Worker
Location: TN 37174
 
Join Date: Sep 2008
Posts: 819
Mein Auto: 540i/6 4/99
Code 139 is back.... Misfires on startup... Any ideas?
__________________
2001 740il Sport- Needs maintenance.. Parts ordered..
2006 Volvo XC90- Kid Hauler
FC3S LS1/6Speed
1992 BMW K75s Cafe build
Reply With Quote
  #8  
Old 11-15-2012, 08:24 PM
joyism5's Avatar
joyism5 joyism5 is offline
Officially Welcomed to the 'Fest
Location: USA
 
Join Date: Jan 2011
Posts: 1,270
Mein Auto: '99 740IL, K75RT
Few things about the thermostat (map one).

The control of the engine cooling system with a conventional thermostat(regular) is determined by the coolant temperature only, while the characteristic of the map thermostat, are that temperature can now be influenced specifically within the thermostat control range.As a result the engine can be operated at a higher coolant temperature in the partial load range, on the other hand, lower coolant temperatures are intentionally set under full load operating conditions. This achieves more eficient combustion thus reducing fuel consumption and pollutant emissions.
The map thermostat is controlled by the engine control module dependent on a characteristic map, determined by the following factors: engine load,engine speed,vehicle speed,intake temperature.
The thermostat still works like conventional one (this one opens at 110Celsius degree ), however, a heating element is additionally integrated in the expansion element . In the event of control intervention by the DME control module, power (12 V) is applied to the heating element integrated in the thermostat. Heating the expansion element means that the thermostat opens at lower coolant temperatures 80- 103Celsius degrees.
The line connection and the function of the characteristic map thermostat are monitored by the diagnosis function in the DME control module. Any faults are stored in the fault code memory of the DME control module. When the coolant gauge is showing the mid-position for coolant temperature means that it reached o 75C - 113 Celsius degrees.

Knowing this , few things that will trigger the map cooling thermostat code could be :
-fault thermostat heating element,
-fault in the coolant temp sensor (the one on the thermostat housing),
-any wiring problems with the above sensor/element,
-a mechanical fault in the thermostat itself.

Any of this could cause the coolant to be out of map , and the code will be stored by the DME.

The thermostat element can be checked with a voltmeter for continuity/OHM, and if receives 12 V at the connector when temp is 73-103C. The thermostat itself can be checked using a infrared thermometer , taking values at the hose after the thermostat.
__________________
JOY = BMW
Reply With Quote
  #9  
Old 11-16-2012, 05:07 AM
rrtec's Avatar
rrtec rrtec is offline
Bored Worker
Location: TN 37174
 
Join Date: Sep 2008
Posts: 819
Mein Auto: 540i/6 4/99
I swapped the sensor and thermostat from a known working set.. Ugg... I guess I will buy NEW just to be certain.
__________________
2001 740il Sport- Needs maintenance.. Parts ordered..
2006 Volvo XC90- Kid Hauler
FC3S LS1/6Speed
1992 BMW K75s Cafe build
Reply With Quote
  #10  
Old 11-16-2012, 10:29 AM
joyism5's Avatar
joyism5 joyism5 is offline
Officially Welcomed to the 'Fest
Location: USA
 
Join Date: Jan 2011
Posts: 1,270
Mein Auto: '99 740IL, K75RT
Quote:
Originally Posted by rrtec View Post
I guess I will buy NEW just to be certain.
I would do same. For some reason the swap is not always certain.
__________________
JOY = BMW
Reply With Quote
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 7 Series / 8 Series > 7 Series - E38 (1995 - 2001)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



Forum Jump


All times are GMT -7. The time now is 11:11 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms