Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 5 Series > E34 (1989 - 1995)

E34 (1989 - 1995)

 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
  #1  
Old 11-17-2012, 09:43 PM
equalie equalie is offline
Registered User
Location: ca
 
Join Date: Nov 2012
Posts: 2
Mein Auto: 1990 525i
e34 lost power

Hello,
first of all thank u guys for replying to posts, I have reviewed multiple posts and u guys have helped me multiple times. I have been having a major issue with my 1990 525i BMW.

1990 525i e34
228 k miles
Manual

I just had refilled my car with gas, pulled out of parking lot and got 100 yards, I was in third gear probably around 2800 rpms when all of a sudden my rpms dropped down to 500 and acted as if it had stalled. Down shifted and again no dice, I pulled off the side of the road and when I stopped the car stalled. Took a minute and tried starting it and it wouldn't it sounded different as well like there was a loss of pressure or something. Took awhile and a lot of pumping of the gas to get it started again. Once it did start, it was running really rough and had a very loud continual clicking that followed the rpms. I was too far away from home to get it towed, and it was at least running, so I took my chances and drove it home. Noticing that the power had dropped dramatically. When I got home I noticed that the ticking was less, but the power loss was still very significant.
I took the car into a mechanic and they said that they had to adjust the tps in the car and added fuel injection cleaner and said that it should improve with time. Still no improvement after a month and one refill of gas. Also the loss of power remains, especially going up hills....ex is one hill I used to be able to get up in 5th gear now I have to down shift into third and rev to about 5000 rpms just to maintain speed. Also the lack of acceleration with the car where the car doesn't get up and go until u hit 4500 rpms.
Side note:
months prior, I replaced the spark plugs, spark plug wires, ignition coil, and clutch. And it had run perfectly fine for those three or four months. So I figured it wasn't that.

Sorry for the lengthy message but any help or suggestions would be greatly appreciated. This has been driving me insane. This has never happened before and I know the car is seasoned, but I love this car too much tho get rid of it.
Reply With Quote
Ads by Google
 

Bookmarks

Tags
e34, low acceleration, power loss, stall


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 5 Series > E34 (1989 - 1995)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 08:44 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms