Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > X Series > X3 E83 (2004 - 2010)

X3 E83 (2004 - 2010)
Talk about the E83 BMW X3 in this forum!

Reply
 
Thread Tools Display Modes
  #1  
Old 11-18-2012, 09:07 AM
hyper_x3 hyper_x3 is offline
Registered User
Location: Kuwait
 
Join Date: Nov 2012
Posts: 5
Mein Auto: 2005 E83 X3 2.5i
Burn smell x3 2.5i

I have noticed that when i roll down the windows and accelerate heavily, there is a burn smell that appears (fire works smell). I am not sure where its coming from and it only appears when i full throttle it or heavily accelerate. Any one has this problem or knows the solution?
Reply With Quote
Advertisement
  #2  
Old 11-18-2012, 09:23 AM
alpinweiss alpinweiss is offline
Officially Welcomed to the 'Fest
Location: Nuevo MÚxico
 
Join Date: Sep 2009
Posts: 1,552
Mein Auto: E46, E83, E90 (all MT)
Could you give us a bit more information on your X3?
1. What is the year model?
2. How many miles (kilometers) on the odometer?
3. Is it manual or automatic transmission?
4. Have you had any recent repair work done on your X3?
5. Is there any unusual noise when you accelerate and have the burning smell?

Hello, and welcome to Bimmerfest!

__________________
Alpinwei▀
E46, E83, E90 (all with three pedals)
BMW CCA member
Reply With Quote
  #3  
Old 11-18-2012, 09:26 AM
hyper_x3 hyper_x3 is offline
Registered User
Location: Kuwait
 
Join Date: Nov 2012
Posts: 5
Mein Auto: 2005 E83 X3 2.5i
its a 2005 automatic. Has 147,000km. no mechanical repairs and no sounds. just smell.
Reply With Quote
  #4  
Old 11-18-2012, 10:10 AM
mlukas161's Avatar
mlukas161 mlukas161 is offline
Officially Welcomed to the 'Fest
Location: WNY
 
Join Date: Oct 2008
Posts: 936
Mein Auto: 03 330i, 04 X3
I would guess its a leaking valve cover gasket. Oil may be leaking out and burning. Look for oil on the passanger side if the valve cover.
__________________
Reply With Quote
  #5  
Old 11-18-2012, 11:05 AM
alpinweiss alpinweiss is offline
Officially Welcomed to the 'Fest
Location: Nuevo MÚxico
 
Join Date: Sep 2009
Posts: 1,552
Mein Auto: E46, E83, E90 (all MT)
Quote:
Originally Posted by mlukas161 View Post
I would guess its a leaking valve cover gasket. Oil may be leaking out and burning. Look for oil on the passanger side if the valve cover.
To the OP: If your valve cover gasket set has never been replaced, it is overdue. It will now be hard and brittle. The set includes the valve cover gasket plus the seals that go around the spark plugs. This will cause a burning oil smell, if it is leaking. You may also want to replace your spark plugs as a part of this job.

Since you mentioned the smell is present only when you accelerate, I wonder if there may be something driveline-related. Have you had the fluids changed on the transfer case and both differentials? The transfer case is especially critical. Follow this link:
http://www.bimmerfest.com/forums/sho...d.php?t=463848

It is a bit hard to diagnose a smell by long distance, but I hope this helps on your problem.

__________________
Alpinwei▀
E46, E83, E90 (all with three pedals)
BMW CCA member
Reply With Quote
  #6  
Old 11-18-2012, 10:24 PM
hyper_x3 hyper_x3 is offline
Registered User
Location: Kuwait
 
Join Date: Nov 2012
Posts: 5
Mein Auto: 2005 E83 X3 2.5i
thank you very much for your help. I haven't changed the cover neither the spark plugs. I will check with the diferential oil. I hope this solves my problem thank you againg.

Sent from my GT-I9300 using Bimmer App
Reply With Quote
  #7  
Old 11-18-2012, 10:25 PM
hyper_x3 hyper_x3 is offline
Registered User
Location: Kuwait
 
Join Date: Nov 2012
Posts: 5
Mein Auto: 2005 E83 X3 2.5i
thank you for your help, I will see if that solves my problem.
Reply With Quote
  #8  
Old 11-20-2012, 08:18 PM
X3-terrestrial's Avatar
X3-terrestrial X3-terrestrial is offline
Aficionado
Location: N.Miss - Memphis,TN Area
 
Join Date: Aug 2008
Posts: 2,631
Mein Auto: '05 X3, '95 M3, '89 MkI
Quote:
Originally Posted by mlukas161 View Post
I would guess its a leaking valve cover gasket. Oil may be leaking out and burning. Look for oil on the passenger side if the valve cover.
X2 on the Valve Cover Gasket!

At that mileage, you need to get serious on catching up on maintenance!

-All fluids (Transfer case, transmission, both differentials)
-Valve Cover Gasket
-Spark Plugs
-02 sensors
-Fuel Filter
-Air Filter
-Brake fluid flush
-Coolant flush
-Power steering fluid flush
-Shocks and struts must be screaming for help too!
__________________
"If everything seems under control, you're just not going fast enough"
-Mario Andretti.

___________________
River City Bimmers BMW CCA
2005 X3 3.0i ZPP, Htd seats, Htd strng, Black Sapphire on Terracotta.
1995 ///M3 Coupe, Lux, MT, Htd seats, Cosmos Black on Black.

Last edited by X3-terrestrial; 11-20-2012 at 08:20 PM.
Reply With Quote
Reply

Bookmarks

Tags
2.5i, burn, e83, x3


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > X Series > X3 E83 (2004 - 2010)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 05:29 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms