Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > X Series > X5 E53 (1999 - 2006)

X5 E53 (1999 - 2006)
The X5 SAV Forum

 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
  #1  
Old 11-19-2012, 12:29 AM
Bundu Bundu is offline
Registered User
Location: Johannesburg
 
Join Date: Nov 2012
Posts: 1
Mein Auto: X5 4.8IS
Exclamation Valves / Petrol Pump Problem

Hi

Please help. Recently purchased an X5 4.8IS on low mileage. Ive been driving the car for almost 3 months now. Whenever i start the car, there is a delay in starting as if the starter is giving in or perhaps the problem with the battery. I checked the following with the mechanics: battery, alternator, starter and all are in good working order.

Could it be that the injectors are not getting enough gas before starting, or does it mean there is a problem with my valves? Or does it mean my petrol pump is gving in? Your assistance is appreciated.
Reply With Quote
Ads by Google
 

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > X Series > X5 E53 (1999 - 2006)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 11:50 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms