Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 5 Series > E60 (2004 - 2010)

E60 (2004 - 2010)
BMW 5-Series (E60 chassis) was first seen in the Unites States in the fall of 2003 with a 2004 Model Year designation. The E60 is now available as a 528i, 528xi, 535i, 535xi, 550i and a 535xi sports wagon! -- View the E60 Wiki

Reply
 
Thread Tools Display Modes
  #1  
Old 04-23-2012, 07:02 AM
rossmelvin rossmelvin is offline
Registered User
Location: Auburn, AL
 
Join Date: Nov 2005
Posts: 22
Mein Auto: E60 530i
Unhappy 06 530i Weird overheating issue

Well over the past week or so on cool mornings, I've been getting the engine temp too high drive moderately or the stop engine too hot. Also the heat won't work on the days this happens and it only happens when it's cooler, hot days sitting in traffic it's fine. If I turn off the car wait a couple of minutes then turn it back on the heat will work and it won't overheat for the rest of my drive. I pulled up the secrete menu so I could watch the temp, and sure enough it never stopped climbing. The fan works, and if you open the coolant tank there's plenty of coolant and you can see the water flowing in and hear the pump running. Is this the thermostat or maybe a faulty water valve in the heating system causing this? Going to the stealership Thursday to have the battery recall done and this issue looked at, but I'd like to know if anybody has any ideas so they don't completely rip me off. And yes I did a search but it seemed the other problems were bad fans, water pump, and they didn't seem to have weird circumstances like mine.
__________________
2006 530i

WAR EAGLE!!!
Reply With Quote
Advertisement
  #2  
Old 04-23-2012, 07:20 AM
sockmonkey sockmonkey is offline
Tail out!
Location: Germany
 
Join Date: Feb 2012
Posts: 365
Mein Auto: BMW
A faulty coolant / heater valve won't cause overheating. Your thermostat needs to be replaced, within all likelyhood.

While your in there, check all hose connections, bleed screws, integrety of your reservoir as well as the side tanks on your radiator. Replace the cap if it hasn't been replaced- these slowly loose pressure holding ability over time and degrade the overall cooling performance.
Reply With Quote
  #3  
Old 11-19-2012, 01:24 PM
navgs400 navgs400 is offline
Registered User
Location: Philadelphia, PA
 
Join Date: Mar 2012
Posts: 30
Mein Auto: 2013 BMW 328i
Hi, just wanted to follow up and see what this issue turned out to be. The exact same things are occuring with me as of the other day. We've had two very cold mornings and it happens at the start of a trip but goes away. Seems like it's the thermostat and/or the water pump. Thanks
__________________
2013 328i, Mineral Grey Metallic, Oyster Leather, Sport Line, Premium Package, Navigation, HK, PDC (Retired)
2007 530xi, Space Grey, Black Dakota Leather, Premium Package, Cold Weather Package, Navigation (Retired)
Reply With Quote
  #4  
Old 11-21-2012, 02:16 PM
looney53 looney53 is offline
Registered User
Location: Los Angeles, Ca
 
Join Date: Sep 2012
Posts: 13
Mein Auto: 07 BMW 530i
same thing happened to me 07 530i 96000 miles, replaced electric water pump (electric), thermostat, (wahler Brand), 2 gals coolant (original BMW) and serpentine belt, did it myself and up and running..
Reply With Quote
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 5 Series > E60 (2004 - 2010)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 07:12 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms