Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > X Series > X5 E53 (1999 - 2006)

X5 E53 (1999 - 2006)
The X5 SAV Forum

 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
  #1  
Old 11-19-2012, 06:46 PM
wyoMom307 wyoMom307 is offline
Registered User
Location: Casper, WY
 
Join Date: Aug 2012
Posts: 9
Mein Auto: 03 BMW X5 4.4i
Red face Clicking after water pump replacement

I just did a DIY water pump replacement on my 2003 X5 4.4i. While in there replaced the a/c belt, and the thermostat. Cleared the codes so that the therm gauge wouldn't read in the red automatically anymore, but now there is a clicking in the engine compartment that gets faster with acceleration. Any ideas what this might be? A tension pulley? Fan Clutch? I am at a loss. Any help is greatly appreciated.
Reply With Quote
Advertisement
 

Bookmarks

Tags
clicking noise, fan clutch, pulley, water pump


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > X Series > X5 E53 (1999 - 2006)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 01:54 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms