Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > The Best of Bimmerfest! > BMW Coding and Programming

BMW Coding and Programming
Discuss coding options and features on your BMW here.

Reply
 
Thread Tools Display Modes
  #1  
Old 10-05-2012, 06:21 AM
lifo_1 lifo_1 is offline
Registered User
Location: Tampa
 
Join Date: Oct 2012
Posts: 13
Mein Auto: F10
F10 - Remove TPMS Warning

I have successfully removed all warnings about TPMS from my NAV - HU_CIC / RDC = nicht_aktiv (Thanks shawnsheridan!)

Now Im trying to remove the yellow warning light in the instrument cluster.

Anyone attempted this?
Reply With Quote
Advertisement
  #2  
Old 10-05-2012, 07:48 PM
shawnsheridan's Avatar
shawnsheridan shawnsheridan is online now
Officially Welcomed to the 'Fest
Location: Houston, TX
 
Join Date: Jan 2009
Posts: 11,262
Mein Auto: 2011 535i M-Sport
Quote:
Originally Posted by lifo_1 View Post
I have successfully removed all warnings about TPMS from my NAV - HU_CIC / RDC = nicht_aktiv (Thanks shawnsheridan!)

Now Im trying to remove the yellow warning light in the instrument cluster.

Anyone attempted this?
Did you search KOMBI for RDC setting, and if that did not work, remove 2VB from VO and VO Code KOMBI, HU_CIC, and RDC?
__________________

- 2011 535i M-Sport (Born 10/10) - AW/BLK/DW - /ZMP (w/ARS, EDC, DHP, & AD) /ZPP /ZP2 (w/ZPS & ZPT) /ZCV (w/SCAD) /6FL /6VC
- Mods - M5 343M 20" Forged Wheels / 6WB MFID / 2TB SAT / 4U1 Ceramic / 6NR Apps / PDV 5k Fogs / Rear Fogs / Euro Tail Lights / Cyba Quad Tips

Last edited by shawnsheridan; 10-06-2012 at 05:10 AM.
Reply With Quote
  #3  
Old 10-06-2012, 05:09 AM
shawnsheridan's Avatar
shawnsheridan shawnsheridan is online now
Officially Welcomed to the 'Fest
Location: Houston, TX
 
Join Date: Jan 2009
Posts: 11,262
Mein Auto: 2011 535i M-Sport
Quote:
Originally Posted by shawnsheridan View Post
Did you search KOMBI for RDC setting, and if that did not work, remove 2VB from VO and VO Code KOMBI, HU_CIC, and RDC?
Ta da!

Kommentar=RDC Ueberwachung (Comment=RDC monitoring)

KOMBI / ST_TYR_TIMEOUT = nicht_aktiv
KOMBI /ST_TYR_ALIVE = nicht_aktiv
__________________

- 2011 535i M-Sport (Born 10/10) - AW/BLK/DW - /ZMP (w/ARS, EDC, DHP, & AD) /ZPP /ZP2 (w/ZPS & ZPT) /ZCV (w/SCAD) /6FL /6VC
- Mods - M5 343M 20" Forged Wheels / 6WB MFID / 2TB SAT / 4U1 Ceramic / 6NR Apps / PDV 5k Fogs / Rear Fogs / Euro Tail Lights / Cyba Quad Tips

Last edited by shawnsheridan; 10-06-2012 at 05:11 AM.
Reply With Quote
  #4  
Old 10-06-2012, 11:21 AM
lifo_1 lifo_1 is offline
Registered User
Location: Tampa
 
Join Date: Oct 2012
Posts: 13
Mein Auto: F10
I tried those 2 above and it didn't fix. I will try to remove 2VB from vo
Reply With Quote
  #5  
Old 10-06-2012, 12:57 PM
shawnsheridan's Avatar
shawnsheridan shawnsheridan is online now
Officially Welcomed to the 'Fest
Location: Houston, TX
 
Join Date: Jan 2009
Posts: 11,262
Mein Auto: 2011 535i M-Sport
Quote:
Originally Posted by lifo_1 View Post
I tried those 2 above and it didn't fix. I will try to remove 2VB from vo
Hmmm...that surprises me that those two did not kill it.

Ok. Try this one too:

KL_PREDRIVE_F10_RPA = nicht_aktiv

If unsuccessful, kill 2VB in your VO, and VO Code HU_CIC and KOMBI. RDC has no coding data, so there is nothing to VO Code there I don't think.
__________________

- 2011 535i M-Sport (Born 10/10) - AW/BLK/DW - /ZMP (w/ARS, EDC, DHP, & AD) /ZPP /ZP2 (w/ZPS & ZPT) /ZCV (w/SCAD) /6FL /6VC
- Mods - M5 343M 20" Forged Wheels / 6WB MFID / 2TB SAT / 4U1 Ceramic / 6NR Apps / PDV 5k Fogs / Rear Fogs / Euro Tail Lights / Cyba Quad Tips
Reply With Quote
  #6  
Old 10-08-2012, 04:08 PM
lifo_1 lifo_1 is offline
Registered User
Location: Tampa
 
Join Date: Oct 2012
Posts: 13
Mein Auto: F10
Removed the 2VB and VO coded HU_CIC and KOMBI.

No luck. TPMS warning still present in NAV screen and instrument panel
Reply With Quote
  #7  
Old 10-08-2012, 04:18 PM
shawnsheridan's Avatar
shawnsheridan shawnsheridan is online now
Officially Welcomed to the 'Fest
Location: Houston, TX
 
Join Date: Jan 2009
Posts: 11,262
Mein Auto: 2011 535i M-Sport
Quote:
Originally Posted by lifo_1 View Post
Removed the 2VB and VO coded HU_CIC and KOMBI.

No luck. TPMS warning still present in NAV screen and instrument panel
That is almost impossible to believe. Are you sure after you removed 2VB from FA, that before you VO Coded HU_CIC and KOMBI, you loaded that FA (the modified one without 2VB) and activated it, and not the FA read from the car?
__________________

- 2011 535i M-Sport (Born 10/10) - AW/BLK/DW - /ZMP (w/ARS, EDC, DHP, & AD) /ZPP /ZP2 (w/ZPS & ZPT) /ZCV (w/SCAD) /6FL /6VC
- Mods - M5 343M 20" Forged Wheels / 6WB MFID / 2TB SAT / 4U1 Ceramic / 6NR Apps / PDV 5k Fogs / Rear Fogs / Euro Tail Lights / Cyba Quad Tips

Last edited by shawnsheridan; 10-08-2012 at 04:45 PM.
Reply With Quote
  #8  
Old 10-08-2012, 04:46 PM
lifo_1 lifo_1 is offline
Registered User
Location: Tampa
 
Join Date: Oct 2012
Posts: 13
Mein Auto: F10
So load the xml file with the 2VB option removed and VO code those 2 again?
Reply With Quote
  #9  
Old 10-08-2012, 04:51 PM
shawnsheridan's Avatar
shawnsheridan shawnsheridan is online now
Officially Welcomed to the 'Fest
Location: Houston, TX
 
Join Date: Jan 2009
Posts: 11,262
Mein Auto: 2011 535i M-Sport
Quote:
Originally Posted by lifo_1 View Post
So load the xml file with the 2VB option removed and VO code those 2 again?
Yes! That is why removed it. Now when you VO Code the ECU's, it won't enable 2VB like your regular FA that is stored in your car will (assuming you did not go so far as to write the modified FA to the car, and the FA in the car is original).
__________________

- 2011 535i M-Sport (Born 10/10) - AW/BLK/DW - /ZMP (w/ARS, EDC, DHP, & AD) /ZPP /ZP2 (w/ZPS & ZPT) /ZCV (w/SCAD) /6FL /6VC
- Mods - M5 343M 20" Forged Wheels / 6WB MFID / 2TB SAT / 4U1 Ceramic / 6NR Apps / PDV 5k Fogs / Rear Fogs / Euro Tail Lights / Cyba Quad Tips
Reply With Quote
  #10  
Old 10-08-2012, 05:53 PM
lifo_1 lifo_1 is offline
Registered User
Location: Tampa
 
Join Date: Oct 2012
Posts: 13
Mein Auto: F10
Just to keep the thread alive I have confirmed with Sean what I did was correct. New FA and VO coded Kombi and HUCIC. Still not luck. Will keep researching
Reply With Quote
  #11  
Old 11-20-2012, 04:17 PM
jaza45 jaza45 is offline
I'm in Miami B.
Location: Miami
 
Join Date: Sep 2003
Posts: 14
Send a message via AIM to jaza45 Send a message via Yahoo to jaza45
Mein Auto: E92 M3
when you remove the 2VB out of the VO, you still need to pulll the plug out of the RDC or remover the fuse, otherwise the car is still going to recognize the module and light is going to stay on.
Reply With Quote
  #12  
Old 11-24-2012, 07:05 AM
lifo_1 lifo_1 is offline
Registered User
Location: Tampa
 
Join Date: Oct 2012
Posts: 13
Mein Auto: F10
Success! Did everything mentioned above but this time I removed fuse. No more tpms warnings, alerts in nav or instrument panel.

However, while coding the kombi it came up with a CEL out of the blue. It has been 3 days and its still there. I don't drive the car that much so I'm hoping it goes away on its own.
Reply With Quote
  #13  
Old 11-24-2012, 07:15 AM
shawnsheridan's Avatar
shawnsheridan shawnsheridan is online now
Officially Welcomed to the 'Fest
Location: Houston, TX
 
Join Date: Jan 2009
Posts: 11,262
Mein Auto: 2011 535i M-Sport
Quote:
Originally Posted by lifo_1 View Post
Success! Did everything mentioned above but this time I removed fuse. No more tpms warnings, alerts in nav or instrument panel.

However, while coding the kombi it came up with a CEL out of the blue. It has been 3 days and its still there. I don't drive the car that much so I'm hoping it goes away on its own.
You can try this.

Assuming the fault condition no longer exists, to clear the fault code.

1) Launch C:\EDIABAS\Bin\TOOL32.EXE
2) Hit F3
3) Load C:\EDIABAS\Ecu\F01.PRG
4) In the "Select Job: F01" window, select FS_LOESCHEN_FUNKTIONAL
5) Hit F5
6) "Results" window should show "JOB_STATUS = OKAY"

Hopefully, Problem Solved.

Note: fs_lesen_funktional only read fault codes, FS_LOESCHEN_FUNKTIONAL will delete it.
__________________

- 2011 535i M-Sport (Born 10/10) - AW/BLK/DW - /ZMP (w/ARS, EDC, DHP, & AD) /ZPP /ZP2 (w/ZPS & ZPT) /ZCV (w/SCAD) /6FL /6VC
- Mods - M5 343M 20" Forged Wheels / 6WB MFID / 2TB SAT / 4U1 Ceramic / 6NR Apps / PDV 5k Fogs / Rear Fogs / Euro Tail Lights / Cyba Quad Tips
Reply With Quote
  #14  
Old 11-25-2012, 03:45 PM
lifo_1 lifo_1 is offline
Registered User
Location: Tampa
 
Join Date: Oct 2012
Posts: 13
Mein Auto: F10
Shawn you the man! CEL is gone. To recap for people wanting to disable TPMS

Pull the fuse in the trunk for TPMS.
Remove 2VB option in VO
HU_CIC / RDC = nicht_aktiv (this removes TPMS options from NAV)
KOMBI / ST_TYR_TIMEOUT = nicht_aktiv
KOMBI /ST_TYR_ALIVE = nicht_aktiv

Last edited by lifo_1; 11-25-2012 at 03:48 PM.
Reply With Quote
  #15  
Old 11-25-2012, 03:59 PM
shawnsheridan's Avatar
shawnsheridan shawnsheridan is online now
Officially Welcomed to the 'Fest
Location: Houston, TX
 
Join Date: Jan 2009
Posts: 11,262
Mein Auto: 2011 535i M-Sport
Quote:
Originally Posted by lifo_1 View Post
Shawn you the man! CEL is gone. To recap for people wanting to disable TPMS

Pull the fuse in the trunk for TPMS.
Remove 2VB option in VO
HU_CIC / RDC = nicht_aktiv (this removes TPMS options from NAV)
KOMBI / ST_TYR_TIMEOUT = nicht_aktiv
KOMBI /ST_TYR_ALIVE = nicht_aktiv
Glad I could help.
__________________

- 2011 535i M-Sport (Born 10/10) - AW/BLK/DW - /ZMP (w/ARS, EDC, DHP, & AD) /ZPP /ZP2 (w/ZPS & ZPT) /ZCV (w/SCAD) /6FL /6VC
- Mods - M5 343M 20" Forged Wheels / 6WB MFID / 2TB SAT / 4U1 Ceramic / 6NR Apps / PDV 5k Fogs / Rear Fogs / Euro Tail Lights / Cyba Quad Tips
Reply With Quote
  #16  
Old 11-30-2012, 04:38 PM
lifo_1 lifo_1 is offline
Registered User
Location: Tampa
 
Join Date: Oct 2012
Posts: 13
Mein Auto: F10
It went away the first time i drove it after clearing it but it came back after that. Comes back after i clear it everytime. Might have to take it in
Reply With Quote
  #17  
Old 11-30-2012, 05:21 PM
shawnsheridan's Avatar
shawnsheridan shawnsheridan is online now
Officially Welcomed to the 'Fest
Location: Houston, TX
 
Join Date: Jan 2009
Posts: 11,262
Mein Auto: 2011 535i M-Sport
Quote:
Originally Posted by lifo_1 View Post
It went away the first time i drove it after clearing it but it came back after that. Comes back after i clear it everytime. Might have to take it in
CEL Zombie! Do you know what the CEL Code and its meaning is?

Maybe undo all your coding, clear it with Tool32, and see if it stays off. At least you will know if it is coding related.
__________________

- 2011 535i M-Sport (Born 10/10) - AW/BLK/DW - /ZMP (w/ARS, EDC, DHP, & AD) /ZPP /ZP2 (w/ZPS & ZPT) /ZCV (w/SCAD) /6FL /6VC
- Mods - M5 343M 20" Forged Wheels / 6WB MFID / 2TB SAT / 4U1 Ceramic / 6NR Apps / PDV 5k Fogs / Rear Fogs / Euro Tail Lights / Cyba Quad Tips
Reply With Quote
  #18  
Old 04-07-2013, 06:20 AM
nimuh nimuh is offline
Registered User
Location: GER
 
Join Date: Apr 2013
Posts: 3
Mein Auto: F10
hi guys, sorry to dig up this thread again but I could not manage to remove the RDC error message yet.

is it really necessary to remove the fuse to kill the error message? i dont even care about the yellow warning light much, i just want to remove the warning message from the idrive that pops up on every start.

I coded the 3 values as stated above, but I do not want to remove the fuse if not 100% necessary.
what does this mean: "Remove 2VB option in VO"? I have e-sys running and have coded a couple values before, but im not a coding expret. what is the VO?
Reply With Quote
  #19  
Old 04-16-2013, 05:26 AM
nimuh nimuh is offline
Registered User
Location: GER
 
Join Date: Apr 2013
Posts: 3
Mein Auto: F10
update: well it wasnt too hard. I just had to remove the RDC fuse in the trunk. warning is gone forever thanks to everyone in this thread
Reply With Quote
  #20  
Old 11-27-2013, 07:57 PM
escalade26s escalade26s is offline
Officially Welcomed to the 'Fest
Location: GA
 
Join Date: Jul 2009
Posts: 101
Mein Auto: 740i
Sorry for bringing back an old thread but I am trying to get my TPMS disabled since I have after market wheels. I am really confused about VO and what it is or where to find it. The same goes for the location of the RDC fuse in the trunk. I have some coding experience and have everything needed to code, just don't know where it is within the program. Thanks in advance.
__________________

Last edited by escalade26s; 11-27-2013 at 08:13 PM.
Reply With Quote
  #21  
Old 11-27-2013, 08:04 PM
Jay Arras's Avatar
Jay Arras Jay Arras is offline
Officially Welcomed to the 'Fest
Location: CT
 
Join Date: Nov 2002
Posts: 516
Mein Auto: 2007 530xi 6 speed manual
Quote:
Originally Posted by escalade26s View Post
Sorry for bringing back an old thread but I a trying to get my TPMS disabled since I have after market wheels.
Reading through this thread, it seems to be more trouble than it's worth to me. Just pick up a set of the damn TPMS sensors on eBay for about a hundred bucks and be done with it!
Reply With Quote
  #22  
Old 11-28-2013, 04:09 PM
Nitrogen's Avatar
Nitrogen Nitrogen is offline
Officially Welcomed to the 'Fest
Location: Central California
 
Join Date: Apr 2012
Posts: 429
Mein Auto: BMW 650i Convertible
Quote:
Originally Posted by lifo_1 View Post
Shawn you the man! CEL is gone. To recap for people wanting to disable TPMS

Pull the fuse in the trunk for TPMS.
Remove 2VB option in VO
HU_CIC / RDC = nicht_aktiv (this removes TPMS options from NAV)
KOMBI / ST_TYR_TIMEOUT = nicht_aktiv
KOMBI /ST_TYR_ALIVE = nicht_aktiv

Hi guys was trying to do the above steps but when trying to delete the 2vb option in VO it asks which module just before process ECU so which module do I delete the 2VB from?

HU_CIC?
KOMBI?
CAS?

Please help thanks!!!
__________________
Sent Via iPhone using BimmerApp
Reply With Quote
  #23  
Old 11-28-2013, 09:03 PM
escalade26s escalade26s is offline
Officially Welcomed to the 'Fest
Location: GA
 
Join Date: Jul 2009
Posts: 101
Mein Auto: 740i
Got it working on my F01. I did everything previously mentioned in this thread minus the 2VB and VO thing. You may want to skip it and see if you are good as well.
__________________
Reply With Quote
  #24  
Old 11-29-2013, 12:56 AM
shawnsheridan's Avatar
shawnsheridan shawnsheridan is online now
Officially Welcomed to the 'Fest
Location: Houston, TX
 
Join Date: Jan 2009
Posts: 11,262
Mein Auto: 2011 535i M-Sport
Quote:
Originally Posted by Nitrogen View Post
Hi guys was trying to do the above steps but when trying to delete the 2vb option in VO it asks which module just before process ECU so which module do I delete the 2VB from?

HU_CIC?
KOMBI?
CAS?

Please help thanks!!!
For Fxx using E-Sys, it does not do this. I presume you are using NCS Expert for your E64 though, and it acts differently.

I would skip this step as @escalade26s wrote.
__________________

- 2011 535i M-Sport (Born 10/10) - AW/BLK/DW - /ZMP (w/ARS, EDC, DHP, & AD) /ZPP /ZP2 (w/ZPS & ZPT) /ZCV (w/SCAD) /6FL /6VC
- Mods - M5 343M 20" Forged Wheels / 6WB MFID / 2TB SAT / 4U1 Ceramic / 6NR Apps / PDV 5k Fogs / Rear Fogs / Euro Tail Lights / Cyba Quad Tips
Reply With Quote
  #25  
Old 11-29-2013, 04:23 PM
Nitrogen's Avatar
Nitrogen Nitrogen is offline
Officially Welcomed to the 'Fest
Location: Central California
 
Join Date: Apr 2012
Posts: 429
Mein Auto: BMW 650i Convertible
Quote:
Originally Posted by shawnsheridan View Post
For Fxx using E-Sys, it does not do this. I presume you are using NCS Expert for your E64 though, and it acts differently.

I would skip this step as @escalade26s wrote.


I will give it a shot and yes I am using NCS expert. I will post my results as soon as I complete it. Weird how it needs VO delete for some and not for others. Are all the cars 650i's?
Mine is a 2006 650i.

Thanks again!!!
__________________
Sent Via iPhone using BimmerApp
Reply With Quote
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > The Best of Bimmerfest! > BMW Coding and Programming
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 06:02 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms