Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 3 Series / 4 Series > E36 (1991 - 1999)

E36 (1991 - 1999)
The E36 chassis 3-Series BMW was a huge hit among driving enthusiasts from the first moment the car hit the pavement. The E36 won numerous awards over the years it was produced and is still a favorite of many BMW enthusiasts to this day! -- View the E36 Wiki

Reply
 
Thread Tools Display Modes
  #1  
Old 10-09-2012, 08:35 AM
Reminis Reminis is offline
Registered User
Location: Hertfordshire
 
Join Date: Dec 2007
Posts: 33
Mein Auto: BMW 325i E36 1992
Question Dash Display, Speedo, Tacho, Instrument Cluster not working

Hi peeps...

A search has only produced a fix for the electronic SI board display not showing properly.
What I am after is a "How To" on replacing the batteries within the instrument cluster as it might be the cause to my problems.

The fault is: None of my Dash Display, Speedo, Tacho, Instrument Cluster, Fuel gauge works... The lights on dash for indicators don't work even though the indicators are actually working, the main beam (green light) doesn't work but the high beam (blue) light does work, the "Check" (orange) light also works.
I noticed one day i went to use the car, just switched on and nothing so I wasnt using it at the time this fault occured.

I have been told by a breaker that sometimes the onboard battry/battries have died, aparently they have been know to leak all over the board and thats what causes the lot to fail?

Anyone with any knowledge on this subject?
Can i open up the dash display or is it sealed?
Are the battries hidden (if so where)?
Is there a online "How To"?
Or is it all porkies lol

It's a E36 1994 325i M50 (The last of the early breed)
Incidently the dash display has a white rear to it (apparently some have blue or green)

Thanks
Reply With Quote
Advertisement
  #2  
Old 10-09-2012, 09:04 AM
ZeGerman's Avatar
ZeGerman ZeGerman is online now
Warm Leatherette
Location: Seattle, WA
 
Join Date: Mar 2009
Posts: 19,535
Mein Auto: 1998 BMW 328is
There aren't any batteries in the cluster that I'm aware of. With the E36, the vast majority of problems like this have to do with the plug connections in the back. Try removing and resetting all three connections in the back and see if it helps. If not, you probably just need to get your hands on a used replacement cluster.
__________________

1998 BMW 328is
1966 Pontiac GTO
2007 Subaru Impreza 2.5i 5-door
View my photos: Caught in the Wild
For sale: E30/E36 front sway links
For sale: OEM E36 328 catback
Reply With Quote
  #3  
Old 10-09-2012, 09:42 AM
B1MM3R's Avatar
B1MM3R B1MM3R is offline
Jesse Moon Bayne
Location: Roanoke, VA
 
Join Date: Apr 2010
Posts: 7,699
Mein Auto: e30, e36, e70
If you need a used cluster i believe I may have one.
__________________
Jesse
"Cassie"///Mpowered 93 318is 5speed (95 m3 swap)
2007 X5 3.0si (Wifes)
E30 87 325e DD
Reply With Quote
  #4  
Old 11-27-2012, 06:23 AM
josephroberts75 josephroberts75 is offline
Registered User
Location: northcarolina
 
Join Date: Nov 2012
Posts: 23
Mein Auto: e36 bmw
like zegerman said no batteries those are capacitors and when they pop its just easier to replace the cluster usaually the same if it says code or ppppp
Reply With Quote
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 3 Series / 4 Series > E36 (1991 - 1999)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 02:53 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms