Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 5 Series > E39 (1997 - 2003)

E39 (1997 - 2003)
The BMW 5-Series (E39 chassis) was introduced in the United States as a 1997 model year car and lasted until the 2004 when the E60 chassis was released. The United States saw several variations including the 525i, 528i, 530i and 540i. -- View the E39 Wiki

Reply
 
Thread Tools Display Modes
  #1  
Old 11-27-2012, 02:57 PM
DBell DBell is offline
Registered User
Location: Campbell, CA
 
Join Date: Sep 2007
Posts: 12
Mein Auto: 1999 528i
'99 528i ABS/Spedo issues

This appears to be a common set of problems!

In my case, all works when the car is cold, then progressively fails as I drive and/or the weather heats up. First to fail is the Tracs/ABS, and if I happen to be braking when it dies, I get the brake system pulsing expected from an ABS stop. I take that (hopefully!) to indicate that a wheel speed sensor is opening up. Happens sooner in stop-n-go traffic, where there's a lot of braking effort, and in hot weather.

Some time later, say within a mile or two, the speedo quits. CEL never comes on under either failure. Along with the speedometer, I lose the odometer of course, and the MPG "gauge". The fuel-remaining computer still works, but there is no damping on tank slosh; with braking, the mileage goes up, and down under acceleration...

Which wheel sensors control which services?
Is there a way to electrically check the sensor (I imagine it's a coil, responding to a magnet on the hub)? What's the best place to plug in to check them?

Thanks!

Dave
Reply With Quote
Ads by Google
  #2  
Old 11-27-2012, 03:09 PM
moots's Avatar
moots moots is offline
wat's dat noise
Location: Malaysia
 
Join Date: Apr 2005
Posts: 451
Mein Auto: '97 528i
LH rear wheel speed sensor is for the speedomeer.change it and you're done.
__________________
Fuelly
Reply With Quote
  #3  
Old 11-27-2012, 03:24 PM
DBell DBell is offline
Registered User
Location: Campbell, CA
 
Join Date: Sep 2007
Posts: 12
Mein Auto: 1999 528i
Thanks, Moots, but does that also control the ABS/Tracs?
It seems like the failure is progressive (1-10 minutes apart), so I figured there were two units failing.

Tonight, for example, after about 4-5 miles, the ABS/Tracs error light came on. 5 minutes later, the speedometer dropped to zero.

Dave

Last edited by DBell; 11-27-2012 at 05:52 PM. Reason: updated information
Reply With Quote
  #4  
Old 11-27-2012, 09:54 PM
moots's Avatar
moots moots is offline
wat's dat noise
Location: Malaysia
 
Join Date: Apr 2005
Posts: 451
Mein Auto: '97 528i
these wheel speed sensors are dual function sensors.all 4 wheels have wheel speed sensors that inputs the ABS obviously.the lh rear also inputs the speedometer.the other sensors also inputs other systems but i can't remember.google is your best friend.

http://www.bimmerfest.com/forums/sho....php?p=3774725
__________________
Fuelly

Last edited by moots; 11-27-2012 at 10:00 PM.
Reply With Quote
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 5 Series > E39 (1997 - 2003)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 01:12 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms