Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 5 Series > F10 / F11 (2011 - Current)

F10 / F11 (2011 - Current)
The new chapter in the highly successful story of the BMW 5 Series Sedan (F10) and wagon (F11)

Reply
 
Thread Tools Display Modes
  #26  
Old 11-10-2012, 08:22 AM
Chuck W.'s Avatar
Chuck W. Chuck W. is offline
Officially Welcomed to the 'Fest
Location: Agoura Hills (LA) CA
 
Join Date: Apr 2007
Posts: 942
Mein Auto: 12 BMW 535I MS Alpine Wht
Quote:
Originally Posted by kssod View Post
I came across this TSB,.....
I would like to see the full bulletin. I did a Google search and couldn't find it.

Last night I got the battery drained/low warning again. This is after an 800 mile trip and keeping the car on a battery tender. Their is a problem here that they haven't addressed.
__________________
2012 BMW 535I 24,000 Miles
ED Pick Up on 12/03/2011; US Pick Up on 01/27/1012
Alpine White, M Sport, Blk Nappa, Cold Weather, Luxury Seating, Premium, Premium Sound, Tech, Sports Trans, Active Cruise, Heads-Up

Mods - Quad Exhaust Tips, HID Fog Lights, Clear Front Reflectors, M5 Spoiler, Calipers Painted Black, 12.5 mm Rear Wheel Spacers, Tint - 5% Rear, 35% Front & 50% Windshield - BlackVue DR500GW Dash Cam, Blendmount for Valentine One

Coding by tuesday (aka; itschase) (Chase)
Reply With Quote
  #27  
Old 11-10-2012, 11:54 AM
kssod kssod is offline
Officially Welcomed to the 'Fest
Location: Cleveland
 
Join Date: Jun 2010
Posts: 275
Mein Auto: Acura RL
***65532;***65532;***65532;
From NHTSA.GOV

Service Bulletins - Search Results
5 Record(s) Displayed.
Make : BMW Model : 5-SERIES Manufacturer : BMW of North America, LLC Service Bulletin Number : SIB-61-02-12
NHTSA Item Number : 10043862
Component : ELECTRICAL SYSTEM: SOFTWARE
Summary :
Year : 2012
Date of Bulletin : AUG 01, 2012
***65532;***65532;***65532;***65532;***65532;***65 532;***65532;Report Date : November 10, 2012 at 02:53 PM Search Type : VEHICLE
Year : 2012 Make : BMW
Model : 5-SERIES
***65532;BMW: ELECTRONIC MALFUNCTION AND VARIOUS CHECK CONTROL MESSAGES ARE DISPLAYED IN CID (CENTRAL INFORMATION DISPLAY) AND INSTRUMENT CLUSTER. *PE MODELS 2009-2012 E70, E71, E72, E82, E88, E90, E91, E92, E93, F01, F02, F04, F07, F10, F12, F13, F25. UPDATED 11/2/12. *PE
***65532;Make : BMW Model : 5-SERIES Manufacturer : BMW of North America, LLC Service Bulletin Number : SIB-12-14-12 NHTSA Item Number : 10045283 Component : ENGINE
Summary :
Year : 2012
Date of Bulletin : AUG 01, 2012
BMW: EXPERIENCING LOSS OF ENGINE POWER, SERVICE ENGINE SOON LAMP IS ILLUMINATED, A NOISE, LIKE RATTLING, COMING FROM ENGINE COMPARTMENT. *PE UPDATED 10/31/12. *PE
***65532;Make : BMW Model : 5-SERIES Manufacturer : BMW of North America, LLC Service Bulletin Number : SIB-61-02-12 NHTSA Item Number : 10043862 Component : ELECTRICAL SYSTEM
Summary :
Year : 2012
Date of Bulletin : AUG 01, 2012
BMW: ELECTRONIC MALFUNCTION AND VARIOUS CHECK CONTROL MESSAGES ARE DISPLAYED IN CID (CENTRAL INFORMATION DISPLAY) AND INSTRUMENT CLUSTER. *PE MODELS 2009-2012 E70, E71, E72, E82, E88, E90, E91, E92, E93, F01, F02, F04, F07, F10, F12, F13, F25. UPDATED 11/2/12. *PE
***65532;Make : BMW Model : 5-SERIES Manufacturer : BMW of North America, LLC
Service Bulletin Number : SIB-24-02-12
NHTSA Item Number : 10043910
Component : ENGINE AND ENGINE COOLING:ENGINE Summary :
BMW: DELAY IN ENGINE RESPONSE. *KB
Year : 2012
Date of Bulletin : MAR 01, 2012
***65532;Make : BMW Model : 5-SERIES
Manufacturer : BMW of North America, LLC
Service Bulletin Number : SIB-16-03-12
NHTSA Item Number : 10043687
Component : FUEL SYSTEM, OTHER:STORAGE:TANK ASSEMBLY
Summary :
BMW: THE EVAPORATIVE SYSTEM LEAKAGE IS FOUND, WHEN USING THE NVLD TANK LEAKAGE TEST PLAN. *PE
Year : 2012
Date of Bulletin : FEB 01, 2012
***65532;***65532;
***65532;***65532;***65532;***65532;***65532;1200 New Jersey Avenue, SE, West Building Washington DC 20590 USA 1.888.327.4236 TTY 1.800.424.9153
***65532;
Reply With Quote
  #28  
Old 11-12-2012, 05:15 PM
kssod kssod is offline
Officially Welcomed to the 'Fest
Location: Cleveland
 
Join Date: Jun 2010
Posts: 275
Mein Auto: Acura RL
Not much help

After a day of diagnostics, only issue was that battery was at 70% charge. They could not find any issue to cause the drain. They can tell how much the car is driven , length of trips, whether shut off properly, thus agreed that it was not human error.
So we will see if it happens again.

Also had software reprogrammed since when the battery is charged. or changed it needs to be updated, (I think that is BS) most dealers hook the terminals up to a battery tender while a new battery is installed. They charge like $400 for a new battery to another customer, claiming it is 3 hrs to reprogram the software.

Had the steering update applied.

Noticed a grooved front rotor, had new rotors and pads installed.

Only gripe is the CBD maintenance reset from 4k to 8k miles.
Reply With Quote
  #29  
Old 11-12-2012, 06:06 PM
Chuck W.'s Avatar
Chuck W. Chuck W. is offline
Officially Welcomed to the 'Fest
Location: Agoura Hills (LA) CA
 
Join Date: Apr 2007
Posts: 942
Mein Auto: 12 BMW 535I MS Alpine Wht
Quote:
Originally Posted by kssod View Post
They charge like $400 for a new battery to another customer, claiming it is 3 hrs to reprogram the software.
WOW.... I had itschase program my daughter's E90 after I installed a new battery. Took him maybe four minutes.
__________________
2012 BMW 535I 24,000 Miles
ED Pick Up on 12/03/2011; US Pick Up on 01/27/1012
Alpine White, M Sport, Blk Nappa, Cold Weather, Luxury Seating, Premium, Premium Sound, Tech, Sports Trans, Active Cruise, Heads-Up

Mods - Quad Exhaust Tips, HID Fog Lights, Clear Front Reflectors, M5 Spoiler, Calipers Painted Black, 12.5 mm Rear Wheel Spacers, Tint - 5% Rear, 35% Front & 50% Windshield - BlackVue DR500GW Dash Cam, Blendmount for Valentine One

Coding by tuesday (aka; itschase) (Chase)
Reply With Quote
  #30  
Old 11-12-2012, 07:38 PM
kssod kssod is offline
Officially Welcomed to the 'Fest
Location: Cleveland
 
Join Date: Jun 2010
Posts: 275
Mein Auto: Acura RL
I think there has to be a software issue, in which the car is not going to sleep correctly, and their is a drain on the battery. Some have suggested that the remote is too close to teh vehicle and this keeps the battery awake. Never had that issue with 30 other cars with a remote.
Might need to lock car to shut everything down, even if 2 push to shut off, locking my car is not a habit I am use to doing, since it is parked in my garage.

As I am finding out, BMW is unique, and unlike any car I've ever owned..

Last edited by kssod; 11-13-2012 at 12:24 PM.
Reply With Quote
  #31  
Old 11-12-2012, 08:12 PM
PeterC4 PeterC4 is offline
Officially Welcomed to the 'Fest
Location: Toronto
 
Join Date: Mar 2011
Posts: 954
Mein Auto: 535xi,328xiC
Something is drawing power... a tune perhaps?
__________________
2012 535xi M-Sport, Carbon Black, Cinnamon-Alum Hex, Exec Pack, Tech Pack, HUD, Damper Control, BMW Apps, Heated Rear Seats
Reply With Quote
  #32  
Old 11-12-2012, 08:37 PM
Alan L. Alan L. is offline
Officially Welcomed to the 'Fest
Location: East Coast
 
Join Date: Apr 2012
Posts: 1,409
Mein Auto: LCI 550i Msport
Nope because I got the message BEFORE I tuned my car so that rules that out.

Alan
__________________

2014 LCI 550i M Sport | 3D Design Front Spoiler | BMW Performance Black Kidney Grills | BMW Performance Trunk Spoiler | BMW Performance Gloss Black Diffuser | Painted Reflectors | Wincos 30% Tint | Supersprint Quad Exhaust | AC Schnitzer Springs | MORR VS8.2 Brushed Finished Wheels 20x10R and 20x9F | Michelin PSS Tires 245/35/20F 285/30/20R | M550d 16mm RSB |||More Photos of my car here|||
Reply With Quote
  #33  
Old 11-13-2012, 09:37 AM
depingre depingre is offline
Registered User
Location: DFW
 
Join Date: Nov 2012
Posts: 10
Mein Auto: 2011 550i
I purchased my 2011 550 about 3 weeks ago pre-owned. It has 16k miles and has the exact issue. I took it week before last and the dealer kept it for 3.5 days and said nothing was wrong, just needed charging. 3 days later it left my wife stranded. We called roadside asst and had a jump and took it back to the dealer. It has now been in 8 days and they cannot seem to diagnose the issue. The regional BMW tech rep is now on the case. The dealer isn't communicating very well with me right now. I am very frustrated.
Reply With Quote
  #34  
Old 11-14-2012, 10:36 AM
kssod kssod is offline
Officially Welcomed to the 'Fest
Location: Cleveland
 
Join Date: Jun 2010
Posts: 275
Mein Auto: Acura RL
Well, same issue exactly 24 hrs after dealer ran full electric system diagnostics.
Lemon law will now be explored by me
Reply With Quote
  #35  
Old 11-14-2012, 11:23 AM
miamiboyca's Avatar
miamiboyca miamiboyca is offline
Officially Welcomed to the 'Fest
Location: Dallas, TX
 
Join Date: Jun 2012
Posts: 1,668
Mein Auto: F10 6MT
Quote:
Originally Posted by kssod View Post
Well, same issue exactly 24 hrs after dealer ran full electric system diagnostics.
Lemon law will now be explored by me
Sweet... 2014

Just kidding... good luck, keep at them.
__________________
2013 535i Space Grey, Biege, M-SPort, Premium, Tech, Cold Weather, Luxury Seating, PDC, 6MT ED-10/11/2012 - PCD Redelivery-12/14/12
Reply With Quote
  #36  
Old 11-14-2012, 04:38 PM
kssod kssod is offline
Officially Welcomed to the 'Fest
Location: Cleveland
 
Join Date: Jun 2010
Posts: 275
Mein Auto: Acura RL
So now the fault code says bad battery, replaced again. No bad battery 2 days ago.
BMW will soon be gone
Reply With Quote
  #37  
Old 11-14-2012, 04:46 PM
Chuck W.'s Avatar
Chuck W. Chuck W. is offline
Officially Welcomed to the 'Fest
Location: Agoura Hills (LA) CA
 
Join Date: Apr 2007
Posts: 942
Mein Auto: 12 BMW 535I MS Alpine Wht
Quote:
Originally Posted by kssod View Post
So now the fault code says bad battery, replaced again. No bad battery 2 days ago.
BMW will soon be gone
Two batteries in just over four months. Yeah, there is something wrong here.
__________________
2012 BMW 535I 24,000 Miles
ED Pick Up on 12/03/2011; US Pick Up on 01/27/1012
Alpine White, M Sport, Blk Nappa, Cold Weather, Luxury Seating, Premium, Premium Sound, Tech, Sports Trans, Active Cruise, Heads-Up

Mods - Quad Exhaust Tips, HID Fog Lights, Clear Front Reflectors, M5 Spoiler, Calipers Painted Black, 12.5 mm Rear Wheel Spacers, Tint - 5% Rear, 35% Front & 50% Windshield - BlackVue DR500GW Dash Cam, Blendmount for Valentine One

Coding by tuesday (aka; itschase) (Chase)
Reply With Quote
  #38  
Old 11-15-2012, 07:27 AM
Alan L. Alan L. is offline
Officially Welcomed to the 'Fest
Location: East Coast
 
Join Date: Apr 2012
Posts: 1,409
Mein Auto: LCI 550i Msport
Ok I texted my buddy who is a tech at Rallye Bmw to get some more info.

According to him he's seen a lot of F10's come in with a bad "BST Cable" which is the negative side of the battery cable which monitors battery loss and detects any abnormal voltage drain. He said a bad BST cable could actually cause voltage loss but he's not sure.

Hopefully this helps some of you guys when you bring the car in.

Alan
__________________

2014 LCI 550i M Sport | 3D Design Front Spoiler | BMW Performance Black Kidney Grills | BMW Performance Trunk Spoiler | BMW Performance Gloss Black Diffuser | Painted Reflectors | Wincos 30% Tint | Supersprint Quad Exhaust | AC Schnitzer Springs | MORR VS8.2 Brushed Finished Wheels 20x10R and 20x9F | Michelin PSS Tires 245/35/20F 285/30/20R | M550d 16mm RSB |||More Photos of my car here|||
Reply With Quote
  #39  
Old 11-15-2012, 07:31 AM
JohnRI JohnRI is offline
Registered User
Location: Rhode Island
 
Join Date: Mar 2011
Posts: 44
Mein Auto: 550i xDrive M Sport
Having problems with my car regarding battery low warning. Took to dealer 2 weeks ago after trying several times to charge up the battery in early October. On third try it fully charged (used battery tender). Less than 2 weeks later again the same recharge message. Dealer recharged the battery at shop and error message would not go away even through it tested fully charged on their automated tester. Said it past 20mA draw test after 4 minutes. They then disconnected the negative terminal and when reconnected the warning went away.

This morning the same "recharge battery" warning came on along with another message about shutting down some items due to battery drain. In all 3 instances the temps were below 40 degrees (first time down to 30 degrees). I have owned the car since 4/2011 and never had a warning message before last month and my driving habits have not changed so I suspect that it is the battery. I measured the voltage with the car off and it is reading 12.3V presently. I'm assuming that I can't measure the charging voltage as car has to be underway. Does anyone know if there is a way to get a digital readout on the LCD display (like a service mode)?

Car is going back to dealer next week and I am going to insist they replace the battery and under warranty.
__________________
2011 550i xDrive, Imperial Blue Metallic/Oyster & Black Nappa, ZAV, ZCW, ZMP, ZP2, 2TB, 337, 465, 610, 6NF and 6WA. Worth the wait!
Reply With Quote
  #40  
Old 11-15-2012, 08:02 AM
Chuck W.'s Avatar
Chuck W. Chuck W. is offline
Officially Welcomed to the 'Fest
Location: Agoura Hills (LA) CA
 
Join Date: Apr 2007
Posts: 942
Mein Auto: 12 BMW 535I MS Alpine Wht
Quote:
Originally Posted by JohnRI View Post
On third try it fully charged (used battery tender).

Car is going back to dealer next week and I am going to insist they replace the battery and under warranty.
I have kept my car on a Battery Tender Gel Plus since the day I brought it home. It sits for several days at a time. Despite this I have had to replace the battery once and got the low battery warning once after the battery was replaced.

Good luck with the battery swap and keep up posted.
__________________
2012 BMW 535I 24,000 Miles
ED Pick Up on 12/03/2011; US Pick Up on 01/27/1012
Alpine White, M Sport, Blk Nappa, Cold Weather, Luxury Seating, Premium, Premium Sound, Tech, Sports Trans, Active Cruise, Heads-Up

Mods - Quad Exhaust Tips, HID Fog Lights, Clear Front Reflectors, M5 Spoiler, Calipers Painted Black, 12.5 mm Rear Wheel Spacers, Tint - 5% Rear, 35% Front & 50% Windshield - BlackVue DR500GW Dash Cam, Blendmount for Valentine One

Coding by tuesday (aka; itschase) (Chase)
Reply With Quote
  #41  
Old 11-15-2012, 12:10 PM
kssod kssod is offline
Officially Welcomed to the 'Fest
Location: Cleveland
 
Join Date: Jun 2010
Posts: 275
Mein Auto: Acura RL
Now it is a defective battery......
Reply With Quote
  #42  
Old 11-16-2012, 10:20 AM
Alan L. Alan L. is offline
Officially Welcomed to the 'Fest
Location: East Coast
 
Join Date: Apr 2012
Posts: 1,409
Mein Auto: LCI 550i Msport
Question for you folks....

Do you guys have your ipod/mp3 player hooked up to the car via the USB slot all the time? I am wondering if the potential problem could be that the usb slot stays "hot" and slowly drawing power when the car is parked.

Just a thought....
Alan
__________________

2014 LCI 550i M Sport | 3D Design Front Spoiler | BMW Performance Black Kidney Grills | BMW Performance Trunk Spoiler | BMW Performance Gloss Black Diffuser | Painted Reflectors | Wincos 30% Tint | Supersprint Quad Exhaust | AC Schnitzer Springs | MORR VS8.2 Brushed Finished Wheels 20x10R and 20x9F | Michelin PSS Tires 245/35/20F 285/30/20R | M550d 16mm RSB |||More Photos of my car here|||
Reply With Quote
  #43  
Old 11-16-2012, 12:44 PM
kssod kssod is offline
Officially Welcomed to the 'Fest
Location: Cleveland
 
Join Date: Jun 2010
Posts: 275
Mein Auto: Acura RL
Nope
Reply With Quote
  #44  
Old 11-16-2012, 12:59 PM
Chuck W.'s Avatar
Chuck W. Chuck W. is offline
Officially Welcomed to the 'Fest
Location: Agoura Hills (LA) CA
 
Join Date: Apr 2007
Posts: 942
Mein Auto: 12 BMW 535I MS Alpine Wht
Quote:
Originally Posted by Alan L. View Post
Question for you folks....

Do you guys have your ipod/mp3 player hooked up to the car via the USB slot all the time? I am wondering if the potential problem could be that the usb slot stays "hot" and slowly drawing power when the car is parked.

Just a thought....
Alan
Nope. Never used an iPod or plugged anything into the USB port.
__________________
2012 BMW 535I 24,000 Miles
ED Pick Up on 12/03/2011; US Pick Up on 01/27/1012
Alpine White, M Sport, Blk Nappa, Cold Weather, Luxury Seating, Premium, Premium Sound, Tech, Sports Trans, Active Cruise, Heads-Up

Mods - Quad Exhaust Tips, HID Fog Lights, Clear Front Reflectors, M5 Spoiler, Calipers Painted Black, 12.5 mm Rear Wheel Spacers, Tint - 5% Rear, 35% Front & 50% Windshield - BlackVue DR500GW Dash Cam, Blendmount for Valentine One

Coding by tuesday (aka; itschase) (Chase)
Reply With Quote
  #45  
Old 11-17-2012, 08:18 AM
jimpal's Avatar
jimpal jimpal is offline
BMW's Since 1989
Location: Minneapolis
 
Join Date: Dec 2011
Posts: 193
Mein Auto: 2012 535xi
Quote:
Originally Posted by Alan L. View Post
Question for you folks....

Do you guys have your ipod/mp3 player hooked up to the car via the USB slot all the time? I am wondering if the potential problem could be that the usb slot stays "hot" and slowly drawing power when the car is parked.

Just a thought....
Alan
I assume you are referring to the USB Audio input in the armrest. I have my iPod Nano plugged in there all the time (nearly a year). Works fine, and no noticeable effect on the battery.

Last edited by jimpal; 11-17-2012 at 08:19 AM.
Reply With Quote
  #46  
Old 11-23-2012, 08:57 PM
Alan L. Alan L. is offline
Officially Welcomed to the 'Fest
Location: East Coast
 
Join Date: Apr 2012
Posts: 1,409
Mein Auto: LCI 550i Msport
Starting to think something is wrong with the car. I picked up a nice AGM battery charger and fully charged my battery through the pos/neg terminals under the hood. I did this for several hours and according to the charger the battery was at 100%

I then drove the car on the highway for atleast 2 hours and the very next day the car still gave me the "increased battery discharge" message! WTF is going on here?! The car seems normal and even before I charged the battery it showed 75% so didn't seem like there was a problem since I don't drive my car M-F.

Alan
__________________

2014 LCI 550i M Sport | 3D Design Front Spoiler | BMW Performance Black Kidney Grills | BMW Performance Trunk Spoiler | BMW Performance Gloss Black Diffuser | Painted Reflectors | Wincos 30% Tint | Supersprint Quad Exhaust | AC Schnitzer Springs | MORR VS8.2 Brushed Finished Wheels 20x10R and 20x9F | Michelin PSS Tires 245/35/20F 285/30/20R | M550d 16mm RSB |||More Photos of my car here|||

Last edited by Alan L.; 11-23-2012 at 08:59 PM.
Reply With Quote
  #47  
Old 11-24-2012, 07:27 PM
kssod kssod is offline
Officially Welcomed to the 'Fest
Location: Cleveland
 
Join Date: Jun 2010
Posts: 275
Mein Auto: Acura RL
how long to return to full charge? My CTEK charger on the C6 would cycle between charging and charged even after a full day driving, when I first connect it.
Reply With Quote
  #48  
Old 11-29-2012, 04:49 PM
JohnRI JohnRI is offline
Registered User
Location: Rhode Island
 
Join Date: Mar 2011
Posts: 44
Mein Auto: 550i xDrive M Sport
Update....

After leaving car with dealer for 4 days the best explanation for battery low/draining was due to "old software". The service manager does not think the old software was the problem either. Considering nothing changed in my driving habits from 1 year ago. BMW NA made them run diagnostic after diagnostic with same result that there was a fault in the parking brake system or the control module was coming on when the car was off. Loading new software made the fault go away so there is nothing more they can do until the next time the warning light comes on.

As far as replacing the battery, BMW NA would not approve as the software update made the fault go away. I will give it a week or two to see if the fault reappears. If so I will call Germany if I need to. Getting concerned about what happens when the warranty is over. Maybe I better invest in an extended one.......
__________________
2011 550i xDrive, Imperial Blue Metallic/Oyster & Black Nappa, ZAV, ZCW, ZMP, ZP2, 2TB, 337, 465, 610, 6NF and 6WA. Worth the wait!
Reply With Quote
  #49  
Old 11-29-2012, 05:36 PM
Chuck W.'s Avatar
Chuck W. Chuck W. is offline
Officially Welcomed to the 'Fest
Location: Agoura Hills (LA) CA
 
Join Date: Apr 2007
Posts: 942
Mein Auto: 12 BMW 535I MS Alpine Wht
Quote:
Originally Posted by JohnRI View Post
Getting concerned about what happens when the warranty is over. Maybe I better invest in an extended one.......
I agree. I can see this getting very expensive. Keep us posted and good luck.
__________________
2012 BMW 535I 24,000 Miles
ED Pick Up on 12/03/2011; US Pick Up on 01/27/1012
Alpine White, M Sport, Blk Nappa, Cold Weather, Luxury Seating, Premium, Premium Sound, Tech, Sports Trans, Active Cruise, Heads-Up

Mods - Quad Exhaust Tips, HID Fog Lights, Clear Front Reflectors, M5 Spoiler, Calipers Painted Black, 12.5 mm Rear Wheel Spacers, Tint - 5% Rear, 35% Front & 50% Windshield - BlackVue DR500GW Dash Cam, Blendmount for Valentine One

Coding by tuesday (aka; itschase) (Chase)
Reply With Quote
  #50  
Old 12-02-2012, 08:49 AM
depingre depingre is offline
Registered User
Location: DFW
 
Join Date: Nov 2012
Posts: 10
Mein Auto: 2011 550i
Dealership service department along with the BMW rep finally said the battery was not good and gave my car's electrical system a "clean bill of health". They released the car to me with a new battery. That was less than 2 weeks ago and the car is now sitting in my garage completely dead.
Reply With Quote
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 5 Series > F10 / F11 (2011 - Current)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 02:51 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms