Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 3 Series / 4 Series > E30 (1982 - 1993)

E30 (1982 - 1993)
God's Chariot. The E30 was produced primarily from 1982 through 1991. The cabriolet was the one exception which was produced through 1993.

 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
  #1  
Old 11-30-2012, 02:48 PM
Dandy dog Dandy dog is offline
Registered User
Location: Denver
 
Join Date: Nov 2012
Posts: 18
Mein Auto: 88 325ic
Need help diagnosing electrical problem

My 88 325ic stopped running in mid-stride a couple of days ago: we were almost done with a 30-minute run back home in the foothills west of Denver when the dash lit up with warning lights and the engine quit. I got her towed home and have spent a couple of days looking for the problem without much success.
What I've learned: all the auxiliary gear is working (lights, wipers, radio, fuel pump, etc.) except the power windows, and the idle air solenoid doesn't purr when the ignition is On. (The fuel pump works only when jumped directly to the battery; connecting the 30 and 87 terminals at the relay doesn't do anything, and the pump doesn't come on when the starter is engaged.)
I've replaced the main relay with a spare, to no effect.
The absence of a hum and vibration from the idle air solenoid indicates to me that this is an electrical problem further upstream (failure of the IAS wouldn't have made the engine quit in mid-run), but I'm unsure about how to diagnose the problem further. I have a spare ECU, but I've got some reservations about subbing it in, because of the possibility that there's a short in the system.
Any advice or suggestions will be greatly appreciated,guys.
Reply With Quote
Ads by Google
 

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 3 Series / 4 Series > E30 (1982 - 1993)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 08:22 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms