Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > X Series > X5 E53 (1999 - 2006)

X5 E53 (1999 - 2006)
The X5 SAV Forum

Reply
 
Thread Tools Display Modes
  #1  
Old 11-30-2012, 10:53 AM
blakey2000 blakey2000 is offline
Registered User
Location: raleigh, nc
 
Join Date: Nov 2012
Posts: 15
Mein Auto: 2001 x5
2001 x5 4.4 starts then dies.....HELP!!!!

my 2001 x5 4.4 will start then dies everytime, throwing these codes:

P0120 = Throttle/Pedal Position Sensor/Switch 'A' Circuit
P0123 =Throttle/Pedal Position Sensor/Switch 'A' Circuit High
P0223 = Throttle/Pedal Position Sensor/Switch 'B' Circuit High

my scantool will not erease them nor will sitting w/ battery unplugged overnight.

I replaced the petal assembly and throttle body with new equipment, HELP!!!

blakeyatwork@yahoo.com
919-417-4448

someone please text me or email me!
Reply With Quote
Ads by Google
  #2  
Old 12-01-2012, 04:16 AM
blakey2000 blakey2000 is offline
Registered User
Location: raleigh, nc
 
Join Date: Nov 2012
Posts: 15
Mein Auto: 2001 x5
do I need to recalibrate or rellearn the throttle system, seems like it? process?

do I need to recalibrate or rellearn the throttle system, seems like it? process?
Reply With Quote
  #3  
Old 12-02-2012, 11:28 AM
blakey2000 blakey2000 is offline
Registered User
Location: raleigh, nc
 
Join Date: Nov 2012
Posts: 15
Mein Auto: 2001 x5
P0120 Throttle/Pedal Position Sensor/Switch A Circuit Malfunction
P0121 Throttle/Pedal Position Sensor/Switch A Circuit Range/Performance Problem
P0223 Throttle/Pedal Position Sensor/Switch B Circuit High Input
Reply With Quote
  #4  
Old 12-12-2012, 06:10 AM
blakey2000 blakey2000 is offline
Registered User
Location: raleigh, nc
 
Join Date: Nov 2012
Posts: 15
Mein Auto: 2001 x5
2001 x5 still starts then stops!

10 days later same issue.

start up and then shuts off after 1-2 seconds

Codes:

P0120
P0123
P0223
P0103


relplaced ecu from ecudoctors and synced ews
new throttle body
new gas pedal

HELP!!!!!!!!!!!!!!!!
Reply With Quote
  #5  
Old 12-13-2012, 12:33 PM
blakey2000 blakey2000 is offline
Registered User
Location: raleigh, nc
 
Join Date: Nov 2012
Posts: 15
Mein Auto: 2001 x5
....help!

...me!
Reply With Quote
  #6  
Old 12-26-2012, 06:58 AM
blakey2000 blakey2000 is offline
Registered User
Location: raleigh, nc
 
Join Date: Nov 2012
Posts: 15
Mein Auto: 2001 x5
Hey guys Im still down . I know a guy with DIS (bmw software) but he wasnt sure if there was a step in the software that Im missing that makes the pedal talk to the throttle. Right now I have the ecudoctors DME, perfect wires and harneses from pedal to DME, DME to throttle body and a new pedal and throttle. Still showing to high of voltage to throttle codes.



Does DIS have a step in it Im missing. I get the initial open/shut on turn of key of the throttle body but no 10 or 30 second initialization process w/ the key seems to do anything.
Reply With Quote
  #7  
Old 02-10-2013, 06:24 AM
blakey2000 blakey2000 is offline
Registered User
Location: raleigh, nc
 
Join Date: Nov 2012
Posts: 15
Mein Auto: 2001 x5
WELL its fixed, cost me 2600$ to figure it out but to save aeveryone trouble, replace the computer (DME) first then if that doesnt fix it its the MAF as well. That combination worked for me. If you do that itll only cost you 1000$
Reply With Quote
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > X Series > X5 E53 (1999 - 2006)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 03:18 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms