Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > Z Series > E89 Z4 (2009 - current)

E89 Z4 (2009 - current)

 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
  #1  
Old 12-02-2012, 04:07 PM
Longhauler Longhauler is offline
Registered User
Location: West Yorkshire
 
Join Date: Jun 2012
Posts: 9
Mein Auto: BMW Z4 SDRIVE 35i
Loss of dashboard electrics (e89) 2009 my

Hi,
I'm wondering if anybody has experienced this fault, my vehicle has been parked unused for a month,I came to use the vehicle this morning and found out I have no dashboard function,no turn-signal indicators,no petrol gauge,no rev-counter,and no temperature gauge.
Everything else is working, it starts it has heating radio electric windows etc etc,
can anyone help?
Regards,
Longhauler.
Reply With Quote
Ads by Google
 

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > Z Series > E89 Z4 (2009 - current)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



Forum Jump


All times are GMT -7. The time now is 12:32 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms