Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > Z Series > E89 Z4 (2009 - current)

E89 Z4 (2009 - current)

Reply
 
Thread Tools Display Modes
  #1  
Old 12-02-2012, 04:07 PM
Longhauler Longhauler is offline
Registered User
Location: West Yorkshire
 
Join Date: Jun 2012
Posts: 9
Mein Auto: BMW Z4 SDRIVE 35i
Loss of dashboard electrics (e89) 2009 my

Hi,
I'm wondering if anybody has experienced this fault, my vehicle has been parked unused for a month,I came to use the vehicle this morning and found out I have no dashboard function,no turn-signal indicators,no petrol gauge,no rev-counter,and no temperature gauge.
Everything else is working, it starts it has heating radio electric windows etc etc,
can anyone help?
Regards,
Longhauler.
Reply With Quote
Ads by Google
  #2  
Old 12-03-2012, 10:38 AM
JavierBayArea JavierBayArea is offline
Registered User
Location: mountain view
 
Join Date: Oct 2012
Posts: 8
Mein Auto: z4 sdrive35, lotus elise
Quote:
Originally Posted by Longhauler View Post
Hi,
I'm wondering if anybody has experienced this fault, my vehicle has been parked unused for a month,I came to use the vehicle this morning and found out I have no dashboard function,no turn-signal indicators,no petrol gauge,no rev-counter,and no temperature gauge.
Everything else is working, it starts it has heating radio electric windows etc etc,
can anyone help?
Regards,
Longhauler.
did you check the fuses?.

i have somewhat similar electric problems with my AC. Some days when it's very moist and there's lots of condensation it does not turn on. I feel it must be condensation short circuiting something
Reply With Quote
  #3  
Old 12-04-2012, 04:45 AM
Longhauler Longhauler is offline
Registered User
Location: West Yorkshire
 
Join Date: Jun 2012
Posts: 9
Mein Auto: BMW Z4 SDRIVE 35i
loss of electrics (E89) sDrive35i

Thank you very much for your input boys,
I, went to the vehicle this morning and found everything to be as it should be very strange I thought, rang local BMW agent but did not get any real reason why this could have happened as I am taking vehicle in next Monday for the OBDII port updating I shall get them to check it out once again thanks for your advice.
Regards,
Longhauler.
Reply With Quote
  #4  
Old 12-18-2012, 03:44 PM
Longhauler Longhauler is offline
Registered User
Location: West Yorkshire
 
Join Date: Jun 2012
Posts: 9
Mein Auto: BMW Z4 SDRIVE 35i
Hi,
Just thought Id let you know the progress regarding (LOSS OF ELECTRICS-E89),
I have just had said vehicle returned from STRATSTONE BMW LEEDS WEST YORKSHIRE UK.
I took it in to be checked over which they did finding 19 faults in the onboard memory,dont ask what they were because they seem very reluctant to tell me,
the service advisor promised to send me a full print out Im not holding my breath, On the bright side while they had the vehicle they performed the security upgrade to
the OBDII port now if they want to steal it they will need a key,
Regards,
Longhauler.
Reply With Quote
  #5  
Old 12-19-2012, 02:00 AM
645/333's Avatar
645/333 645/333 is offline
Michael
Location: uk
 
Join Date: Jun 2010
Posts: 1,160
Mein Auto: Black Sapphire BMW Z4 3L
Hi you should push for a reply and see the fault codes, this will make a real difference if you have any issues into the future, plus any information passed on will helps others. The dealers are holding way to much secret details when it comes to these cars nowadays, Whilst i sold my Z4 after 6 months ownership, my brother still has his, so I keep a watching eye in case of any problems
Ps all BMW's hate to be laid up for long periods of time, especially if you are not putting a tender on the battery during the period, I had a 6 Series also and when it comes to electronic issues due to battery condition almost unbelievable !!
__________________

Does my bum look good in this !

Last edited by 645/333; 12-19-2012 at 02:04 AM.
Reply With Quote
  #6  
Old 12-19-2012, 03:44 PM
Longhauler Longhauler is offline
Registered User
Location: West Yorkshire
 
Join Date: Jun 2012
Posts: 9
Mein Auto: BMW Z4 SDRIVE 35i
Hi. (645/333)
I,really understand your logic in your comment! but it a'int as easy as that, the job it went in for(2HRS!) turned out to be 60hrs,
its going back in on Friday(21st Dec) reason? the folding roof is opening continuously (it a'int) but obviously the guy doing the job (which I can understand must be extremely Bbbbboring!) must have taken his eye off the ball for a nanosecond the saga continues I shall keep you informed.
Regards,
ZIPPY435I,
(LONGHAULER)
Reply With Quote
  #7  
Old 12-19-2012, 03:44 PM
Longhauler Longhauler is offline
Registered User
Location: West Yorkshire
 
Join Date: Jun 2012
Posts: 9
Mein Auto: BMW Z4 SDRIVE 35i
Hi. (645/333)
I,really understand your logic in your comment! but it a'int as easy as that, the job it went in for(2HRS!) turned out to be 60hrs,
its going back in on Friday(21st Dec) reason? the folding roof is opening continuously (it a'int) but obviously the guy doing the job (which I can understand must be extremely Bbbbboring!) must have taken his eye off the ball for a nanosecond the saga continues I shall keep you informed.
Regards,
ZIPPY435I,
(LONGHAULER)
Reply With Quote
  #8  
Old 12-21-2012, 06:09 AM
645/333's Avatar
645/333 645/333 is offline
Michael
Location: uk
 
Join Date: Jun 2010
Posts: 1,160
Mein Auto: Black Sapphire BMW Z4 3L
Quote:
Originally Posted by Longhauler View Post
Hi. (645/333)
I,really understand your logic in your comment! but it a'int as easy as that, the job it went in for(2HRS!) turned out to be 60hrs,
its going back in on Friday(21st Dec) reason? the folding roof is opening continuously (it a'int) but obviously the guy doing the job (which I can understand must be extremely Bbbbboring!) must have taken his eye off the ball for a nanosecond the saga continues I shall keep you informed.
Regards,
ZIPPY435I,
(LONGHAULER)
Hi! There is no fun when this happens, I always understood that the hard top had very few kinks in its design and operation!
__________________

Does my bum look good in this !
Reply With Quote
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > Z Series > E89 Z4 (2009 - current)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



Forum Jump


All times are GMT -7. The time now is 05:56 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms