Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > X Series > X5 E70 (2007 - 2013)

X5 E70 (2007 - 2013)
E70 BMW X5 produced between 2007 and 2013. Discuss the E70 X5 with other BMW owners here.

Reply
 
Thread Tools Display Modes
  #1  
Old 12-04-2012, 08:13 PM
Jim Scott-Young Jim Scott-Young is offline
Registered User
Location: Melbourne Australia
 
Join Date: Dec 2012
Posts: 1
Mein Auto: X 5 model E70
Poor windscreen wiper pressure

I have suddenly started having poor pressure in my windscreen wiper spray. Vehicle is 4 years old and travelled 60000 kms. I have had a look at the 2 spray heads (just under the bonnet) and there appears to be electrical wires plus the water pipe going into each one.
Do they each have a pump?
If someone can tell me how to check out the system i would be grateful!
Many Thanks, Jim
Reply With Quote
Ads by Google
  #2  
Old 12-05-2012, 07:29 AM
Dirtbag Dirtbag is offline
Registered User
Location: Montana
 
Join Date: Nov 2012
Posts: 38
Mein Auto: 04 Duramax 09 BMW X5
Jim, could it be a problem with hard water? ie: maybe the nozzles are partially clogged. I have not looked at them(new owner, still trying to figure everything on the inside!)but if they are soaking them in vinegar should clear them.
Reply With Quote
  #3  
Old 12-05-2012, 07:56 AM
smyles smyles is offline
Officially Welcomed to the 'Fest
Location: DC
 
Join Date: Dec 2011
Posts: 588
Mein Auto: X5
The wires are for nozzles heating. I'd say the pump is to blame.
Reply With Quote
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > X Series > X5 E70 (2007 - 2013)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 10:26 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms