Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > Z Series > E89 Z4 (2009 - current)

E89 Z4 (2009 - current)

 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
  #1  
Old 12-05-2012, 04:05 PM
jcm12 jcm12 is offline
Officially Welcomed to the 'Fest
Location: Wickliffe, KY
 
Join Date: Dec 2011
Posts: 319
Mein Auto: 2012 Z4 35i--2002 330ci
Bad Knock Sensor??????

About 400 miles ago I got the attached CEL and my car (2012 35i) went into limp mode. Immediately called the Dealership and as I stopped and restarted the car the light went away. Today, with mileage barely over 3000 I got same CEL and it stayed a while longer. I called same dealer and told them I wanted my car in within the next day or so and they told me if it was out of limp mode to bring it in then. Approximtely 25 miles away. Was given a 2013 X5 as a loaner and told them the soonest I could get their car back would be Monday. Service person just called (about 5:30 pm our time) and i was told I had a bad Knock Sensor and part would be in Friday. Anybody ever experience this or know anything about an issue like this?
Attached Thumbnails
Click image for larger version

Name:	IMG_0266.jpg
Views:	64
Size:	71.5 KB
ID:	352069  
Reply With Quote
Ads by Google
 

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > Z Series > E89 Z4 (2009 - current)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



Forum Jump


All times are GMT -7. The time now is 11:17 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms