Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 3 Series / 4 Series > E46 (1999 - 2006)

E46 (1999 - 2006)
The fourth generation 3 Series (E46 chassis) was introduced in 1999 and set the standard for engineering and performance during it's years of production including being named to Car & Driver's 10 best list every one of those years! ! -- View the E46 Wiki

 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
  #1  
Old 12-07-2012, 08:24 AM
JoshBosh JoshBosh is offline
Registered User
Location: Arlingotn, VA
 
Join Date: Jul 2007
Posts: 28
Mein Auto: 1994 BM
Problem with aftermarket head unit

I bought my 2002 BMW 325ci with an aftermarket Pioneer head unit already installed but no steering wheel control module. I decided to install one myself. Got everything hooked up with the battery disconnected, reconnected the battery, programmed the SWC unit, and everything worked great.

Then I made a mistake. I forgot to disconnect the battery before pushing the wiring harness and head unit back into its slot. As I was doing so, I heard some odd noises and then the sound cut off. Head unit was still getting power, just mo sound. I kicked myself for not disconnecting the battery and proceeded to check all fuses. No blown fuses in the glove box or on the head unit.

After checking fuses, I tried to turn it back on and now there is no power to the head unit.

Fuses 7 and 41 are good, tried switching with others.

Please help. Did I fry something? Hidden fuse somewhere?

Help is much appreciated.
Reply With Quote
Advertisement
 

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 3 Series / 4 Series > E46 (1999 - 2006)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 05:15 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms