Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > The Best of Bimmerfest! > BMW Coding and Programming

BMW Coding and Programming
Discuss coding options and features on your BMW here.

Reply
 
Thread Tools Display Modes
  #1  
Old 12-08-2012, 05:28 AM
tissot tissot is offline
Registered User
Location: net
 
Join Date: Aug 2012
Posts: 37
Mein Auto: 528
Help! files with green marks disappear from SVT section.

Hi,
I tried to revert to orignal, but something goes wrong.
Now, some files from SVT section disappeared, I haven't got ACSM, KAFAS, and some others...
I have these catalogues (ACSM, KAFAS) but inside are only files with grey mark.
I have many errors on the dash, airbags, seatbelts, ASR, EDC...
I don't know what has happend. Probably I have to go to dealer but I don't even know what to tell them.
I have CAF files backuped, but I can't use them, because I can't right click on file with green mark as I don't have it.
please help.
Attached Thumbnails
Click image for larger version

Name:	nasM5F10esys.jpg
Views:	84
Size:	223.8 KB
ID:	352327  

Last edited by tissot; 12-08-2012 at 05:31 AM.
Reply With Quote
Ads by Google
  #2  
Old 12-08-2012, 07:45 AM
cn555ic cn555ic is offline
The Coder guy in N.Y
Location: New York, Brooklyn
 
Join Date: Mar 2012
Posts: 421
Mein Auto: bmw
http://www.bimmerfest.com/forums/sho...d.php?t=653389
Reply With Quote
  #3  
Old 12-08-2012, 09:43 PM
shawnsheridan's Avatar
shawnsheridan shawnsheridan is online now
Officially Welcomed to the 'Fest
Location: Houston, TX
 
Join Date: Jan 2009
Posts: 8,683
Mein Auto: 2011 535i M-Sport
Quote:
Originally Posted by tissot View Post
Hi,
I tried to revert to orignal, but something goes wrong.
Now, some files from SVT section disappeared, I haven't got ACSM, KAFAS, and some others...
I have these catalogues (ACSM, KAFAS) but inside are only files with grey mark.
I have many errors on the dash, airbags, seatbelts, ASR, EDC...
I don't know what has happend. Probably I have to go to dealer but I don't even know what to tell them.
I have CAF files backuped, but I can't use them, because I can't right click on file with green mark as I don't have it.
please help.
I think I can help you, but just so I am clear, you have many ECU's that are still in your SVT, but they are missing their CAFD, so you can't FDL Code, nor can you right-click => NEW to restore your saved CAFD.

Is that right?

Besides ACSM and KAFAS, what other modules are in this condition? Keep in mind this is normal for RDC and ZGW modules as they do not contain coding data.

Where are you located?
__________________

- 2011 535i M-Sport (Born 10/10) - AW/BLK/DW - /ZMP (w/ARS, EDC, DHP, & AD) /ZPP /ZP2 (w/ZPS & ZPT) /ZCV (w/SCAD) /6FL /6VC
- Mods - 2TB SAT / 6WB MFID Cluster / 4U1 Ceramic Controls / 6NR BMW Apps / Rear Fog Lights / Cyba Double Layer Black Chrome Quad Tips
Reply With Quote
  #4  
Old 12-09-2012, 06:58 AM
tissot tissot is offline
Registered User
Location: net
 
Join Date: Aug 2012
Posts: 37
Mein Auto: 528
Quote:
Originally Posted by shawnsheridan View Post
you have many ECU's that are still in your SVT, but they are missing their CAFD, so you can't FDL Code, nor can you right-click => NEW to restore your saved CAFD.
Is that right?
Yes, exactly. Even if I could click NEW, I don't know wich CAFD file fits to each ECU.

I attached my SVT view, report after read all ECU's with 1 fault, and view after reading, there is no VIN numer beside missing ECU's files. Also fault list and my backuped CAFD files.
Missing ECU's files: ACSM, AMP, GWS, KAFAS, PDC, RK[a6], SM, ZGW
I think these ECU's that I modified ever, although I don't remember RK, SM.
Quote:
Originally Posted by shawnsheridan View Post
Where are you located?
far, far... Poland.
Shawn you are my last hope
Attached Thumbnails
Click image for larger version

Name:	SVT view.jpg
Views:	45
Size:	80.3 KB
ID:	352456   Click image for larger version

Name:	after read.jpg
Views:	49
Size:	128.2 KB
ID:	352457   Click image for larger version

Name:	faults.jpg
Views:	59
Size:	95.5 KB
ID:	352458   Click image for larger version

Name:	my CAFD files.jpg
Views:	43
Size:	188.5 KB
ID:	352459  
Attached Files
File Type: pdf report.pdf (66.9 KB, 86 views)

Last edited by tissot; 12-09-2012 at 07:04 AM.
Reply With Quote
  #5  
Old 12-09-2012, 07:47 AM
shawnsheridan's Avatar
shawnsheridan shawnsheridan is online now
Officially Welcomed to the 'Fest
Location: Houston, TX
 
Join Date: Jan 2009
Posts: 8,683
Mein Auto: 2011 535i M-Sport
Quote:
Originally Posted by tissot View Post
Yes, exactly. Even if I could click NEW, I don't know wich CAFD file fits to each ECU.

I attached my SVT view, report after read all ECU's with 1 fault, and view after reading, there is no VIN numer beside missing ECU's files. Also fault list and my backuped CAFD files.
Missing ECU's files: ACSM, AMP, GWS, KAFAS, PDC, RK[a6], SM, ZGW
I think these ECU's that I modified ever, although I don't remember RK, SM.

far, far... Poland.
Shawn you are my last hope
Ok. For each ECU missing a CAFD, I want to to highlight the ECU, and select Detect CAF for SWE. A window will pop up, and you can select a CAFD. Pick anyone of them at this point. It will put CAFD under ECU. Then click on the CAFD, and select NEW, and use you backed up .ncd file, then FDL code the module. Do this for every module you have no CAFD for.
__________________

- 2011 535i M-Sport (Born 10/10) - AW/BLK/DW - /ZMP (w/ARS, EDC, DHP, & AD) /ZPP /ZP2 (w/ZPS & ZPT) /ZCV (w/SCAD) /6FL /6VC
- Mods - 2TB SAT / 6WB MFID Cluster / 4U1 Ceramic Controls / 6NR BMW Apps / Rear Fog Lights / Cyba Double Layer Black Chrome Quad Tips
Reply With Quote
  #6  
Old 12-09-2012, 08:09 AM
shawnsheridan's Avatar
shawnsheridan shawnsheridan is online now
Officially Welcomed to the 'Fest
Location: Houston, TX
 
Join Date: Jan 2009
Posts: 8,683
Mein Auto: 2011 535i M-Sport
Since you do not know which .ncd goes with each ECU, do you know what I-Level is on your car?

You can go under VCM and read your I-Step. What it shows for your I-Step (Current) is your current Integration Level.

Now when you run "Detect CAF for SWE", each CAFD shown is associated with an I-Level, so select the CAFD file that matches your I-Level.
__________________

- 2011 535i M-Sport (Born 10/10) - AW/BLK/DW - /ZMP (w/ARS, EDC, DHP, & AD) /ZPP /ZP2 (w/ZPS & ZPT) /ZCV (w/SCAD) /6FL /6VC
- Mods - 2TB SAT / 6WB MFID Cluster / 4U1 Ceramic Controls / 6NR BMW Apps / Rear Fog Lights / Cyba Double Layer Black Chrome Quad Tips
Reply With Quote
  #7  
Old 12-09-2012, 11:57 AM
tissot tissot is offline
Registered User
Location: net
 
Join Date: Aug 2012
Posts: 37
Mein Auto: 528
Thank you very, very much.
Unfortunatly it works only on AMP, KAFAS, PDC, SM.
In others ACSM, GWS, RK[a6], after "code FDL" I have errors, I attached report. Maybe in this ECU's should be more files? I saw on same printscreens that in ACSM are 3 files with green marks. But I don't know how to load more than 1 file.
I tried load files in diferent sequence. I checked everything twice.
Attached Files
File Type: pdf ACSM error.pdf (61.6 KB, 61 views)

Last edited by tissot; 12-09-2012 at 12:08 PM.
Reply With Quote
  #8  
Old 12-09-2012, 12:24 PM
shawnsheridan's Avatar
shawnsheridan shawnsheridan is online now
Officially Welcomed to the 'Fest
Location: Houston, TX
 
Join Date: Jan 2009
Posts: 8,683
Mein Auto: 2011 535i M-Sport
Quote:
Originally Posted by tissot View Post
Thank you very, very much.
Unfortunatly it works only on AMP, KAFAS, PDC, SM.
In others ACSM, GWS, RK[a6], after "code FDL" I have errors, I attached report. Maybe in this ECU's should be more files? I saw on same printscreens that in ACSM are 3 files with green marks. But I don't know how to load more than 1 file.
I tried load files in diferent sequence. I checked everything twice.
Try this now. VO Code ACSM, GWS, RK[a6]. Right-click on each ECU itself, not the underlying CAFD, and selct CODE.

See if that works.
__________________

- 2011 535i M-Sport (Born 10/10) - AW/BLK/DW - /ZMP (w/ARS, EDC, DHP, & AD) /ZPP /ZP2 (w/ZPS & ZPT) /ZCV (w/SCAD) /6FL /6VC
- Mods - 2TB SAT / 6WB MFID Cluster / 4U1 Ceramic Controls / 6NR BMW Apps / Rear Fog Lights / Cyba Double Layer Black Chrome Quad Tips
Reply With Quote
  #9  
Old 12-09-2012, 12:32 PM
shawnsheridan's Avatar
shawnsheridan shawnsheridan is online now
Officially Welcomed to the 'Fest
Location: Houston, TX
 
Join Date: Jan 2009
Posts: 8,683
Mein Auto: 2011 535i M-Sport
Quote:
Originally Posted by tissot View Post
Thank you very, very much.
Unfortunatly it works only on AMP, KAFAS, PDC, SM.
In others ACSM, GWS, RK[a6], after "code FDL" I have errors, I attached report. Maybe in this ECU's should be more files? I saw on same printscreens that in ACSM are 3 files with green marks. But I don't know how to load more than 1 file.
I tried load files in diferent sequence. I checked everything twice.
My ACSM has 3 CAFD's, RK[a6] has 2 CAFD's, but GWS has only 1 CAFD.

When you did "Detect CAF for SWE", you should have used the Ctrl Key and tagged all the needed CAFD's at once for the appropriate I-Level, like attached picture.

If the VO Coding doesn't work, go back and add the missing CAFD's from the same I-Level you used to add the one CAFD.
Attached Thumbnails
Click image for larger version

Name:	Image%20003.jpg
Views:	49
Size:	247.5 KB
ID:	352530  
__________________

- 2011 535i M-Sport (Born 10/10) - AW/BLK/DW - /ZMP (w/ARS, EDC, DHP, & AD) /ZPP /ZP2 (w/ZPS & ZPT) /ZCV (w/SCAD) /6FL /6VC
- Mods - 2TB SAT / 6WB MFID Cluster / 4U1 Ceramic Controls / 6NR BMW Apps / Rear Fog Lights / Cyba Double Layer Black Chrome Quad Tips

Last edited by shawnsheridan; 12-09-2012 at 08:37 PM.
Reply With Quote
  #10  
Old 12-10-2012, 05:31 AM
tissot tissot is offline
Registered User
Location: net
 
Join Date: Aug 2012
Posts: 37
Mein Auto: 528
I did it
But I wonder if everything is ok. When I tried use "code FDL", I had errors. I highlighted ACSM and then clicked "code". After that I have normal files with green marks.
Then I cleared faults like in this thread:
http://www.bimmerfest.com/forums/sho...d.php?t=662901
They didn't deasapear after coding.
What is the difference between "code FDL" and "code"?
Shawn, what do you think, everything is in order?
Reply With Quote
  #11  
Old 12-10-2012, 06:42 AM
shawnsheridan's Avatar
shawnsheridan shawnsheridan is online now
Officially Welcomed to the 'Fest
Location: Houston, TX
 
Join Date: Jan 2009
Posts: 8,683
Mein Auto: 2011 535i M-Sport
Quote:
Originally Posted by tissot View Post
I did it
But I wonder if everything is ok. When I tried use "code FDL", I had errors. I highlighted ACSM and then clicked "code". After that I have normal files with green marks.
Then I cleared faults like in this thread:
http://www.bimmerfest.com/forums/sho...d.php?t=662901
They didn't deasapear after coding.
What is the difference between "code FDL" and "code"?
Shawn, what do you think, everything is in order?
It's not clear to me what you have now.

Do all of your ECU's have CAFD's with Green dot (except non-coding ones)?

Are you getting any errors now in E-Sys when FDL coding any ECU?

What errors are showing on the car?
__________________

- 2011 535i M-Sport (Born 10/10) - AW/BLK/DW - /ZMP (w/ARS, EDC, DHP, & AD) /ZPP /ZP2 (w/ZPS & ZPT) /ZCV (w/SCAD) /6FL /6VC
- Mods - 2TB SAT / 6WB MFID Cluster / 4U1 Ceramic Controls / 6NR BMW Apps / Rear Fog Lights / Cyba Double Layer Black Chrome Quad Tips
Reply With Quote
  #12  
Old 12-10-2012, 06:53 AM
tissot tissot is offline
Registered User
Location: net
 
Join Date: Aug 2012
Posts: 37
Mein Auto: 528
All ECU's have CAFD with green dot.
I haven't errors on the car, everything works properly. Faults deasapear after use TOOL32.EXE.
Today, after work, I will check everything carefully. I will try to make some changes (dvd in motion, seat belt ring). Then I will use "code FDL" on all ECUs.
Reply With Quote
  #13  
Old 12-10-2012, 07:01 AM
shawnsheridan's Avatar
shawnsheridan shawnsheridan is online now
Officially Welcomed to the 'Fest
Location: Houston, TX
 
Join Date: Jan 2009
Posts: 8,683
Mein Auto: 2011 535i M-Sport
Quote:
Originally Posted by tissot View Post
All ECU's have CAFD with green dot.
I haven't errors on the car, everything works properly. Faults deasapear after use TOOL32.EXE.
Today, after work, I will check everything carefully. I will try to make some changes (dvd in motion, seat belt ring). Then I will use "code FDL" on all ECUs.
Ok. Sounds to me as if all your problems are solved. PM me your address so I can send an Invoice.

After this "trauma", I would VO Code (CODE), not CODE FDL, every ECU, before I FDL Coded anything.
__________________

- 2011 535i M-Sport (Born 10/10) - AW/BLK/DW - /ZMP (w/ARS, EDC, DHP, & AD) /ZPP /ZP2 (w/ZPS & ZPT) /ZCV (w/SCAD) /6FL /6VC
- Mods - 2TB SAT / 6WB MFID Cluster / 4U1 Ceramic Controls / 6NR BMW Apps / Rear Fog Lights / Cyba Double Layer Black Chrome Quad Tips
Reply With Quote
  #14  
Old 12-10-2012, 11:36 PM
tissot tissot is offline
Registered User
Location: net
 
Join Date: Aug 2012
Posts: 37
Mein Auto: 528
!!!!! Shawn THANK YOU VERY MUCH !!!!!!
Everything works perfect, no faults
Reply With Quote
  #15  
Old 12-11-2012, 02:26 AM
shawnsheridan's Avatar
shawnsheridan shawnsheridan is online now
Officially Welcomed to the 'Fest
Location: Houston, TX
 
Join Date: Jan 2009
Posts: 8,683
Mein Auto: 2011 535i M-Sport
__________________

- 2011 535i M-Sport (Born 10/10) - AW/BLK/DW - /ZMP (w/ARS, EDC, DHP, & AD) /ZPP /ZP2 (w/ZPS & ZPT) /ZCV (w/SCAD) /6FL /6VC
- Mods - 2TB SAT / 6WB MFID Cluster / 4U1 Ceramic Controls / 6NR BMW Apps / Rear Fog Lights / Cyba Double Layer Black Chrome Quad Tips
Reply With Quote
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > The Best of Bimmerfest! > BMW Coding and Programming
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 05:30 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms