Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 5 Series > E60 (2004 - 2010)

E60 (2004 - 2010)
BMW 5-Series (E60 chassis) was first seen in the Unites States in the fall of 2003 with a 2004 Model Year designation. The E60 is now available as a 528i, 528xi, 535i, 535xi, 550i and a 535xi sports wagon! -- View the E60 Wiki

Reply
 
Thread Tools Display Modes
  #1  
Old 12-12-2012, 01:47 AM
Aniq Aniq is offline
Registered User
Location: Pakistan
 
Join Date: Dec 2012
Posts: 2
Mein Auto: BMW 525i 2007
RPM sudden drop/ jerk at idle

I own a BMW 525i, 2007 (E60), done 41000 miles. At the cold start up takes the RPM to 1000 and then slowly starts coming down. At about 700 rpm it suddenly takes a sudden dip to below 500 and quickly jumps back to 600-or 700. Then its settles at 600 or about. The car also does the same when it is at idle say at a traffic signal. it can take a sudden jerk from 600-700 to below 500 and again back.

BMW service center insist that some sensor is to be changed. earlier they replaced the fuel sensor but it did not help. Now they want too change the NO2 sensor. Expensive proposition that is. Anyone who has the same experience and may have resolved it may advise.
Reply With Quote
Advertisement
  #2  
Old 12-12-2012, 02:23 AM
UltimateDriving UltimateDriving is offline
Officially Welcomed to the 'Fest
Location: Somewhere
 
Join Date: Oct 2007
Posts: 892
Mein Auto: A Car
I have a MY10 N52K engine that i don't drive a lot (17K Kilometers) and it does the same, although it does not drops as low as yours.
On the first 2 seconds of cold starts it usally has unstable idling between 1000RPM - 800RPM . . . just the first 2 seconds after that it idles fine.

Last edited by UltimateDriving; 12-12-2012 at 03:02 AM.
Reply With Quote
  #3  
Old 12-12-2012, 06:59 AM
DAI's Avatar
DAI DAI is offline
Gap Filler for a M6 GC?!?
Location: Wisconsin
 
Join Date: Dec 2007
Posts: 406
Mein Auto: '10 550i M-Sport
I had an '01 3-series with a similar problem years ago, and the dealer fixed it with a software update. 41 K seams low mileage to replace O2 sensors. If the car is not throwing codes, I'd be hesitant chasing sensors when paying for each one out of my own pocket.
Reply With Quote
  #4  
Old 12-14-2012, 01:41 AM
Aniq Aniq is offline
Registered User
Location: Pakistan
 
Join Date: Dec 2012
Posts: 2
Mein Auto: BMW 525i 2007
Well the BMW service centre only reelies on the computer diagnostic and that can throw up multiple codes.
Reply With Quote
  #5  
Old 12-14-2012, 04:27 AM
DAI's Avatar
DAI DAI is offline
Gap Filler for a M6 GC?!?
Location: Wisconsin
 
Join Date: Dec 2007
Posts: 406
Mein Auto: '10 550i M-Sport
Did they tell you what codes are coming up?
Reply With Quote
Reply

Bookmarks

Tags
525i, cold start, e60, idle problem, rpm drop


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 5 Series > E60 (2004 - 2010)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 01:40 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms