Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 3 Series / 4 Series > E36 (1991 - 1999)

E36 (1991 - 1999)
The E36 chassis 3-Series BMW was a huge hit among driving enthusiasts from the first moment the car hit the pavement. The E36 won numerous awards over the years it was produced and is still a favorite of many BMW enthusiasts to this day! -- View the E36 Wiki

 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
  #1  
Old 12-12-2012, 09:27 PM
ekoms ekoms is offline
Registered User
Location: AZ
 
Join Date: Nov 2011
Posts: 9
Mein Auto: 95 325is / 01 330ci
CEL, misfiring, sputtering, running like crap......help!

hello,
First off it an 95 325is 2.5 auto. yesterday the fuel pump died on me, so I installed a new one.
car started & ran/operated perfectly until around 4pm today. I did the pedal trick for the CEL & its giving an 1221 code & the car is now misfiring, sputtering, running like crap, & pretty much undriveable. I know that the 1221 code is referring to the primary o2 sensor. what else should I look into. fuel filter was replaced a month ago & it idles fine. once the petrol pedal is pressed it starts running rough, missing & sputtering.

thank you.
Reply With Quote
Advertisement
 

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 3 Series / 4 Series > E36 (1991 - 1999)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 07:56 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms