Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > Z Series > E36/7 Z3 (1996-2002)

E36/7 Z3 (1996-2002)
E36/7 Z3 Roadster, Z3 coupe, Z3 M Roadster and Z3 M Coupe talk with our gurus here.

Reply
 
Thread Tools Display Modes
  #1  
Old 12-22-2012, 11:26 AM
nitrydr1600 nitrydr1600 is offline
Registered User
Location: michigan
 
Join Date: Dec 2012
Posts: 35
Mein Auto: 1997 z3, 1982 corvette
97 z3 1.9

just bought this car with blown head gasket. repaired that and car is hard to start. restarts are terrible and have to let it sit for a hour sometimes. also clicking noise sounds like comming from intake area. first bmw and im lost. Im sure o2 senser is probably bad from coolant on it. ANY help or advise would be great. thanks
Reply With Quote
Advertisement
  #2  
Old 12-22-2012, 04:08 PM
marty505 marty505 is offline
Officially Welcomed to the 'Fest
Location: New Mexico
 
Join Date: Nov 2012
Posts: 151
Mein Auto: 99 Z3 M Coupe/99 540i
Did you do the head gasket yourself or pay someone? That it runs is a good sign, but there are many things that could go wrong when replacing the head gasket that could cause trouble. Getting one of the cams off by a tooth comes to mind first but injectors not hooked up right, crimped fuel line. big air leak, MAF sensor not working properly, there are a lot of possible culprits. How about the plugs? have you pulled them and looked at them, and maybe run a compression test while you're there?
Reply With Quote
  #3  
Old 12-22-2012, 04:29 PM
nitrydr1600 nitrydr1600 is offline
Registered User
Location: michigan
 
Join Date: Dec 2012
Posts: 35
Mein Auto: 1997 z3, 1982 corvette
bought car not running and cam gears are correct. it will start and run but seems like when its warm its almost flooded . dont smell fuel but wont fire unless it sets for 2 hours. regulater perhaps????????? my first bmw and quite lost!
Reply With Quote
  #4  
Old 12-22-2012, 05:45 PM
vintage42's Avatar
vintage42 vintage42 is offline
BMW CCA 1405
Location: Louisville, KY
 
Join Date: Jun 2007
Posts: 1,547
Mein Auto: 1997 BMW Z3 1.9 5MT
You could buy an inexpensive code reader, or if the car will make it, go to an auto supply shop that will read the codes. The codes might be a good place to start seeing what the engine is complaining about.
I bought this reader from Amazon:
http://www.amazon.com/gp/product/B00...ls_o00_s00_i00
Reply With Quote
  #5  
Old 12-22-2012, 06:05 PM
nitrydr1600 nitrydr1600 is offline
Registered User
Location: michigan
 
Join Date: Dec 2012
Posts: 35
Mein Auto: 1997 z3, 1982 corvette
thanks for the link. i just bought 1 myself. appreciate the help
Reply With Quote
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > Z Series > E36/7 Z3 (1996-2002)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 08:16 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms