Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 3 Series / 4 Series > E46 (1999 - 2006)

E46 (1999 - 2006)
The fourth generation 3 Series (E46 chassis) was introduced in 1999 and set the standard for engineering and performance during it's years of production including being named to Car & Driver's 10 best list every one of those years! ! -- View the E46 Wiki

 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
  #1  
Old 12-26-2012, 01:17 PM
sun3301 sun3301 is offline
Officially Welcomed to the 'Fest
Location: Silicon Valley
 
Join Date: Jul 2004
Posts: 136
Mein Auto: 2001 330ci Ti Silver
Question Accidentally drove with low oil levels

Guys, I have the common yellow oil level light come on at start-up and then go out on my 2001 330ci, 5 speed. The sender unit is bad. I had the car in the dealer last year for some work and they saw the light was coming on even after they changed the oil. But didn't change the unit because they had just buttoned it up.

So the car has about 7 thousand miles on from that oil change. Because I was so busy recently, I didn't check the oil till yesterday and saw that I was below the dipstick! I added a quart and that got the oil level up to the stick, but halway, so I need another 1/2 quart of so.

I know its my fault for not checking, but I hope I didn't do any permanant damage to the engine. With the oil level sensor being questionable, hopefully it not turning red meant that oil pressure levels were still at the ragged minimum before I added the oil. The engine sure sounds better. But I didn't have any issues before I added oil, except at highway speeds I could hear some noise that I thought was tire noise. The engine has 86,000 miles on it and driven for most part very easily by this original owner. No jack rabbit starts and speeds at 65 when no traffic.

I may for the first time change the oil myself on this car and do the sending unit too. I've changed the oil regularly on my vintage Mustang myself, but not on this car. It scares me a bit!

Thanks for any insight. I hope the engine is pretty tolerable to the low oil level.
Reply With Quote
Advertisement
 

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 3 Series / 4 Series > E46 (1999 - 2006)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 12:32 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms