Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 3 Series / 4 Series > E90/E91/E92/E93 (2006 - 2013)

E90/E91/E92/E93 (2006 - 2013)
The E9X is the 4th evolution of the BMW 3 series including a highly tuned twin turbo 335i variant pushing out 300hp and 300 ft. lbs. of torque. BMW continues to show that it sets the bar for true driving performance! -- View the E9X Wiki

Reply
 
Thread Tools Display Modes
  #1  
Old 12-06-2012, 05:57 AM
brewder brewder is online now
Officially Welcomed to the 'Fest
Location: Allentown PA Area
 
Join Date: May 2010
Posts: 630
Mein Auto: 2011 328i xDrive
RPM dip and dive

Hello,

I have a 2007 E92 with 114k miles on the odo. I recently replaced the plugs around 90k miles..... This week I was on a long (500+ mile) trip and got off the interstate after about 3+ hours of continual driving. While sitting at the light, my car started to shake/shudder and the RPM guage was dipping from it's normal idle of 650rmp to below 500..

The car has never done this before and is fairly well maintained... It occassionally will shake a little just after it's been started especially after sitting all night in the cold.

I know ignition coils should be able to last until ~150k miles, but does anyone think this could be the issue??

Or could it be something like the "winter gas" switch over??

ps... I also use a bottle or two of Techron roughly every 3k miles... last usage probably 2k miles ago.

//Brew
__________________
//Brew...KCCO

('11 E92 328i xDrive - Deep Sea Blue | '07 E92 328xi - Space Gray)
Reply With Quote
Advertisement
  #2  
Old 12-06-2012, 06:39 AM
CALWATERBOY's Avatar
CALWATERBOY CALWATERBOY is offline
Officially Welcomed to the 'Fest
Location: San Francisco
 
Join Date: Aug 2009
Posts: 10,007
Mein Auto: 2009 E93 N54
Quote:
Originally Posted by brewder View Post
Hello,

I have a 2007 E92 with 114k miles on the odo. I recently replaced the plugs around 90k miles..... This week I was on a long (500+ mile) trip and got off the interstate after about 3+ hours of continual driving. While sitting at the light, my car started to shake/shudder and the RPM guage was dipping from it's normal idle of 650rmp to below 500..

The car has never done this before and is fairly well maintained... It occassionally will shake a little just after it's been started especially after sitting all night in the cold.

I know ignition coils should be able to last until ~150k miles, but does anyone think this could be the issue??

Or could it be something like the "winter gas" switch over??

ps... I also use a bottle or two of Techron roughly every 3k miles... last usage probably 2k miles ago.

It could be something like....a need to read codes to know where to start.

Do that / have it done; c'mon back....
Reply With Quote
  #3  
Old 12-07-2012, 06:19 AM
brewder brewder is online now
Officially Welcomed to the 'Fest
Location: Allentown PA Area
 
Join Date: May 2010
Posts: 630
Mein Auto: 2011 328i xDrive
Quote:
Originally Posted by CALWATERBOY View Post
It could be something like....a need to read codes to know where to start.

Do that / have it done; c'mon back....
Yeeeaaahh... I really need to break down and buy me that Bav Tech tool one of these days... I always assume that codes are thrown only when one of the idiot lights shines on the dash, but I know that's not true.

oh well, thanks for the reminder!
__________________
//Brew...KCCO

('11 E92 328i xDrive - Deep Sea Blue | '07 E92 328xi - Space Gray)
Reply With Quote
  #4  
Old 12-07-2012, 01:17 PM
fb88 fb88 is offline
Officially Welcomed to the 'Fest
Location: NJ
 
Join Date: Sep 2011
Posts: 624
Mein Auto: 2014 X1 xDrive28i
114k and you never replaced ignition coil? eventually Check Engine light would come on for misfire code if it's ignition coil, but that should be a permanent rough drive and not come and go.
Perhaps it's related to your spark plugs change.
Reply With Quote
  #5  
Old 12-08-2012, 03:25 PM
Ilovemycar Ilovemycar is offline
wooohooo
Location: CA
 
Join Date: Feb 2010
Posts: 2,742
Mein Auto: '08 335i coupe 6MT sport
I cannot help you resolve your issue, and I do wish you luck in figuring out what it was. However, I'd like to say that DSX warned me about the use of Techron, saying something like it is a strong medicine: only use it when you really have a need for it. Therefore, I have no plans to ever use it again, unless someone who knows what they're talking about recommends its use for whatever particular reason that may arise in the future.
Reply With Quote
  #6  
Old 12-08-2012, 04:59 PM
Bimmer1995318ti's Avatar
Bimmer1995318ti Bimmer1995318ti is offline
Officially Welcomed to the 'Fest
Location: Indiana
 
Join Date: Oct 2012
Posts: 150
Mein Auto: 1995 bimmer 318ti
What is techtron used for ?
Reply With Quote
  #7  
Old 12-08-2012, 05:54 PM
CALWATERBOY's Avatar
CALWATERBOY CALWATERBOY is offline
Officially Welcomed to the 'Fest
Location: San Francisco
 
Join Date: Aug 2009
Posts: 10,007
Mein Auto: 2009 E93 N54
Quote:
Originally Posted by Bimmer1995318ti View Post
What is techtron used for ?

Cleans injectors.
Reply With Quote
  #8  
Old 12-08-2012, 08:18 PM
fb88 fb88 is offline
Officially Welcomed to the 'Fest
Location: NJ
 
Join Date: Sep 2011
Posts: 624
Mein Auto: 2014 X1 xDrive28i
BMW Group Fuel System Cleaner Plus. SI B 13 05 06
PN 82 14 0 413 341

bmwcca.org editor recommends every 3k to 5k miles. I have not used in my car of 134k miles.

Since you are experiencing the problem, try it once.
dump it into an empty tank before filling up
Reply With Quote
  #9  
Old 12-09-2012, 06:05 AM
MP3_E46's Avatar
MP3_E46 MP3_E46 is offline
Code/wrench Monkey
Location: Atlanta
 
Join Date: Oct 2003
Posts: 1,044
Mein Auto: Miata NC2
Spend $24 to pull codes: http://www.amazon.com/gp/product/B005NLQAHS

Quote:
Originally Posted by brewder View Post
Hello,It occassionally will shake a little just after it's been started especially after sitting all night in the cold.
Mine does that at 11K miles. Unsure of the issue; I had guessed at the battery but that seems fine after charging with a CTEK. Current guess is moisture accumulating somewhere
__________________


Six Euro Deliveries since December 1998 (Owned E46, E90, E91, E92 and E93)

28 vehicles in 26 years of driving so far. Guess I like cars

Last edited by MP3_E46; 12-09-2012 at 06:12 AM.
Reply With Quote
  #10  
Old 12-09-2012, 09:59 AM
Bimmer1995318ti's Avatar
Bimmer1995318ti Bimmer1995318ti is offline
Officially Welcomed to the 'Fest
Location: Indiana
 
Join Date: Oct 2012
Posts: 150
Mein Auto: 1995 bimmer 318ti
Try cleaning your icv and maf
Reply With Quote
  #11  
Old 12-09-2012, 10:06 AM
Bimmer1995318ti's Avatar
Bimmer1995318ti Bimmer1995318ti is offline
Officially Welcomed to the 'Fest
Location: Indiana
 
Join Date: Oct 2012
Posts: 150
Mein Auto: 1995 bimmer 318ti
Oh wait,..., nvm about that!
Reply With Quote
  #12  
Old 12-22-2012, 01:09 PM
brewder brewder is online now
Officially Welcomed to the 'Fest
Location: Allentown PA Area
 
Join Date: May 2010
Posts: 630
Mein Auto: 2011 328i xDrive
Quote:
Originally Posted by CALWATERBOY View Post
It could be something like....a need to read codes to know where to start.

Do that / have it done; c'mon back....
Pulled the codes... got nothing... No errors have been logged...
__________________
//Brew...KCCO

('11 E92 328i xDrive - Deep Sea Blue | '07 E92 328xi - Space Gray)
Reply With Quote
  #13  
Old 12-23-2012, 08:10 PM
mike in texas's Avatar
mike in texas mike in texas is offline
Mike in Texas
Location: Rosenberg, Texas
 
Join Date: May 2007
Posts: 232
Mein Auto: 2007 328i coupe
your comment about moisture makes sense because the last time I had this issue is after I washed my car with a power washer.
Have you learned anything new about his issue.
__________________

07 - 328i Coupe
Reply With Quote
  #14  
Old 12-24-2012, 06:23 AM
brewder brewder is online now
Officially Welcomed to the 'Fest
Location: Allentown PA Area
 
Join Date: May 2010
Posts: 630
Mein Auto: 2011 328i xDrive
Quote:
Originally Posted by mike in texas View Post
your comment about moisture makes sense because the last time I had this issue is after I washed my car with a power washer.
Have you learned anything new about his issue.
MiT: No I haven't.... I'm wondering if the battery may be starting to fail? It's still original and I know some days (cold days) it seems to struggle ever so slightly when starting the car...

My driving "pattern" is roughly 2 long (500+ mile) trips per month with a majority of that non-stop giving the battery a good long charge each month... But still, it could finally be starting to show it's age and generating some odd gremlins.
__________________
//Brew...KCCO

('11 E92 328i xDrive - Deep Sea Blue | '07 E92 328xi - Space Gray)
Reply With Quote
  #15  
Old 12-29-2012, 03:54 AM
MP3_E46's Avatar
MP3_E46 MP3_E46 is offline
Code/wrench Monkey
Location: Atlanta
 
Join Date: Oct 2003
Posts: 1,044
Mein Auto: Miata NC2
As mentioned above the root cause could one or a combination of many factors. A new battery resolved the same issue in my low mileage car though
__________________


Six Euro Deliveries since December 1998 (Owned E46, E90, E91, E92 and E93)

28 vehicles in 26 years of driving so far. Guess I like cars
Reply With Quote
  #16  
Old 12-29-2012, 06:22 AM
CALWATERBOY's Avatar
CALWATERBOY CALWATERBOY is offline
Officially Welcomed to the 'Fest
Location: San Francisco
 
Join Date: Aug 2009
Posts: 10,007
Mein Auto: 2009 E93 N54
Quote:
Originally Posted by brewder View Post
MiT: No I haven't.... I'm wondering if the battery may be starting to fail? It's still original and I know some days (cold days) it seems to struggle ever so slightly when starting the car...

My driving "pattern" is roughly 2 long (500+ mile) trips per month with a majority of that non-stop giving the battery a good long charge each month... But still, it could finally be starting to show it's age and generating some odd gremlins.

Your last walnut shell blast was....was....when?
Reply With Quote
  #17  
Old 12-29-2012, 06:23 AM
MP3_E46's Avatar
MP3_E46 MP3_E46 is offline
Code/wrench Monkey
Location: Atlanta
 
Join Date: Oct 2003
Posts: 1,044
Mein Auto: Miata NC2
Quote:
Originally Posted by CALWATERBOY View Post
Your last walnut shell blast was....was....when?
He has a 328i; a few doses of techron 'should' suffice
__________________


Six Euro Deliveries since December 1998 (Owned E46, E90, E91, E92 and E93)

28 vehicles in 26 years of driving so far. Guess I like cars
Reply With Quote
  #18  
Old 12-29-2012, 06:31 AM
CALWATERBOY's Avatar
CALWATERBOY CALWATERBOY is offline
Officially Welcomed to the 'Fest
Location: San Francisco
 
Join Date: Aug 2009
Posts: 10,007
Mein Auto: 2009 E93 N54
Quote:
Originally Posted by MP3_E46 View Post
He has a 328i; a few doses of techron 'should' suffice

Did that read "walnut shell blast?"

Frequently a victim of random hand spasms, I mis-posted. Shoulda read: "Vanos solenoid blast [air]."

Name:  Disoriented Smiley.jpg
Views: 155
Size:  1.8 KB
Reply With Quote
  #19  
Old 12-29-2012, 08:26 AM
MP3_E46's Avatar
MP3_E46 MP3_E46 is offline
Code/wrench Monkey
Location: Atlanta
 
Join Date: Oct 2003
Posts: 1,044
Mein Auto: Miata NC2
Quote:
Originally Posted by CALWATERBOY View Post
Did that read "walnut shell blast?"

Frequently a victim of random hand spasms, I mis-posted. Shoulda read: "Vanos solenoid blast [air]."
Was in a pinch at work yesterday and bought a can of compressed air from WalMart.. would have been so much more fun to bring in my Pancake Compressor and use that like I do at home
__________________


Six Euro Deliveries since December 1998 (Owned E46, E90, E91, E92 and E93)

28 vehicles in 26 years of driving so far. Guess I like cars
Reply With Quote
  #20  
Old 12-29-2012, 11:52 AM
bluskye bluskye is offline
Officially Welcomed to the 'Fest
Location: chicago
 
Join Date: Jul 2002
Posts: 786
Mein Auto: 2006 330i / 2007 X3
I've had issues with faulty IBS (Intelligent Battery Sensor) and low battery in the past, both very bizarre.

IBS failure: RPMs would drop dramatically during cruising as if the car lost electrical. Codes would read faulty Water Pump and IBS in this condition. The faulty water pump code was triggered because it lost electrical power (electric pump). Dealer replaced IBS and all is resolved.

Low battery - the bastard issue to nail down: Subtle rpm dips at idle/cold. HVAC fan would go in and out in really cold or really hot conditions. Yes, HVAC fan. I replaced fan/resistor thinking they were busted, but that was not the problem. Resolved with a new battery, in my case, Interstate Megatron Plus. These issues were resolved by mistake as I normally swap out batteries every 5 years or so I dont get stuck out in the cold.

These cars are dam sensitive to electrical glitches.

Last edited by bluskye; 12-29-2012 at 11:55 AM.
Reply With Quote
  #21  
Old 12-29-2012, 05:11 PM
MP3_E46's Avatar
MP3_E46 MP3_E46 is offline
Code/wrench Monkey
Location: Atlanta
 
Join Date: Oct 2003
Posts: 1,044
Mein Auto: Miata NC2
Quote:
Originally Posted by bluskye View Post
I've had issues with faulty IBS (Intelligent Battery Sensor) and low battery in the past, both very bizarre.

IBS failure: RPMs would drop dramatically during cruising as if the car lost electrical. Codes would read faulty Water Pump and IBS in this condition. The faulty water pump code was triggered because it lost electrical power (electric pump). Dealer replaced IBS and all is resolved.

Low battery - the bastard issue to nail down: Subtle rpm dips at idle/cold. HVAC fan would go in and out in really cold or really hot conditions. Yes, HVAC fan. I replaced fan/resistor thinking they were busted, but that was not the problem. Resolved with a new battery, in my case, Interstate Megatron Plus. These issues were resolved by mistake as I normally swap out batteries every 5 years or so I dont get stuck out in the cold.

These cars are dam sensitive to electrical glitches.
Ouch, your pain is felt!

So the conclusion is if your battery is at least three years old and these symptoms appear swap the battery out first. Cheap-ish easy DIY (~$100 from Walmart) that would need doing sooner or later anyway
__________________


Six Euro Deliveries since December 1998 (Owned E46, E90, E91, E92 and E93)

28 vehicles in 26 years of driving so far. Guess I like cars
Reply With Quote
  #22  
Old 12-30-2012, 06:07 AM
brewder brewder is online now
Officially Welcomed to the 'Fest
Location: Allentown PA Area
 
Join Date: May 2010
Posts: 630
Mein Auto: 2011 328i xDrive
Quote:
Originally Posted by CALWATERBOY View Post
Your last walnut shell blast was....was....when?
lol... ah never...
__________________
//Brew...KCCO

('11 E92 328i xDrive - Deep Sea Blue | '07 E92 328xi - Space Gray)
Reply With Quote
  #23  
Old 12-30-2012, 06:10 AM
brewder brewder is online now
Officially Welcomed to the 'Fest
Location: Allentown PA Area
 
Join Date: May 2010
Posts: 630
Mein Auto: 2011 328i xDrive
Quote:
Originally Posted by CALWATERBOY View Post
Did that read "walnut shell blast?"

Frequently a victim of random hand spasms, I mis-posted. Shoulda read: "Vanos solenoid blast [air]."

Attachment 355041
Ahhh now THAT I have had done.. It was at 59,200 on the odo.
__________________
//Brew...KCCO

('11 E92 328i xDrive - Deep Sea Blue | '07 E92 328xi - Space Gray)
Reply With Quote
  #24  
Old 12-30-2012, 06:33 AM
CALWATERBOY's Avatar
CALWATERBOY CALWATERBOY is offline
Officially Welcomed to the 'Fest
Location: San Francisco
 
Join Date: Aug 2009
Posts: 10,007
Mein Auto: 2009 E93 N54
Quote:
Originally Posted by brewder View Post
Ahhh now THAT I have had done.. It was at 59,200 on the odo.

OD's now 114K - time for another dose.

Inexpensive multimeter reads battery voltage after lights on awhile.....<12 volts?




YO! If you got that guy's problem, assault your battery, an inconvenient R&R in the German tradition.

Bavarian Technic scan tool will enable you to register your battery. Among many, many other things....GET ONE.

I LOVE the smell of a DIY on a frosty December morn....

Name:  Chilly.gif
Views: 393
Size:  5.7 KB

.

Last edited by CALWATERBOY; 12-30-2012 at 07:09 AM.
Reply With Quote
  #25  
Old 12-30-2012, 07:33 AM
MP3_E46's Avatar
MP3_E46 MP3_E46 is offline
Code/wrench Monkey
Location: Atlanta
 
Join Date: Oct 2003
Posts: 1,044
Mein Auto: Miata NC2
Quote:
Originally Posted by CALWATERBOY View Post
OD's now 114K - time for another [URL="http://www.e90post.com/forums/showthread.php?t=486201&highlight=VANOS+solenoid+DIY"]Inexpensive multimeter reads battery voltage after lights on awhile.....<12 volts?
Good point. I did that with mine and it read low. Exact number is probably in a previous thread. Seems a sensible way to detect batteries like that mine that would charge to the correct voltage but not hold it for long

Ah, found it in the email to a local SA: it measured 11.7 V and indeed needed replacement
__________________


Six Euro Deliveries since December 1998 (Owned E46, E90, E91, E92 and E93)

28 vehicles in 26 years of driving so far. Guess I like cars
Reply With Quote
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 3 Series / 4 Series > E90/E91/E92/E93 (2006 - 2013)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 08:58 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms