Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > X Series > X5 E53 (1999 - 2006)

X5 E53 (1999 - 2006)
The X5 SAV Forum

Reply
 
Thread Tools Display Modes
  #1  
Old 05-19-2012, 02:05 AM
talaly talaly is offline
Registered User
Location: Bahrain
 
Join Date: Sep 2009
Posts: 3
Mein Auto: e46
Fuel level sender issue help plz

Hi all,
I have a problem and I hope some one can help, because I gave up.
I had a problem with my fuel level sowing it's empty.
I replaced the left level sensor and it works fine but only for 1 week as soon as the tunk got empty and I re fuller up the indecator stayed empty .
I opened the left fuel sensor shine and it was smashed broken like some one Brie it into two part, so I thought maybe it's because of an error in insttalation so I replaced it with another one and the same resault I had.
I asked some ppl and the told me it because of a high pressure.
I don't know what to do.
Please advice if any one had a similar issue.
Reply With Quote
Ads by Google
  #2  
Old 05-19-2012, 02:46 AM
tonywintn tonywintn is offline
Drivin' the dream
Location: Tennessee
 
Join Date: Jun 2009
Posts: 187
Mein Auto: 2005 BMW X5 & 2007 Z4 si
Have the tank's venting system checked. A blocked vent to atmosphere could be causing the tank to collapse when it cools overnight.
Reply With Quote
  #3  
Old 05-20-2012, 12:47 AM
talaly talaly is offline
Registered User
Location: Bahrain
 
Join Date: Sep 2009
Posts: 3
Mein Auto: e46
where dose it locate and is this got to do witht the fuel tank
Reply With Quote
  #4  
Old 05-20-2012, 02:57 AM
Mickeymotormoun Mickeymotormoun is offline
Registered User
Location: Quakertown Pa.
 
Join Date: May 2012
Posts: 3
Mein Auto: '06 X5
Hey Guys,
I'm a newbie here with the same issue as Talaly.

6 months ago I purchased a 2006 X5 for the wife. The car was well maintained by a BMW dealership and was in excellent condition. It's got the 3.0 liter engine and has 90,000 miles on it. It runs and handles like brand new and is a beautiful car.

About two months after I got it, the fuel guage reads empty. I have read that using low quality fuels can cause problems with the sending unit. I ran two full tanks with injection cleaner and switched to Shell gasoline hoping this would solve the problem but no luck.

Is there any way to determine which sending unit is bad before I purchase one? I don't feel like spending extra money buying the right hand sender with pump and the left sender as well.

I have also heard that the guage itself could be faulty. Is there any way to check this as well to verify that the guage is fine and the problem lies with one of the sending units?

Any light you guys could shed on this problem would be greatly appreciated. THANKS!!
Reply With Quote
  #5  
Old 05-20-2012, 05:37 AM
tonywintn tonywintn is offline
Drivin' the dream
Location: Tennessee
 
Join Date: Jun 2009
Posts: 187
Mein Auto: 2005 BMW X5 & 2007 Z4 si
If you have an Ohmmeter you can remove the rear seat, unplug the connectors on the tank lids on both sides. One side has 4 pins. Two are for the fuel pump, two for the level sender and the other side has two for the other level sender. If you see less than 1 ohm, that is the fuel pump pins. Fill your tank first so that you know the tank has fuel. Measure the resistance on each tank lid. If either one reads 980 ohms or higher, then something is wrong with that level sender. 980 ohms is the normal empty reading. If your gage on the dash reads empty all of the time, it could possibly be due to a faulty sender. The computer will drive the needle to empty if it detects a problem with either fuel sender. This ohm check will confirm which one or if even both are bad.
As for venting; fuel is like soda pop. It generates a vapor pressure. That pressure is vented through a carbon canister and then to atmosphere. The tank builds up a certain amount of pressure before it is vented. As the fuel heats up the pressure builds and gets vented through the canister. The charcoal captures the hydrocarbons and stores them until they can be burned off by the engine. Once the tanks cools the pressure drops inside the tank. Now venting must take place the other way. Air from the outside must enter into the tank so that the tank does not create a vacuum. It would be like canning tomatoes. You fill the jar and heat it, then seal the lid. After the jar cools it has a vacuum inside. The difference is your gas tank is made of a high density polyethylene, not rigid glass. So a vacuum can cause the tank to collapse and if severe enough, break the fuel pump/level sender components. That is why it is important that the venting system be clear of any obstructions. The vent pipe is mounted on the carbon canister in the rear of the car.
Reply With Quote
  #6  
Old 05-20-2012, 04:44 PM
Mickeymotormoun Mickeymotormoun is offline
Registered User
Location: Quakertown Pa.
 
Join Date: May 2012
Posts: 3
Mein Auto: '06 X5
Thanks for the info, Tonywintn. I have a digital ohmeter and will check it out as you said. I will also check the venting system as well. Much Obliged and best Regards.
Reply With Quote
  #7  
Old 10-04-2012, 08:53 PM
dallas320i dallas320i is offline
Registered User
Location: Sunny Isles, FL
 
Join Date: Apr 2010
Posts: 6
Mein Auto: 320i '99
Guys please let me know if anyone already solved this issue? What exactly need to be replaced in tank vent system? Tnx
Reply With Quote
  #8  
Old 10-31-2012, 02:45 PM
cj_lovely7 cj_lovely7 is offline
Registered User
Location: Kentucky
 
Join Date: Jun 2012
Posts: 10
Mein Auto: X5 4.8is
I have a 2004 BMW x5 and after a recent fuel pump replacement, I have the similar problem of my gas gauge not reading correctly. I actually ran out of gas twice because of this. My machanic has checked the pump and claims that everything is working correctly. I do have an instrument cluster that needs to be replaced and he is blaming this on the cluster. Does this sound right?Could a babd insrtument cluster cause my gas gauge to not work properly?..It will read full but will npot go down past half a tank..any suggestions..Please???????
Reply With Quote
  #9  
Old 01-02-2013, 10:07 PM
glhx glhx is offline
Registered User
Location: tennessee
 
Join Date: Jan 2012
Posts: 23
Mein Auto: bmw 330ci
Get a BMW scan tool 1.4.0. It has a gauges test. Cost me $40......it also tests everything else
Reply With Quote
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > X Series > X5 E53 (1999 - 2006)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 10:00 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms