Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 6 Series

6 Series
The BMW 6 Series builds on BMW's sporty heritage with aggressive lines and an incredible motor to back the design up. Available in coupe and convertible trims with a standard 4.8 liter engine producing 360 horsepower and 360 lb-ft of torque, the 6-series is a popular choice that exceeds expectations.

Reply
 
Thread Tools Display Modes
  #26  
Old 05-25-2011, 11:21 PM
moe007 moe007 is offline
Registered User
Location: toronto
 
Join Date: May 2011
Posts: 1
Mein Auto: 645ci
amp problem

Hello All,


I just experinced the exact same problem. It was raining a lot today and all of sudden my left driver speaker started to make loud noises, and then the noise went on to right pessenger speaker and then middle speaker started to make a little noise as well.

I went in the trunk and opened up everything where the amp was located and all I saw was WATER around the amp.

I have few questions.

1) currently none of my speakers are ****ing other then all my subs are working perfectly fine, any idea wat exact problem is it?

2) im guessing the amp is gone because of the drain problem, once i replace my logic7 amp, would I still have to replace the speakers, or sometimes after replacing the amp the speakers dont need to be replaced ?

3) if these cars were on recall for drain issue, shouldnt bmw replace the amp as well because it happend due to their mistake?


anyone knows any places to repair or get used logic7 amps in toronto area

i hope after replacing an expeinsve logic 7 amp, we dont have to replace the speakers?

someone please help me out.


Thanks in advance !

Last edited by moe007; 05-25-2011 at 11:35 PM.
Reply With Quote
  #27  
Old 05-25-2011, 11:52 PM
Yorgi's Avatar
Yorgi Yorgi is offline
Officially Welcomed to the 'Fest
Location: Toronto
 
Join Date: Mar 2005
Posts: 3,201
Mein Auto: '04 M3 / '06 650i Cab
1. - it's your amp
2. - the speakers should be fine, no need to replace them
3. - people have tried that and BMW will refuse to cover the amp. Would not hurt to try.

Read this amp thread to find some specialists that repair the logic 7 amp.

If you read some other amp threads, you may find a few more repair companies. I don't think there are any local shops in the GTA that will have experience with BMW amps. If you want to try a local electronics repair shop do a search on the canuckaudiomart forums for recommended shops. Any competent audio repair technician will be able to fix this amp. It might take him longer due to unfamiliarity (ie it will probably cost more) but you won't have to ship the unit. Amps are not that complicated.
__________________
Straight lines are for fast cars...turns are for fast drivers
'04 M3 - track
'06 650i Cab - daily driver
'02 Highlander - kid hauler
'01 330Ci - winter beater


Last edited by Yorgi; 05-26-2011 at 12:02 AM.
Reply With Quote
  #28  
Old 05-26-2011, 08:54 PM
gsxr906 gsxr906 is offline
Registered User
Location: Canada
 
Join Date: May 2011
Posts: 16
Mein Auto: 645ci e64
Quote:
Originally Posted by moe007 View Post
Hello All,


I just experinced the exact same problem. It was raining a lot today and all of sudden my left driver speaker started to make loud noises, and then the noise went on to right pessenger speaker and then middle speaker started to make a little noise as well.

I went in the trunk and opened up everything where the amp was located and all I saw was WATER around the amp.

I have few questions.

1) currently none of my speakers are ****ing other then all my subs are working perfectly fine, any idea wat exact problem is it?

2) im guessing the amp is gone because of the drain problem, once i replace my logic7 amp, would I still have to replace the speakers, or sometimes after replacing the amp the speakers dont need to be replaced ?

3) if these cars were on recall for drain issue, shouldnt bmw replace the amp as well because it happend due to their mistake?


anyone knows any places to repair or get used logic7 amps in toronto area

i hope after replacing an expeinsve logic 7 amp, we dont have to replace the speakers?

someone please help me out.


Thanks in advance !
I had the same problem with my car, I took out the amp, took it apart and cleaned off all the oxidation on the board. its in good working condition. But u will need to reset the system. there is a tread on this forum that tells u steps on the repair. took me 30mins for the R&R
Reply With Quote
  #29  
Old 11-19-2011, 04:34 PM
N60B44 N60B44 is offline
Account Under Review
Location: Emeryville, CA
 
Join Date: Aug 2010
Posts: 85
Mein Auto: 745i 2003
If anyone interested I can fix logic 7 amps for e60, e65, e54 etc
Reply With Quote
  #30  
Old 01-04-2013, 09:28 AM
chercom chercom is offline
Registered User
Location: Atlanta, georgia
 
Join Date: Jun 2011
Posts: 4
Mein Auto: Alpharetta
Guys, I have the same problem. I have a 2007 650i. When I called the dealer, he tells me that it's the amp. The guy didn't say a thing about the drainage problem. When I mentioned it, he say that BMW had a recall on the drains but couldn't tell me where my car was covered. The drive out cost for the replacement is $2500. My CPO warranty doesn't cover this.

So after reading you guys posting, I am going to try to replace the amp, with some help myself. I am a bit of a geek and think if there is no reprogramming involved should be able to pull it out and replace. With that said, can someone please point to me a link where I can find the installation guide.

Thanks kindly,
Reply With Quote
  #31  
Old 01-04-2013, 09:32 AM
chercom chercom is offline
Registered User
Location: Atlanta, georgia
 
Join Date: Jun 2011
Posts: 4
Mein Auto: Alpharetta
One last thing. Is there anyone in Georgia that know how replace the amp?
Reply With Quote
  #32  
Old 01-05-2013, 11:42 PM
Yorgi's Avatar
Yorgi Yorgi is offline
Officially Welcomed to the 'Fest
Location: Toronto
 
Join Date: Mar 2005
Posts: 3,201
Mein Auto: '04 M3 / '06 650i Cab
The amp can be repaired or replaced with any Logic 7 amp from a 7 series or 5 series.

There are a few threads on sub-forums for other models. Do a search.

Here are a few threads:
Sound SYS Amplifier Problem

E64 645ci 2004 Logic7 Amp replacement

DIY - Logic7 R&R Easy as pie 745i E65

Logic 7 amp replacement
__________________
Straight lines are for fast cars...turns are for fast drivers
'04 M3 - track
'06 650i Cab - daily driver
'02 Highlander - kid hauler
'01 330Ci - winter beater

Reply With Quote
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 6 Series
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 08:50 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms