Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > X Series > X5 E53 (1999 - 2006)

X5 E53 (1999 - 2006)
The X5 SAV Forum

 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
  #1  
Old 01-07-2013, 09:11 AM
nesram4biz nesram4biz is offline
Registered User
Location: Houston
 
Join Date: Feb 2009
Posts: 3
Mein Auto: X5 4.4i
Question Rough idling when cold, check engine light on

I have an '04 X5 4.4i with 120K miles. I had the 100K miles service warranty so it was pampered by the dealer during the first 100k. The check engine light is on (mostly steady but was flashing when idling is really bad), idling is rough when cold. Sometimes too rough that the engine dies or stops. When it's warmed up enough though it runs ok with a bit of hesitation at times. After it has reach "optimum" temperature (I guess when the needle points in middle), it runs great just like when I first bought it. Took it to an Autohaus shop (bimmer experts) and they say per their diagnostic tool all 8 cylinders have misfired at one time or another. I have replaced all plugs with recommended NGK plugs, oil and air filters, and the valve cover gasket (driver side only). I ended up replacing the ecentric valve shaft sensor as it was broken. Only mounting two bolts holding it to the engine. I still have the same symptoms, was discouragingly worst in the during the first 2 days after repair. It's gotten better but the darn check engine light is still on.

HELP! I am loosing faith on this X5 and am now thinking of getting rid of it .
Reply With Quote
Ads by Google
 

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > X Series > X5 E53 (1999 - 2006)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 03:33 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms