Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 7 Series / 8 Series > 7 Series - E65 / E66 (2002 - 2008)

7 Series - E65 / E66 (2002 - 2008)
Discussion pertaining to the flagship BMW here.

Reply
 
Thread Tools Display Modes
  #1  
Old 12-09-2012, 04:09 PM
10Go 10Go is offline
Welcomed to the 'Fest
Location: California
 
Join Date: Jun 2011
Posts: 71
Mein Auto: E65 745i
Idrive Message

Hello all.
So I got the car back from the dealer for my "recharge battery" message, radio that comes on at will and my transmission bumping and clunking along with this message in the idrive "The transmission automatically shifts into P when the car is switched off. Please contact your BMW center." They had the car for a week and all they did was replace the battery. The said they found no codes for the transmission.

Has anyone else had this message -"The transmission automatically shifts into P when the car is switched off. Please contact your BMW center." and if so how did you get The dealership to address it?
__________________
Regards,

Ten

745I
Slate Green Metallic___
Reply With Quote
Advertisement
  #2  
Old 12-09-2012, 04:31 PM
SuperSnoop's Avatar
SuperSnoop SuperSnoop is offline
Officially Welcomed to the 'Fest
Location: Austin, Texas
 
Join Date: Aug 2012
Posts: 559
Mein Auto: 2007 760Li
A bad battery can throw some strange messages. I would tend to believe them if that's all they said was wrong.
Reply With Quote
  #3  
Old 12-09-2012, 04:53 PM
10Go 10Go is offline
Welcomed to the 'Fest
Location: California
 
Join Date: Jun 2011
Posts: 71
Mein Auto: E65 745i
That's what madding. They replaced the battery and today that message came up on the Idrive again. I can't say it's a money game. I have a warranty on it but having had complained about this for the entire year I've have the 7 is frustrating.
__________________
Regards,

Ten

745I
Slate Green Metallic___
Reply With Quote
  #4  
Old 12-09-2012, 07:47 PM
SuperSnoop's Avatar
SuperSnoop SuperSnoop is offline
Officially Welcomed to the 'Fest
Location: Austin, Texas
 
Join Date: Aug 2012
Posts: 559
Mein Auto: 2007 760Li
Could be the alternator. The symptoms tend to be the same.
Reply With Quote
  #5  
Old 12-09-2012, 09:46 PM
Seven11's Avatar
Seven11 Seven11 is offline
President
Location: San Francisco
 
Join Date: Mar 2008
Posts: 8,023
Mein Auto: BMW
i always had that message, trans swicthes to P when car is off.. or something like that

thats normal... no need to worry about it, unless its doing something weird
__________________

'03 745i - modded - GONE -
'08 535i - Sport - Sport Trans - Navi - Comfort Seats - daily beater -
'07 GSXR-750 - Gray/Black - Akrapovic Ti Shorty Exhaust -
Reply With Quote
  #6  
Old 01-07-2013, 02:36 PM
10Go 10Go is offline
Welcomed to the 'Fest
Location: California
 
Join Date: Jun 2011
Posts: 71
Mein Auto: E65 745i
***Update***
The dealership replaced the battery (again) and said it was bad. That was the cause of my tranny issue. And also per the BMW Tech, the reason I got the "The transmission automatically shifts into P when the car is switched off. Please contact your BMW center." Was due to pressing and holding the "start" button to turn off and park the car. He said it was a huge "NONO". The proper way is the put the car in park then press the button. *sigh*
__________________
Regards,

Ten

745I
Slate Green Metallic___
Reply With Quote
  #7  
Old 01-08-2013, 11:05 AM
7Rage 7Rage is offline
Officially Welcomed to the 'Fest
Location: Long Beach, CA
 
Join Date: May 2012
Posts: 183
Mein Auto: 2007 750Li
Quote:
Originally Posted by 10Go View Post
***Update***
Was due to pressing and holding the "start" button to turn off and park the car. He said it was a huge "NONO". The proper way is the put the car in park then press the button. *sigh*
There is a recall for this exact problem..... ask them if your car is affected...
Reply With Quote
  #8  
Old 01-14-2013, 12:15 PM
10Go 10Go is offline
Welcomed to the 'Fest
Location: California
 
Join Date: Jun 2011
Posts: 71
Mein Auto: E65 745i
I have a favor to ask you guys...

I'm trying to get to the bottom of my "The transmission automatically shifts into P when the car is switched off. Please contact your BMW center." message. Whereas it would show up at random times, I can get the car to show me every time now and I wanted you guys with 02-04's, not sure if the newer 7's have the "key fob eject" option to try it. After the car was parked, I'd "double" tap the start/stop, holding it on the second tap. The message would show. Could you guys try it to see if you get the message? If you guys don't then I would think it's a glitch or my "Start" switch.
__________________
Regards,

Ten

745I
Slate Green Metallic___
Reply With Quote
  #9  
Old 01-14-2013, 01:25 PM
7Rage 7Rage is offline
Officially Welcomed to the 'Fest
Location: Long Beach, CA
 
Join Date: May 2012
Posts: 183
Mein Auto: 2007 750Li
why double tap.... i jsut hold mine the first time and it shuts off and ejects key... that double tapping is what a lot of people do and they issued a recall for it not shifting in to park when its done liek that....its not a zombie lmao no need to double tap... mine is a 2007 tho
Reply With Quote
  #10  
Old 01-14-2013, 01:28 PM
Piers1989 Piers1989 is offline
Officially Welcomed to the 'Fest
Location: Newcastle, UK
 
Join Date: Mar 2012
Posts: 302
Mein Auto: E65 745i
Quote:
Originally Posted by 7Rage View Post
why double tap.... i jsut hold mine the first time and it shuts off and ejects key... that double tapping is what a lot of people do and they issued a recall for it not shifting in to park when its done liek that....its not a zombie lmao no need to double tap... mine is a 2007 tho
^^^^^^ This ^^^^^^

If you just hold the button down for 1 second, maybe even less, it ejects the key immediately and turns everything off.

Also you could consider pressing the "P" button before you turn the car off if its a problem
Reply With Quote
  #11  
Old 01-14-2013, 01:44 PM
SuperSnoop's Avatar
SuperSnoop SuperSnoop is offline
Officially Welcomed to the 'Fest
Location: Austin, Texas
 
Join Date: Aug 2012
Posts: 559
Mein Auto: 2007 760Li
I think you have to double tap if you have comfort access. The first tap turns off the engine and the second acts like pulling out the key.
Reply With Quote
  #12  
Old 01-14-2013, 01:48 PM
7Rage 7Rage is offline
Officially Welcomed to the 'Fest
Location: Long Beach, CA
 
Join Date: May 2012
Posts: 183
Mein Auto: 2007 750Li
Noooooooo.. I have CA...
Reply With Quote
  #13  
Old 01-21-2013, 03:49 PM
10Go 10Go is offline
Welcomed to the 'Fest
Location: California
 
Join Date: Jun 2011
Posts: 71
Mein Auto: E65 745i
••Update••

Got the car back from the dealer. They replaced the "Mechatronics sleeve". The car now shifts and seems to drive better.

We shall see. (Evil Stewie eye squint)
__________________
Regards,

Ten

745I
Slate Green Metallic___
Reply With Quote
  #14  
Old 01-21-2013, 05:36 PM
7Rage 7Rage is offline
Officially Welcomed to the 'Fest
Location: Long Beach, CA
 
Join Date: May 2012
Posts: 183
Mein Auto: 2007 750Li
lol software update too? flush? or even new tranny (doubt it) I REALLY have a hard time trusting the dealer they can do whatever they want to save money... we get a printout that can say anything..... I dunno... I had a problem, they fixed it. prob came back and it was something else even tho it had exact same problems... in CALI we have lemon law... if something is repaired 3 times under the same warranty then they have to replace it (if you aren't aware they wont tell you this) I jsut have this feeling that they put down that they change different parts every visit for the same issue to avoid this... i dunno...

say they repalce the tranny 3x under manufacturers warranty... they would have to repalce the car cause its a lemon.... but say they had to repalce the IVM... I wonder if you would get your car repalced?? lol...be nice...
Reply With Quote
  #15  
Old 02-09-2013, 02:44 PM
10Go 10Go is offline
Welcomed to the 'Fest
Location: California
 
Join Date: Jun 2011
Posts: 71
Mein Auto: E65 745i
That's true what your saying and I've been keeping an eye on what the dealership has been replacing. I swear I feel like its a game they are playing to make more money. For example, If i say the tire is bad, i feel they wouldn't check the tire and not everything else involved in what keeps the tire doing its job e.g. Rotor, strut/shock etc.

They did say if they couldn't fix it that they would get me into "another" vehicle.
__________________
Regards,

Ten

745I
Slate Green Metallic___
Reply With Quote
  #16  
Old 02-09-2013, 03:04 PM
10Go 10Go is offline
Welcomed to the 'Fest
Location: California
 
Join Date: Jun 2011
Posts: 71
Mein Auto: E65 745i
•••Update••***8 226;

On returning the 7 again for the mystery message the dealer says they have REALLY found the problem. The vehicle has a bad CAS module. A new one is on order. We shall see...again.
__________________
Regards,

Ten

745I
Slate Green Metallic___
Reply With Quote
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 7 Series / 8 Series > 7 Series - E65 / E66 (2002 - 2008)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 02:25 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms