Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 5 Series > E34 (1989 - 1995)

E34 (1989 - 1995)

 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
  #1  
Old 01-09-2013, 12:27 AM
tchat48 tchat48 is offline
tchat
Location: north carolina
 
Join Date: Jan 2013
Posts: 5
Mein Auto: 1990 525i
lost all heat!!! baby born yesterday need help asap

I was sitting in drive thrust when all a sudden it was like steam started coming full speed thrust all my vents and noticed it was running a little hot. So after bout 2 hours of letting it cool filling it up with water and driving a mile before running hot again I finally got it home. It was like there was coolant condensation in the vents and coolant in the floor board what would this be? Baby was born on Sunday and really need my vehicle back and running.I have a 90 525i

Last edited by tchat48; 01-09-2013 at 12:28 AM.
Reply With Quote
Advertisement
 

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 5 Series > E34 (1989 - 1995)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 04:21 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms