Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > X Series > X5 E53 (1999 - 2006)

X5 E53 (1999 - 2006)
The X5 SAV Forum

Reply
 
Thread Tools Display Modes
  #1  
Old 01-08-2013, 05:34 PM
wolverine88 wolverine88 is offline
Registered User
Location: Ann Arbor
 
Join Date: Jan 2013
Posts: 1
Mein Auto: 2005 BMW X5
Desperately need help on X5/2005

Hi, I need help on my 2005 X5. Its battery was dead last night, so I called AAA to jump start it. After jump start, when I drive it out, I found its instrumental panel is not working, also on the center console, there is no clock or date. FM/CD does work though and show correctly.

On the instrumental panel, there is no light for mileage, trip and the lower center LED window.
Gas and RPM gauge does not work, but the speed, temprature gauge work correctly (I guess).

Any idea? Should I bring it to dealer, I guess it will cost around $$$$ to fix the electornics stuff. I guess I have to fix gas gauge, otherwise, I don't know how much gas left.

Is it possible that fuze just fried? How do I locate them and where to get the replacement part?

Million thanks.

Last edited by wolverine88; 01-08-2013 at 05:35 PM.
Reply With Quote
Advertisement
  #2  
Old 01-09-2013, 07:53 PM
ALTY ALTY is offline
Registered User
Location: Minnesota
 
Join Date: Jan 2013
Posts: 9
Mein Auto: 2004 530i Sport package
Alternator failure... The system shuts down when village is low... Once you get battery charged up and new alternator the system should come back online....

Sent from my LG-LS840 using Bimmer App
Reply With Quote
  #3  
Old 01-10-2013, 07:51 AM
QSilver7's Avatar
QSilver7 QSilver7 is offline
Officially Welcomed to the 'Fest
Location: Northeast Indiana
 
Join Date: Aug 2008
Posts: 5,863
Mein Auto: 1997 740iL / 2006 X5 4.4
The fuse locations are listed in your owners manual...and there should be a card or list in both locations that has an alphabetical list with the fuse location, and a diagram that shows where each fuse is located in the fuse box along with that fuse's amperage rating.

If you take it to the dealer without attempting any trouble shooting on your own...then yes, it is going to cost you $$$. Take a few minutes to look at some of the things you brought up like...blown fuses. BTW, how did AAA jump start your battery? Did they hook up to the jump start posts in the engine bay (which are designed for jump starting the vehicle)...or did they hook up directly to the battery in the spare wheel compartment?

Ditto where ALTY was going in his response...if the battery's voltage is LOW...you will experience a lot of weird electrical gremlins. If the battery was deeply discharged to the point that you required a jump, the battery won't be sufficiently recharged a few minutes after getting the vehicle running...thus lots of electrical gremlins could be present.

As far as the clock & date...can't tell from the way you wrote it...but if the battery was dead...you could have LOST this data. Did you try to re-enter the clock/date info into the MID? If the odometer is still dimmed...the jump may have blown one or more of the FIVE incandescent light bulbs that illuminate the instrument cluster. Again, this is a relatively simple fix even for those that are new to DIY repairs. There's only a couple of screws that secure the cluster to the dash...which can be undone and the cluster tilted out. Once out, the electrical harness can be disconnected...and you can go to your local BMW dealerships parts dept and buy/order the 5 bulbs and replace them. They don't cost that much and are simple to do yourself. If you have the dealership's service dept do it...the minimum will be what ever the labor charge is for at least 1 hour ($140 in some places) just to change 5 bulbs that cost a few dollars each.

five (#2) bulbs + two (#3) screws

click this link to go to the diagram below to retrieve the 11 digit BMW part nbr for the bulbs (#2): http://www.realoem.com/bmw/showparts...74&hg=62&fg=05

__________________
Q {BMW CCA Member #191509}
2006 E53 X5 4.4i (Sterling Gray) 12/05 mfg date <<~>> 97 740iL (Arctic Silver) 3/97 mfg date
(SOLD)
99 540iT (Orient Blue) <<~>> 95 525IT (Alpine White)
91 735iL (Schwarz Black) <<~>> 85 325e (Bronzit)

http://imageshack.com/scaled/grid240/822/e38e532ndsigpic.jpg
Reply With Quote
  #4  
Old 01-10-2013, 04:31 PM
dryflyguy dryflyguy is offline
Registered User
Location: Marin County, CA
 
Join Date: Nov 2009
Posts: 25
Mein Auto: 2006 X5 4.8iS
Sounds to me like your battery or alternator is toast. All the issues you are dealing with is voltage related. I doubt you have any fuses blown.
Reply With Quote
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > X Series > X5 E53 (1999 - 2006)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 11:50 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms