Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > X Series > X3 E83 (2004 - 2010)

X3 E83 (2004 - 2010)
Talk about the E83 BMW X3 in this forum!

Reply
 
Thread Tools Display Modes
  #1  
Old 01-04-2013, 01:02 PM
mekaneck mekaneck is offline
tool
Location: Illinois
 
Join Date: Apr 2007
Posts: 159
Mein Auto: 2003 325xi, 2007 X3
X3 rain sensor

Would anyone be so kind as to take a close-up picture of their X3's rain sensor (from the outside of their car, aimed at the rearview mirror area, with good lighting)?

I just got a new windshield installed (non-oem), and the rain sensor isn't working now. When I compare to my E46, the E83 is missing the small clear dot which I thought was for the light sensor. However the E83 light sensor works fine. So I'm wondering if the large purple area is really for the light sensor, and the small clear dot is the rain sensor.

I went so far as to make an extension cable so that I could plug the E83's wires into my E46's windshield sensor. Everything worked dandy. So it's either the windshield & lens, or it's the sensor that clips onto the lens.

Thanks!
__________________

2003 325xi BlackČ
Reply With Quote
Advertisement
  #2  
Old 01-04-2013, 01:35 PM
al_macaroni al_macaroni is offline
Officially Welcomed to the 'Fest
Location: DE
 
Join Date: Jul 2009
Posts: 322
Mein Auto: BMW X3
2008 e83 mirror

- unsure if photo will upload from app

Sent from my DROID X2 using Bimmer App
Attached Thumbnails
Click image for larger version

Name:	uploadfromtaptalk1357335306734.jpg
Views:	142
Size:	53.6 KB
ID:	355967  
__________________
2013 535i - ED, Oct 2012 | Cashmere Silver | Oyster/Black Nappa Anthracite | ZCW | Sirius | Air Blue 80
2008 X3 | Monaco | Sand/Black Light Poplar | ZAP | ZPP | ZCW | Xenon | Rear Fog
1988 Grand Wagoneer | Burgundy | Ghost Flames | 360 ci | Holley carb

BMW CCA #422951


Last edited by al_macaroni; 01-04-2013 at 01:39 PM.
Reply With Quote
  #3  
Old 01-04-2013, 01:38 PM
mekaneck mekaneck is offline
tool
Location: Illinois
 
Join Date: Apr 2007
Posts: 159
Mein Auto: 2003 325xi, 2007 X3
Awesome, thanks for that! Can you confirm you have both rain sensing wipers & automatic headlights?

That's exactly what my new windshield looks like.
__________________

2003 325xi BlackČ
Reply With Quote
  #4  
Old 01-04-2013, 01:40 PM
al_macaroni al_macaroni is offline
Officially Welcomed to the 'Fest
Location: DE
 
Join Date: Jul 2009
Posts: 322
Mein Auto: BMW X3
Yes, rain sensing and auto lamps. I have xenons and premium package.

Sent from my DROID X2 using Bimmer App
__________________
2013 535i - ED, Oct 2012 | Cashmere Silver | Oyster/Black Nappa Anthracite | ZCW | Sirius | Air Blue 80
2008 X3 | Monaco | Sand/Black Light Poplar | ZAP | ZPP | ZCW | Xenon | Rear Fog
1988 Grand Wagoneer | Burgundy | Ghost Flames | 360 ci | Holley carb

BMW CCA #422951

Reply With Quote
  #5  
Old 01-04-2013, 01:41 PM
Supercourse Supercourse is offline
Officially Welcomed to the 'Fest
Location: British Columbia, Canada
 
Join Date: Feb 2008
Posts: 3,154
Mein Auto: 2004 X3 2.5i
Can't get a good picture right now, but I'm sure the rectangular purple area is the rain sensor, and the small round light sensor in the rearview mirror doesn't have (or need) a lens in the windshield.

Not sure what the red dots are in my cell phone picture - had difficulty preventing the flash reflection from obscuring the picture.

I think the installer has to work carefully to successfully patch in a recycled or new rain sensor onto an aftermarket windshield.

A previous discussion may be of interest: http://www.bimmerfest.com/forums/sho...d.php?t=446664
Attached Thumbnails
Click image for larger version

Name:	sensor.jpg
Views:	111
Size:	78.6 KB
ID:	355969  
Reply With Quote
  #6  
Old 01-04-2013, 01:57 PM
SonicBoom SonicBoom is offline
Gearhead
Location: Minneapolis
 
Join Date: Apr 2012
Posts: 166
Mein Auto: 2007 X3
I that how that works?? I always wondered. Kewl!!
Reply With Quote
  #7  
Old 01-04-2013, 02:23 PM
mekaneck mekaneck is offline
tool
Location: Illinois
 
Join Date: Apr 2007
Posts: 159
Mein Auto: 2003 325xi, 2007 X3
Thanks guys. I had this same shop do my E46 a few months back and they did a great job (even though it was a non-OEM windshield with rain sensor). From the looks of their handiwork this time they did a great job again, but for some reason the sensor still won't work.

I'm still digging into it, but thanks a million for the pictures. I was concerned because I didn't see a clear dot like there is on my E46 (see picture below that I stole from another user, notice the dot below the bottom right corner of the purple sensor):



it's interesting that the sensor part numbers are identical between the E46 and E83, yet only the E46 windshields have that dot.
__________________

2003 325xi BlackČ
Reply With Quote
  #8  
Old 01-04-2013, 03:18 PM
AzNMpower32's Avatar
AzNMpower32 AzNMpower32 is offline
Tar Heel Faithful
Location: WNC
 
Join Date: Oct 2005
Posts: 13,996
Send a message via AIM to AzNMpower32
Mein Auto: 2014 Mazda3 GT
This may be a stupid question, but did they plug the sensor/wire harness back in? I also think there is a reinitialising process for the rain sensor whenever a new windshield is installed.

The light sensor is on the back (forward facing) side of the mirror itself, not attached to the windshield. On the passenger half of the mirror backing, there's a recessed area and a photocell inside. You can see it right underneath the toll transponder in al_macaroni's picture.

Last edited by AzNMpower32; 01-04-2013 at 03:20 PM.
Reply With Quote
  #9  
Old 01-04-2013, 04:13 PM
mekaneck mekaneck is offline
tool
Location: Illinois
 
Join Date: Apr 2007
Posts: 159
Mein Auto: 2003 325xi, 2007 X3
The sensor on the front of the autodim mirror is to disable the mirror dimming feature during daylight. The sensor for the automatic headlights is integrated with the rain sensor.

Yes, there is a "reinitialization" procedure that can be done to clear the learning memory of the rain sensor. I may try that if everything else fails, since I have to take it to the dealer for that. From what I understand, it's only rare cases where that needs to be done (and actually solves anything).

My next task is to swap the sensors (just the sensors, not the glued-on lenses) between my two cars, to see if that changes anything. If not, I'll go to the dealer for the reinitialization.
__________________

2003 325xi BlackČ
Reply With Quote
  #10  
Old 01-04-2013, 09:09 PM
mekaneck mekaneck is offline
tool
Location: Illinois
 
Join Date: Apr 2007
Posts: 159
Mein Auto: 2003 325xi, 2007 X3
Oh, and yes they did plug the sensor back in. Definitely not a stupid question.
__________________

2003 325xi BlackČ
Reply With Quote
  #11  
Old 01-04-2013, 10:16 PM
bluskye bluskye is offline
Officially Welcomed to the 'Fest
Location: chicago
 
Join Date: Jul 2002
Posts: 786
Mein Auto: 2006 330i / 2007 X3
I had "issues" with the rain sensor on my 330i when the windshield was replaced, see here.

http://www.bimmerfest.com/forums/sho...ht=rain+sensor

Turns out, the lens on the sensor itself was cracked =|

As far as the dot on the glass's surface is concerned, BMW has changed that design over the years. The E90 simply relocated the real sensor chip to the middle of the square. You need to see where the actual sensor aligns to the glass. See my post for reference.

Last edited by bluskye; 01-04-2013 at 10:24 PM.
Reply With Quote
  #12  
Old 01-12-2013, 07:51 AM
mekaneck mekaneck is offline
tool
Location: Illinois
 
Join Date: Apr 2007
Posts: 159
Mein Auto: 2003 325xi, 2007 X3
Just an update on this problem. I brought my car back to the windshield shop, and I talked them into letting me hook up my rain sensor to a new windshield (with my homemade rain sensor extension cord). The rain sensor worked just like it should on the new window, so the shop replaced the windshield for me again, this time free of charge.

I think that I might have been able to get the old windshield to work if I could have gotten the sensor re-initialized, but that would have cost me $125 at the BMW stealership.

Anyway, it's all working perfectly now. Thanks for the help.
__________________

2003 325xi BlackČ
Reply With Quote
  #13  
Old 01-12-2013, 07:54 AM
mekaneck mekaneck is offline
tool
Location: Illinois
 
Join Date: Apr 2007
Posts: 159
Mein Auto: 2003 325xi, 2007 X3
Oh, and the dot on the windshield - It's not on the E83 windows, and I don't think it does anything on the E46 windows. So it had nothing to do with the problem at all.
__________________

2003 325xi BlackČ
Reply With Quote
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > X Series > X3 E83 (2004 - 2010)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 09:48 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms