Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 5 Series > E39 (1997 - 2003)

E39 (1997 - 2003)
The BMW 5-Series (E39 chassis) was introduced in the United States as a 1997 model year car and lasted until the 2004 when the E60 chassis was released. The United States saw several variations including the 525i, 528i, 530i and 540i. -- View the E39 Wiki

Reply
 
Thread Tools Display Modes
  #1  
Old 01-11-2013, 07:13 PM
Studawg's Avatar
Studawg Studawg is offline
Officially Welcomed to the 'Fest
Location: SC
 
Join Date: Mar 2012
Posts: 259
Mein Auto: 2003 540iT M Sport
Code 8C: MAP controlled thermostat circuit control?

Getting this code with 1C and 1D, lean idle mixture on both banks. Any ideas? Thermostat was replaced at 70k in 2009, car has 103k now.
Reply With Quote
Advertisement
  #2  
Old 01-11-2013, 07:48 PM
edjack edjack is offline
Officially Welcomed to the 'Fest
Location: San Jose, CA
 
Join Date: May 2007
Posts: 9,687
Mein Auto: '97 540i 6 speed
Defective thermostat? What coolant temperature does your cluster report?
__________________


Ed in San Jose '97 540i 6 speed aspensilber over aubergine leather. Build date 3/97. Golden Gate Chapter BMW CCA Nr 62319.
Reply With Quote
  #3  
Old 01-11-2013, 08:08 PM
Studawg's Avatar
Studawg Studawg is offline
Officially Welcomed to the 'Fest
Location: SC
 
Join Date: Mar 2012
Posts: 259
Mein Auto: 2003 540iT M Sport
Thermostat was replaced about 40k miles/3 years ago, for what its worth. I havent checked the water temps yet. Guess I will do that next.
Reply With Quote
  #4  
Old 01-12-2013, 08:57 AM
Studawg's Avatar
Studawg Studawg is offline
Officially Welcomed to the 'Fest
Location: SC
 
Join Date: Mar 2012
Posts: 259
Mein Auto: 2003 540iT M Sport
So I just checked it and its reporting 44*C, but thats with the car off. It is unusually warm here today, about 70*F, and I had started the car and let it idle for just a few minutes before I did that. But, is there no way to check the temp while the car is running? After I get the OBC unlocked, how do I start the car to run any tests?
Reply With Quote
  #5  
Old 01-12-2013, 09:02 AM
energizedmortal's Avatar
energizedmortal energizedmortal is offline
Officially Welcomed to the 'Fest
Location: Manhattan, New York
 
Join Date: Jan 2010
Posts: 646
Mein Auto: 2003 530i
you can unlock the cluster with car warmed up. Test number 7 Coolant temperature should be around 93 Celsius.

http://forums.bimmerforums.com/forum....php?t=1241963

Last edited by energizedmortal; 01-12-2013 at 09:04 AM.
Reply With Quote
  #6  
Old 01-12-2013, 09:06 AM
Studawg's Avatar
Studawg Studawg is offline
Officially Welcomed to the 'Fest
Location: SC
 
Join Date: Mar 2012
Posts: 259
Mein Auto: 2003 540iT M Sport
Quote:
Originally Posted by energizedmortal View Post
you can unlock the cluster with car warmed up. Test number 7 Coolant temperature should be around 93 Celsius.

http://forums.bimmerforums.com/forum....php?t=1241963
Thanks, but why is there a velocity test?

Last edited by Studawg; 01-12-2013 at 09:12 AM.
Reply With Quote
  #7  
Old 01-12-2013, 09:10 AM
energizedmortal's Avatar
energizedmortal energizedmortal is offline
Officially Welcomed to the 'Fest
Location: Manhattan, New York
 
Join Date: Jan 2010
Posts: 646
Mein Auto: 2003 530i
test number 8 will show km/h (current velocity)
Reply With Quote
  #8  
Old 01-12-2013, 09:13 AM
Studawg's Avatar
Studawg Studawg is offline
Officially Welcomed to the 'Fest
Location: SC
 
Join Date: Mar 2012
Posts: 259
Mein Auto: 2003 540iT M Sport
If the car isnt running, the velocity will be zero!
Reply With Quote
  #9  
Old 01-12-2013, 09:14 AM
Studawg's Avatar
Studawg Studawg is offline
Officially Welcomed to the 'Fest
Location: SC
 
Join Date: Mar 2012
Posts: 259
Mein Auto: 2003 540iT M Sport
Quote:
Originally Posted by Studawg View Post
After I get the OBC unlocked, how do I start the car to run any tests?
This is what Im trying to figure out
Reply With Quote
  #10  
Old 01-12-2013, 09:18 AM
energizedmortal's Avatar
energizedmortal energizedmortal is offline
Officially Welcomed to the 'Fest
Location: Manhattan, New York
 
Join Date: Jan 2010
Posts: 646
Mein Auto: 2003 530i
turn the car on first, and then unlock the cluster to run tests.

Last edited by energizedmortal; 01-12-2013 at 09:21 AM.
Reply With Quote
  #11  
Old 01-12-2013, 09:28 AM
Studawg's Avatar
Studawg Studawg is offline
Officially Welcomed to the 'Fest
Location: SC
 
Join Date: Mar 2012
Posts: 259
Mein Auto: 2003 540iT M Sport
Oh, the instructions I read said the key had to be in position 1.
Reply With Quote
  #12  
Old 01-16-2013, 08:23 PM
Studawg's Avatar
Studawg Studawg is offline
Officially Welcomed to the 'Fest
Location: SC
 
Join Date: Mar 2012
Posts: 259
Mein Auto: 2003 540iT M Sport
So my core temp, according to the OBC, got up to about 104 C on a 2 hour drive, (it was about 70* F ambient) but never more. Gauge needle never moved. Ive still got the 3 codes. Any more ideas?
Reply With Quote
  #13  
Old 01-16-2013, 11:44 PM
doru's Avatar
doru doru is offline
Officially Welcomed to the 'Fest
Location: Calgary
 
Join Date: Sep 2007
Posts: 4,549
Mein Auto: 2003 530iA
Quote:
Originally Posted by Studawg View Post
So my core temp, according to the OBC, got up to about 104 C on a 2 hour drive, (it was about 70* F ambient) but never more. Gauge needle never moved. Ive still got the 3 codes. Any more ideas?
For a v8, I think your KTMP is fine.
Not sure what your codes. Can you post them detailed? Are these Peake? If so, post the whole thing. First and 2nd part (table & number). What you posted doesn't make any sense.
__________________
Looking for a DIY? Parts? Check this out, it might be your ticket
TMS underdrive pullies - Stewart WP - PSS9 - Beisan Vanos seals - Zimmerman cross-drilled & Akebono Euro - Deka 649 MF - 55w HID headlights - 35w HID foglights - Hualigan double din - ACS (rep) alu pedals - Euro central storage console - Breyton Magic Racing staggered wheels - M5 bumper - M5 steering wheel - Tint
Stable: e39, e53, e46 & Tribby
Reply With Quote
  #14  
Old 01-17-2013, 06:37 AM
Studawg's Avatar
Studawg Studawg is offline
Officially Welcomed to the 'Fest
Location: SC
 
Join Date: Mar 2012
Posts: 259
Mein Auto: 2003 540iT M Sport
Table OF

1C Mixture Control Idle Cyl 1-4
1D Mixture Control Idle Cyl 5-8
8C MAP Controlled Thermostat Circuit Control

Last edited by Studawg; 01-17-2013 at 06:40 AM.
Reply With Quote
  #15  
Old 01-17-2013, 09:28 AM
doru's Avatar
doru doru is offline
Officially Welcomed to the 'Fest
Location: Calgary
 
Join Date: Sep 2007
Posts: 4,549
Mein Auto: 2003 530iA
Quote:
Originally Posted by Studawg View Post
Table OF

1C Mixture Control Idle Cyl 1-4
1D Mixture Control Idle Cyl 5-8
8C MAP Controlled Thermostat Circuit Control
the first 2 codes point to a lean condition: check for vacuum leaks, clean the MAF (and test it). Check the age of the O2 sensors.

The last code is BMW specific code - your T-stat is toast.
__________________
Looking for a DIY? Parts? Check this out, it might be your ticket
TMS underdrive pullies - Stewart WP - PSS9 - Beisan Vanos seals - Zimmerman cross-drilled & Akebono Euro - Deka 649 MF - 55w HID headlights - 35w HID foglights - Hualigan double din - ACS (rep) alu pedals - Euro central storage console - Breyton Magic Racing staggered wheels - M5 bumper - M5 steering wheel - Tint
Stable: e39, e53, e46 & Tribby
Reply With Quote
  #16  
Old 01-17-2013, 09:49 AM
oembimmerparts oembimmerparts is offline
'Fest Sponsor
Location: San Antonio
 
Join Date: Jan 2007
Posts: 1,533
Mein Auto: 2001 Z3
On the 540, Make sure to check the harness where it plugs into the stat. There is a known issue there that can even lead to a engine fire. Check your plug to make sure its not loose and falling apart.

Max
__________________
Reply With Quote
  #17  
Old 01-17-2013, 12:11 PM
Studawg's Avatar
Studawg Studawg is offline
Officially Welcomed to the 'Fest
Location: SC
 
Join Date: Mar 2012
Posts: 259
Mein Auto: 2003 540iT M Sport
Thanks for the responses.

I checked for vacuum leaks before and found a couple and fixed them. I have a new CCV, but I didnt replace it yet because after I fixed the vac leaks it started running a lot better. Maybe the CCV is the source of another vac leak?

I cleaned the MAF with MAF cleaner already, but didnt test it.

All 4 O2 sensors were replaced by PO at 100k.

T stat was replaced at 70k in 09, time to replace again?

Question: When I first start the car in the morning, it fires right up, and idles smooth. Then about 45 sec later, i hear something that sounds like a gurgling sound, and or a valve closing, then the idle speed goes down a little, almost too much because then it starts idling a little rougher. Any ideas on that?

oembimmerparts--I had already checked that plug and it looks ok. I didnt disconnect it though.

Last edited by Studawg; 01-19-2013 at 06:26 AM.
Reply With Quote
  #18  
Old 01-19-2013, 06:25 AM
Studawg's Avatar
Studawg Studawg is offline
Officially Welcomed to the 'Fest
Location: SC
 
Join Date: Mar 2012
Posts: 259
Mein Auto: 2003 540iT M Sport
bump
Reply With Quote
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 5 Series > E39 (1997 - 2003)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 01:45 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms