Sticky Speedometer - Bimmerfest - BMW Forums



Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > X Series > X5 E53 (1999 - 2006)

X5 E53 (1999 - 2006)
The X5 SAV Forum

Reply
 
Thread Tools Display Modes
  #1  
Old 01-13-2013, 06:27 PM
mfpreach mfpreach is offline
Registered User
Location: Victoria BC
 
Join Date: Jan 2013
Posts: 1
Mein Auto: 2002 X5 4.4i
Sticky Speedometer

Hello,
I just purchased a 2002 X5 4.4i Executive edition.
The Car is in GREAT condition with only a few minor repairs required.
I didn't notice however (and neither did a bmw 100 point check) that the speedometer has a problem.

It will tell my speed but it does not go up fluidly. My Tach goes up fluidly but not my speedo. What happens it it lags and it will suddely go to 30, 40 etc.. but it doesn't go up fluidly like it should.

Any advice what to do? I wouldn't mind having this working properly but will wait for it to die if the repair is too much money (or I could simply put a GPS unit in).

Thanks!
Reply With Quote
Sponsored Links
Advertisement
 
  #2  
Old 01-24-2017, 03:13 AM
a1i.cu a1i.cu is offline
Registered User
Location: Jersey, Channel Islands, Britain
 
Join Date: Jan 2017
Posts: 21
Mein Auto: X3 E83 3.0i
Can I bump this please as I have the same problem
Reply With Quote
  #3  
Old 01-24-2017, 12:14 PM
BMWFatherFigure's Avatar
BMWFatherFigure BMWFatherFigure is offline
Old School
Location: Perth, Western Australia
 
Join Date: Aug 2012
Posts: 4,116
Mein Auto: E23;E32;E34;E38;R50;R55
Check the sensor and the wires to it. Also get the cluster checked on the bench.
__________________
Good - Fast - Cheap: Pick any two.
Current:
3 x E32 735iL (Alpine White, Glacier Blue & Kashmir Beige); 2 X E38 735iL (Oxford Green & Alpine White); E53 X5 4.4i (Pearl Beige); R50 Cooper; R55 Cooper Clubman (Both Pure Silver).
E38 Parts Car
Previous:
E21 318i; E23 735i; E30 318i; E32 735iL; E34 535i; E38 730iL; E53 4.4i
I've just changed my wiper blades and now my reverse lights don't work. Should I change my fuel pump relay?
Reply With Quote
Sponsored Links
Advertisement
 
  #4  
Old 01-24-2017, 03:23 PM
a1i.cu a1i.cu is offline
Registered User
Location: Jersey, Channel Islands, Britain
 
Join Date: Jan 2017
Posts: 21
Mein Auto: X3 E83 3.0i
Quote:
Originally Posted by BMWFatherFigure View Post
Check the sensor and the wires to it. Also get the cluster checked on the bench.
So how do I do that? I'm not a petrol headess, but I'm willing to try things on the car
Reply With Quote
Reply

See More Related BMW Stories


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > X Series > X5 E53 (1999 - 2006)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 03:20 PM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
© 2001- VerticalScope Inc. All rights reserved.