Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 7 Series / 8 Series > 7 Series - E65 / E66 (2002 - 2008)

7 Series - E65 / E66 (2002 - 2008)
Discussion pertaining to the flagship BMW here.

Reply
 
Thread Tools Display Modes
  #1  
Old 01-14-2013, 08:34 AM
Emeer18's Avatar
Emeer18 Emeer18 is offline
Officially Welcomed to the 'Fest
Location: Akron, Ohio
 
Join Date: Jul 2011
Posts: 468
Mein Auto: BMW 745Li
L7 amp ????

So i took my 7 in to the local dealer. My bass goes in and out. The dealer says my subs are blown. I know car audio and i highly doubt it. When subs are blown they dont just work one day and stop the next. Thats a connection or amplifier issue! What do you guys think? They also wanted $900 per speaker to repair. Insane!
__________________
Reply With Quote
Advertisement
  #2  
Old 01-14-2013, 08:46 AM
7Rage 7Rage is offline
Officially Welcomed to the 'Fest
Location: Long Beach, CA
 
Join Date: May 2012
Posts: 183
Mein Auto: 2007 750Li
well the subs are pretty easy to access... four bolts connect seat to floor... lean seat back and viola - access to subs.... check for yourself.... test the leads on sub with volt meter on ohm setting or continuity.... check cable from amp for voltage (presence of signal) (while audio is on).. hook up sub to another source see if it works at all (dont keep it on another source for long, impedance mismatch can damage speaker and amp) and wrong frequencies not good for sub... try another sub to connections to car amp... \

even if subs were "blown" you will still get sound but distorted as hell... usully spyder becomes disconnected from cone or coils burn out.... the latter could cause no sound (which is what continuity test is for)
Reply With Quote
  #3  
Old 01-14-2013, 08:51 AM
Emeer18's Avatar
Emeer18 Emeer18 is offline
Officially Welcomed to the 'Fest
Location: Akron, Ohio
 
Join Date: Jul 2011
Posts: 468
Mein Auto: BMW 745Li
Quote:
Originally Posted by 7Rage View Post
well the subs are pretty easy to access... four bolts connect seat to floor... lean seat back and viola - access to subs.... check for yourself.... test the leads on sub with volt meter on ohm setting or continuity.... check cable from amp for voltage (presence of signal) (while audio is on).. hook up sub to another source see if it works at all (dont keep it on another source for long, impedance mismatch can damage speaker and amp) and wrong frequencies not good for sub... try another sub to connections to car amp... \

even if subs were "blown" you will still get sound but distorted as hell... usully spyder becomes disconnected from cone or coils burn out.... the latter could cause no sound (which is what continuity test is for)
Thanks for the quick response. What size subs are under the seat and whats the ohm load on them?
__________________
Reply With Quote
  #4  
Old 01-14-2013, 09:34 AM
7Rage 7Rage is offline
Officially Welcomed to the 'Fest
Location: Long Beach, CA
 
Join Date: May 2012
Posts: 183
Mein Auto: 2007 750Li
8"..... as far as impedance, 6ohm is standard for most car applications, and 8ohm for most home applications, but I dont know for sure for this car..... someone else on here will tho.... 2 and 4 ohm are usually set on afteramrket subs, but I have found on cars with integrated subs (stock) the subs impedance matches the whole system
Reply With Quote
  #5  
Old 01-14-2013, 11:20 AM
DFEL750I's Avatar
DFEL750I DFEL750I is offline
Officially Welcomed to the 'Fest
Location: Toronto
 
Join Date: Apr 2010
Posts: 1,859
Mein Auto: 750I
Quote:
Originally Posted by Emeer18 View Post
Thanks for the quick response. What size subs are under the seat and whats the ohm load on them?
Stock subs are 4 ohms
__________________
Reply With Quote
  #6  
Old 01-14-2013, 11:25 AM
Emeer18's Avatar
Emeer18 Emeer18 is offline
Officially Welcomed to the 'Fest
Location: Akron, Ohio
 
Join Date: Jul 2011
Posts: 468
Mein Auto: BMW 745Li
Quote:
Originally Posted by DFEL750I View Post
Stock subs are 4 ohms
Thanks, what subs would you recommend. I see bmw tis is down aswell. How do i remove them?
__________________
Reply With Quote
  #7  
Old 01-14-2013, 01:49 PM
Emeer18's Avatar
Emeer18 Emeer18 is offline
Officially Welcomed to the 'Fest
Location: Akron, Ohio
 
Join Date: Jul 2011
Posts: 468
Mein Auto: BMW 745Li
So i got the subs out. Seems like they are fine. I think the dealer is messin with me. 4ohm single voice coil by the way.
Attached Thumbnails
Click image for larger version

Name:	ImageUploadedByBimmerApp1358200092.604488.jpg
Views:	87
Size:	111.2 KB
ID:	357692   Click image for larger version

Name:	ImageUploadedByBimmerApp1358200123.747760.jpg
Views:	80
Size:	106.3 KB
ID:	357693  
__________________
Reply With Quote
  #8  
Old 01-14-2013, 02:05 PM
DFEL750I's Avatar
DFEL750I DFEL750I is offline
Officially Welcomed to the 'Fest
Location: Toronto
 
Join Date: Apr 2010
Posts: 1,859
Mein Auto: 750I
Quote:
Originally Posted by Emeer18 View Post
Thanks, what subs would you recommend. I see bmw tis is down aswell. How do i remove them?
If you want to replace them with aftermarket subs you can buy the earthquake shallow 8 inch subs. Here is a link below

http://www.ebay.com/sch/i.html?_trks...at=0&_from=R40
__________________
Reply With Quote
  #9  
Old 01-14-2013, 03:09 PM
rideme2's Avatar
rideme2 rideme2 is offline
rideme2
Location: new york
 
Join Date: Dec 2009
Posts: 548
Mein Auto: 2006li bmw
Quote:
Originally Posted by Emeer18 View Post
So i got the subs out. Seems like they are fine. I think the dealer is messin with me. 4ohm single voice coil by the way.
It's not your speakers it's your L7amp. Subs Ch. goes bad first.
__________________
2006 750li K&N Filters Giovanna Kilis on 265/30/22 305/25/22 HID fogs 6000k Mtec angel eyes all lights 6000k ACS front lip,ACS rear wing,ACS rear window wing.dual exhaust working qual tips, rear camera, upgrade DVD to front watch jl13.5t sub with jl500/1v2 amp power cap.PassPort 9500ci,CrossDrilled&Slotted Rotors with EBC Brake Pads.Rear comfort seats, Fully loaded from dealer. Next mod iPhone hookup, .
Reply With Quote
  #10  
Old 01-14-2013, 03:36 PM
Rookie2008's Avatar
Rookie2008 Rookie2008 is offline
Officially Welcomed to the 'Fest
Location: NYC 4 Eva! Current California
 
Join Date: Feb 2011
Posts: 2,199
Mein Auto: BMW 745LI/ F02
Quote:
Originally Posted by rideme2 View Post
it's not your speakers it's your l7amp. Subs ch. Goes bad first.
+1
__________________
Sittin on 24's now with floating center caps
Reply With Quote
  #11  
Old 01-14-2013, 04:05 PM
Sebringx Sebringx is offline
Registered User
Location: New york
 
Join Date: Feb 2011
Posts: 34
Mein Auto: BMW 750i
Emeer18 it is l7 amp ....Rookie is so right. I have the same problems with mine. A INDY told it was the subwoofer ....NOT. Soon your Sub's will stop working all together ......it's RARE for Both subs to go out....unless its the channel powering them from the amp go out.
Reply With Quote
  #12  
Old 01-14-2013, 04:20 PM
7Rage 7Rage is offline
Officially Welcomed to the 'Fest
Location: Long Beach, CA
 
Join Date: May 2012
Posts: 183
Mein Auto: 2007 750Li
theres a thread on here to fix... price is right, but he's ~~~~~~~~~ alright...

Last edited by PAPER; 07-02-2013 at 08:34 PM.
Reply With Quote
  #13  
Old 01-14-2013, 09:13 PM
Emeer18's Avatar
Emeer18 Emeer18 is offline
Officially Welcomed to the 'Fest
Location: Akron, Ohio
 
Join Date: Jul 2011
Posts: 468
Mein Auto: BMW 745Li
Thanks guys for all your input! I had it out with the dealer today. I got my seats out and got the subs out easily. I tested each speaker. They sounded crisp and clear. Then went to two local car audio shops. They backed up my conclusion. Went back to the dealer sat the sub on the mans desk and demanded a real diagnosis. The amp is barely a year old! Its under a 2.5 year warranty. I think the dealers trying to avoid replacing it!
__________________
Reply With Quote
  #14  
Old 01-14-2013, 09:14 PM
Emeer18's Avatar
Emeer18 Emeer18 is offline
Officially Welcomed to the 'Fest
Location: Akron, Ohio
 
Join Date: Jul 2011
Posts: 468
Mein Auto: BMW 745Li
Quote:
Originally Posted by Sebringx View Post
Emeer18 it is l7 amp ....Rookie is so right. I have the same problems with mine. A INDY told it was the subwoofer ....NOT. Soon your Sub's will stop working all together ......it's RARE for Both subs to go out....unless its the channel powering them from the amp go out.
The subs already stopped working, they jus have popping now. The doors are the only things working
__________________
Reply With Quote
  #15  
Old 01-14-2013, 10:25 PM
7Rage 7Rage is offline
Officially Welcomed to the 'Fest
Location: Long Beach, CA
 
Join Date: May 2012
Posts: 183
Mein Auto: 2007 750Li
Quote:
Originally Posted by Emeer18 View Post
I think the dealers trying to avoid replacing it!
of course... that amp is $1200 (retail at dealer) so the invoice cant be less than 1000...
Reply With Quote
  #16  
Old 01-25-2013, 06:35 PM
Emeer18's Avatar
Emeer18 Emeer18 is offline
Officially Welcomed to the 'Fest
Location: Akron, Ohio
 
Join Date: Jul 2011
Posts: 468
Mein Auto: BMW 745Li
Update: So they finally diagnose the L7 again and determine its not sending a signal to the speakers. Big surprise! And they wont give me the diagnosis fee back even thou they agreed to!
__________________
Reply With Quote
  #17  
Old 01-26-2013, 09:46 AM
KingSilverback KingSilverback is offline
The Silverback
Location: Wisconsin
 
Join Date: Feb 2012
Posts: 448
Mein Auto: 2006 750Li
replace it with.

Last edited by PAPER; 07-02-2013 at 08:34 PM.
Reply With Quote
  #18  
Old 01-26-2013, 10:35 AM
Sebringx Sebringx is offline
Registered User
Location: New york
 
Join Date: Feb 2011
Posts: 34
Mein Auto: BMW 750i
Don't miss out on item BMW OEM FACTORY AMPLIFIER L7 LOGIC65-12-6-961-389 BMW TOP HIFI DSP SYSTEM AMP (181068146593)
this on eBay
Reply With Quote
  #19  
Old 01-26-2013, 10:37 AM
Sebringx Sebringx is offline
Registered User
Location: New york
 
Join Date: Feb 2011
Posts: 34
Mein Auto: BMW 750i
Here is the link::: I just a Ordered one for $250
Reply With Quote
  #20  
Old 01-26-2013, 10:37 AM
Sebringx Sebringx is offline
Registered User
Location: New york
 
Join Date: Feb 2011
Posts: 34
Mein Auto: BMW 750i
Hi! I found this on eBay and thought you might like it! "BMW OEM FACTORY AMPLIFIER L7 LOGIC 65-12-6-961-389 BMW TOP HIFI DSP SYSTEM AMP" http://r.ebay.com/uufoHX
Reply With Quote
  #21  
Old 01-27-2013, 05:28 AM
Emeer18's Avatar
Emeer18 Emeer18 is offline
Officially Welcomed to the 'Fest
Location: Akron, Ohio
 
Join Date: Jul 2011
Posts: 468
Mein Auto: BMW 745Li
Thanks but its already getting replaced under warranty.
__________________
Reply With Quote
  #22  
Old 01-31-2013, 05:21 PM
Sebringx Sebringx is offline
Registered User
Location: New york
 
Join Date: Feb 2011
Posts: 34
Mein Auto: BMW 750i
Just replaced my Logic 7 amp....it took about 15-20 to replace amp. My subwoofers are working excellent now!!!!
Reply With Quote
  #23  
Old 02-01-2013, 09:53 PM
Emeer18's Avatar
Emeer18 Emeer18 is offline
Officially Welcomed to the 'Fest
Location: Akron, Ohio
 
Join Date: Jul 2011
Posts: 468
Mein Auto: BMW 745Li
Quote:
Originally Posted by Sebringx View Post
Just replaced my Logic 7 amp....it took about 15-20 to replace amp. My subwoofers are working excellent now!!!!
Im still waiting on mine to arrive, its always the amps.
__________________
Reply With Quote
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 7 Series / 8 Series > 7 Series - E65 / E66 (2002 - 2008)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 06:35 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms