Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > X Series > X1 E84 (2011 - current)

X1 E84 (2011 - current)
The new to the US BMW X1 will arrive at BMW dealers in the fall of 2012 as a 2013 model year. Get your X1 28i with either sDrive (RWD) or xDrive (AWD) or get the US exclusive I6 N55 powered X1 35i dDrive.

Reply
 
Thread Tools Display Modes
  #1  
Old 01-08-2013, 02:19 PM
jph1 jph1 is offline
Registered User
Location: SF bay area
 
Join Date: Nov 2012
Posts: 12
Mein Auto: X1 x28
"Engine Malfunction"

I was wondering if this has happened to anyone else here.
Car: X128 with x drive. Current odometer reading at 2k miles

I was leaving for lunch, started my engine, it ran extremely rough, and I got the following message on the idrive screen: Engine Malfunction. Operating on low power.

Only when I took out the key and replaced it, did it restart without the issue, but one warning remained, telling me that maintenance was required soon.

I figure it's a software glitch, but I was wondering if this happens a lot.
Reply With Quote
Advertisement
  #2  
Old 01-08-2013, 03:27 PM
floydarogers's Avatar
floydarogers floydarogers is offline
Pedant and Curmudgeon
Location: Renton, WA
 
Join Date: Oct 2010
Posts: 3,831
Mein Auto: 335d, 328d, Toyota T100
That's not a glitch. Something went wrong, but re-starting the engine cleared the problem - temporarily at least. You need to take it to a dealer to get them to read the codes and fix the underlying problem. Do not ignore it.
Reply With Quote
  #3  
Old 01-08-2013, 03:34 PM
nospam nospam is offline
Officially Welcomed to the 'Fest
Location: Orange County, CA
 
Join Date: Apr 2006
Posts: 455
Mein Auto: X1 x28i; 128i; S2000
This is the behavior exhibited with the High Pressure Fuel Pump failure on my E90 335i. Definitely take in for service.
Reply With Quote
  #4  
Old 01-08-2013, 04:53 PM
jph1 jph1 is offline
Registered User
Location: SF bay area
 
Join Date: Nov 2012
Posts: 12
Mein Auto: X1 x28
Thanks guys.
I have an appointment tomorrow. I'll let you know what they say.
Reply With Quote
  #5  
Old 01-10-2013, 05:05 PM
jph1 jph1 is offline
Registered User
Location: SF bay area
 
Join Date: Nov 2012
Posts: 12
Mein Auto: X1 x28
Looks like it's a O2 sensor.
Reply With Quote
  #6  
Old 01-10-2013, 07:55 PM
conceyted conceyted is offline
Officially Welcomed to the 'Fest
Location: USA
 
Join Date: Sep 2012
Posts: 119
Mein Auto: 2013 X1
Quote:
Originally Posted by jph1 View Post
Looks like it's a O2 sensor.
Easy fix. You'll be back on the road enjoying your new car in no time!
Reply With Quote
  #7  
Old 01-12-2013, 10:51 PM
jph1 jph1 is offline
Registered User
Location: SF bay area
 
Join Date: Nov 2012
Posts: 12
Mein Auto: X1 x28
Got the car back. Ran fine going home. The ext morning started running rough. Then stalled and Engine Malfunction back It is now back at the dealer
I'm wondering if the bad O2 sensor caused a secondary issue. Or was it mis diagnosed?
Reply With Quote
  #8  
Old 01-13-2013, 03:54 AM
Leekay07 Leekay07 is offline
Officially Welcomed to the 'Fest
Location: Stillwater NY
 
Join Date: Jan 2012
Posts: 596
Mein Auto: X5 35D, Former X1 and 335
Probably a bad coil pack that caused the engine to run rich that caused them to diagnose the O2.
__________________
If you like customer service. Don't look beyond a BMW.
Reply With Quote
  #9  
Old 01-15-2013, 02:26 PM
jph1 jph1 is offline
Registered User
Location: SF bay area
 
Join Date: Nov 2012
Posts: 12
Mein Auto: X1 x28
They're saying it's a bad injector. The bad news, is that the injector is coming from Germany, so they estimate 10 days. The good news is that I have a courtesy car.
Reply With Quote
  #10  
Old 10-24-2014, 12:53 PM
rh604 rh604 is offline
Registered User
Location: NJ. USA
 
Join Date: Oct 2014
Posts: 1
Mein Auto: X1
Two weeks and still not fixed

I had the "loss of power" and "engine malfunction" issue at about 10K (on a 2014 X1). The dealer replaced two fuel injectors and sent me on my way.

Less than a week later it happened again. I dropped off the car and it's now been about 2 weeks and I still don't have it back.

I've heard everything from sending computer data to Germany to that it was inspected by three German engineers. Now they say the regional service manager said to order all new fuel injectors from Germany.

These guys really don't know what they're doing, right? Would anyone else be hesitant to try another BMW after an experience like this?
Reply With Quote
  #11  
Old 10-25-2014, 04:23 PM
SilverX3's Avatar
SilverX3 SilverX3 is offline
Officially Welcomed to the 'Fest
Location: Australia
 
Join Date: Sep 2005
Posts: 3,298
Mein Auto: 130i & E92 325i, E90 SOLD
that's BMW turbo engine

I stay with non turbo cars
__________________
Residence - StarTrek Enterprise
Job - Captain
Current Starship Fleet:
06 130i - ROCK SOLID Performer
MY11.5 X1 Xdrive25i
2013 VW Golf R - Rising Metallic Blue
07 320i - SOLD
08 E92 325i - Blue SOLD
Bicycles: Giant TCR Advanced Zero SOLD, Argon 18 Krypton, Argon 18E114, Trek Madone COMING
Reply With Quote
  #12  
Old 10-25-2014, 07:08 PM
stonex1's Avatar
stonex1 stonex1 is online now
Officially Welcomed to the 'Fest
Location: BC, Canada
 
Join Date: Oct 2012
Posts: 705
Mein Auto: 13' X1 35i
Quote:
Originally Posted by SilverX3 View Post

I stay with non turbo cars
Don't like turbos?
__________________
2013 X1
MinGrey,Xenon,HK,PwrSeats,Sirius,XLine,Nav
Reply With Quote
  #13  
Old 10-25-2014, 10:12 PM
SilverX3's Avatar
SilverX3 SilverX3 is offline
Officially Welcomed to the 'Fest
Location: Australia
 
Join Date: Sep 2005
Posts: 3,298
Mein Auto: 130i & E92 325i, E90 SOLD
I do like turbo

But not bmw

Give them a few years to perfect turbo engines
__________________
Residence - StarTrek Enterprise
Job - Captain
Current Starship Fleet:
06 130i - ROCK SOLID Performer
MY11.5 X1 Xdrive25i
2013 VW Golf R - Rising Metallic Blue
07 320i - SOLD
08 E92 325i - Blue SOLD
Bicycles: Giant TCR Advanced Zero SOLD, Argon 18 Krypton, Argon 18E114, Trek Madone COMING
Reply With Quote
  #14  
Old 10-26-2014, 06:25 AM
vbmx vbmx is offline
Registered User
Location: Massachusetts
 
Join Date: Aug 2014
Posts: 68
Mein Auto: 2012 BMW 528i X-Drive
Quote:
Originally Posted by SilverX3 View Post
I do like turbo

But not bmw

Give them a few years to perfect turbo engines

Haven't the Turbo engines been around for quite a few years in various non US markets? That's why I ended up feeling comfortable purchasing my 2012 4 cylinder turbo 528ix.. At first I was very hesitant but knowing that it's not their first rodeo gave me the comfort level.

Overall I like it except for the lag which is a problem with all turbos
Reply With Quote
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > X Series > X1 E84 (2011 - current)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 07:57 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms