Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 3 Series / 4 Series > E46 (1999 - 2006)

E46 (1999 - 2006)
The fourth generation 3 Series (E46 chassis) was introduced in 1999 and set the standard for engineering and performance during it's years of production including being named to Car & Driver's 10 best list every one of those years! ! -- View the E46 Wiki

Reply
 
Thread Tools Display Modes
  #1  
Old 12-19-2012, 06:17 PM
stairwayto7 stairwayto7 is offline
Pittsburgh Steelers Fan
Location: Wilson N.C.
 
Join Date: Nov 2009
Posts: 165
Mein Auto: 325i & 528i & 33ci
e46 studdering on acceleration

My 2001 330ci runs fine when idling but shoot her the gas, and she acts as if its starving for fuel and the transmission does not shift right.

It was running fine, but then the fuel pump went out. So I change it and the filter. Its been running like crap ever since. It thru a crankshaft position code and camshaft position code.

Ive checked all the vacuum lines and can't find a leak.

Ive changed the following: Crankshaft PS / Camshaft PS / Fuel pump & Filter / Upper & lower / Spark plugs / boots from the throttle body to the MA flow sensor (they were cracked). and cleaned the throttle body.

Please Help!!
__________________

Last edited by stairwayto7; 12-19-2012 at 07:18 PM.
Reply With Quote
Ads by Google
  #2  
Old 12-19-2012, 06:35 PM
scarede46er scarede46er is offline
Officially Welcomed to the 'Fest
Location: Clemson, SC
 
Join Date: Aug 2012
Posts: 161
Mein Auto: 2001 BMW 325i ZSP
Were the sensors OEM or aftermarket? Also, how old are the O2 sensors? Does it throw any code?
Reply With Quote
  #3  
Old 12-19-2012, 07:11 PM
stairwayto7 stairwayto7 is offline
Pittsburgh Steelers Fan
Location: Wilson N.C.
 
Join Date: Nov 2009
Posts: 165
Mein Auto: 325i & 528i & 33ci
No O2 codes and Im not sure the last time they were changed.

All sensors are OEM.
__________________

Last edited by stairwayto7; 12-19-2012 at 07:16 PM.
Reply With Quote
  #4  
Old 12-20-2012, 04:31 PM
stairwayto7 stairwayto7 is offline
Pittsburgh Steelers Fan
Location: Wilson N.C.
 
Join Date: Nov 2009
Posts: 165
Mein Auto: 325i & 528i & 33ci
Just pulled my secondary air pump and it is bad. I did a cold start test and it didn't come on. So I pulled it and stright wired it but didn't work.

Can this be my problem?
__________________
Reply With Quote
  #5  
Old 12-20-2012, 06:14 PM
mlukas161's Avatar
mlukas161 mlukas161 is offline
Officially Welcomed to the 'Fest
Location: WNY
 
Join Date: Oct 2008
Posts: 934
Mein Auto: 03 330i, 04 X3
Did you connect the fuel filter hoses in the proper places?
__________________
Reply With Quote
  #6  
Old 01-17-2013, 10:09 AM
stairwayto7 stairwayto7 is offline
Pittsburgh Steelers Fan
Location: Wilson N.C.
 
Join Date: Nov 2009
Posts: 165
Mein Auto: 325i & 528i & 33ci
sorry so late responding but yes.
__________________
Reply With Quote
  #7  
Old 01-19-2013, 11:31 AM
ahull's Avatar
ahull ahull is offline
Officially Welcomed to the 'Fest
Location: Carolina
 
Join Date: Apr 2006
Posts: 3,364
Mein Auto: ist schnell! (03 330i SC)
get the error codes read. the secondary air pump only runs the first couple of minutes on cold start to get the cats going quicker so it's purely for emissions purposes. shouldn't affect performance but you will need it to be working next time you get an inspection.
Reply With Quote
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 3 Series / 4 Series > E46 (1999 - 2006)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 08:32 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms