What could cause a loss of power ???? - Bimmerfest - BMW Forums



Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 5 Series > E39 (1997 - 2003)

E39 (1997 - 2003)
The BMW 5-Series (E39 chassis) was introduced in the United States as a 1997 model year car and lasted until the 2004 when the E60 chassis was released. The United States saw several variations including the 525i, 528i, 530i and 540i. -- View the E39 Wiki

 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
  #1  
Old 01-23-2013, 01:50 PM
diggyd357's Avatar
diggyd357 diggyd357 is offline
Officially Welcomed to the 'Fest
Location: Louisiana
 
Join Date: Sep 2012
Posts: 637
Mein Auto: 97 528I
What could cause a loss of power ????

My 97 528i with 220k has been a project....its never not ran or had any major issues, its just an aging car. I've done all the usual preventative type stuff (transmission service, O2 sensors, CCV , alternator , belts and hoses, replaced a broken header and gaskets, front wheel speed sensor, new plugs, ect). I do believe I need a VCG as I had oil in the plug channels and the car will sometimes smoke a little bit. My concern is that my car used to really respond to the gas pedal. Now it seems that rather Im at 1/4 pedal or 3/4 pedal its picking up about the same. Its not so much "lagging", its just not responding with the same "oomph !!! " as before. What might cause this ? Thanks for taking the time !
__________________
Reply With Quote
 

See More Related BMW Stories


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 5 Series > E39 (1997 - 2003)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 05:16 AM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
© 2001- VerticalScope Inc. All rights reserved.