Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 5 Series > E39 (1997 - 2003)

E39 (1997 - 2003)
The BMW 5-Series (E39 chassis) was introduced in the United States as a 1997 model year car and lasted until the 2004 when the E60 chassis was released. The United States saw several variations including the 525i, 528i, 530i and 540i. -- View the E39 Wiki

Reply
 
Thread Tools Display Modes
  #1  
Old 01-20-2013, 12:58 AM
nhansen907 nhansen907 is offline
Registered User
Location: Oregon
 
Join Date: Jan 2013
Posts: 23
Mein Auto: 540i
Trans failsafe prog

This came up on my car while my friend was reversing. It's not the battery because I just put a new one in. Reversing is fine but when I am in drive and accelerate my rpms go up but my car has no power and then the trans failsafe prog comes on and my car seems to have some power as if it was in a high gear. What could this be? My car is a 98' 540i
Reply With Quote
Advertisement
  #2  
Old 01-20-2013, 05:47 AM
Fudman's Avatar
Fudman Fudman is offline
Officially Welcomed to the 'Fest
Location: Sudbury, MA
 
Join Date: Apr 2007
Posts: 6,345
Mein Auto: '02 530i Sport auto
Do a search. TPF indicates a tranny failure. You are now in default (2d gear) or limp mode, which is to protect the tranny from further damage. It could be triggered by a bad sensor, bad alternator or a tranny failure. It needs to be reset to see if it returns. It requires GT-1 (dealer), INPA or equivalent to reset. Sometimes its an easy fix and sometimes an expensive one.
Reply With Quote
  #3  
Old 01-20-2013, 10:18 AM
nhansen907 nhansen907 is offline
Registered User
Location: Oregon
 
Join Date: Jan 2013
Posts: 23
Mein Auto: 540i
Thanks, I will look into that. I wanted to see if it could potentially be something i could do myself, with out it bring to expensive. I will have to pull the code off of it and see info can't figure something out before take it into a dealer which charge a **** ton
Reply With Quote
  #4  
Old 01-20-2013, 10:29 AM
Fudman's Avatar
Fudman Fudman is offline
Officially Welcomed to the 'Fest
Location: Sudbury, MA
 
Join Date: Apr 2007
Posts: 6,345
Mein Auto: '02 530i Sport auto
Only the GT-1, INPA or equivalent can pull (& reset) a tranny code. Find an indy.
Reply With Quote
  #5  
Old 01-20-2013, 01:46 PM
ill540i's Avatar
ill540i ill540i is offline
Officially Welcomed to the 'Fest
Location: riverside
 
Join Date: Jul 2012
Posts: 115
Mein Auto: Bmw 540i
Had the same problem on my 98 540 the trans oil was burned and had to replace it now it runs fine replaced it 3 months ago

Sent from my MB502 using Bimmer App
Reply With Quote
  #6  
Old 01-20-2013, 03:54 PM
nhansen907 nhansen907 is offline
Registered User
Location: Oregon
 
Join Date: Jan 2013
Posts: 23
Mein Auto: 540i
I will try that too, thanks
Reply With Quote
  #7  
Old 01-20-2013, 04:57 PM
Eurojay89's Avatar
Eurojay89 Eurojay89 is offline
Faithful to the fest
Location: Providence, Rhode Island
 
Join Date: Jan 2009
Posts: 366
Send a message via AIM to Eurojay89
Mein Auto: 2003 530i
Could be the alternator that was my issue
__________________
_______________________________________




Reply With Quote
  #8  
Old 01-24-2013, 04:18 PM
nhansen907 nhansen907 is offline
Registered User
Location: Oregon
 
Join Date: Jan 2013
Posts: 23
Mein Auto: 540i
So anyway I took it in for them to do a inspection and they Said I have a forward clutch drum damage. Code p0720 & p0731.
They told me I need a rebuild to my transmission. Would that be worth trying or should I find a replacement one And have it installed?
Reply With Quote
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 5 Series > E39 (1997 - 2003)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 03:45 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms