Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > Z Series > E85 / E86 Z4 (2003-2008)

E85 / E86 Z4 (2003-2008)
E85 Z4 convertible and E86 Z4 coupe talk with our BMW gurus here.

Reply
 
Thread Tools Display Modes
  #1  
Old 01-09-2013, 04:01 PM
Irak1121 Irak1121 is offline
Registered User
Location: NY
 
Join Date: Jan 2013
Posts: 2
Mein Auto: 2006 Z4
Question Z4 2006

2006 z4
Hi guys, looking for help on a warning indicator battery light is on when car is started but then will go out after a few minutes.
Manual says alternator not charging . Battery not charging. However why would light go out then?.
Please help.
Reply With Quote
Ads by Google
  #2  
Old 01-09-2013, 06:03 PM
GA Z4 GA Z4 is offline
Registered User
Location: Perry GA
 
Join Date: Jan 2010
Posts: 81
Mein Auto: 2004 Z4
Belt loose?
Reply With Quote
  #3  
Old 01-09-2013, 07:34 PM
Droptop85 Droptop85 is offline
Officially Welcomed to the 'Fest
Location: Fresno
 
Join Date: Oct 2011
Posts: 351
Mein Auto: 03 Z4 3.0i
Check your battery voltage before startup. Maybe your battery is weak.
Reply With Quote
  #4  
Old 01-10-2013, 04:03 AM
Mikey48 Mikey48 is offline
Officially Welcomed to the 'Fest
Location: Charleston,S.C.
 
Join Date: Mar 2011
Posts: 405
Mein Auto: BMW Z4 3.0
Sounds like a weak battery to me.
Reply With Quote
  #5  
Old 01-25-2013, 03:58 PM
Uber-Fritz Uber-Fritz is offline
Registered User
Location: Victoria BC
 
Join Date: Aug 2012
Posts: 21
Mein Auto: 2006 Z4 3.0i
I think a loose/defective belt is the most likely too. As the engine warms up and expands (slightly tightening the belt) and the alternator warms up and runs freerer, this may well produce enough output that the idiot light goes out. Second guess is the regulator isnt delivering the juice in the specified amounts. Good luck.
Reply With Quote
  #6  
Old 01-27-2013, 09:29 AM
NewZee NewZee is offline
Registered User
Location: Lancaster, NY, USA
 
Join Date: Feb 2012
Posts: 61
Mein Auto: 2008 Z4 3.0si Roadster
Hi!
If you have a volt/ohm meter you can check the voltage at the battery when the car is running. The alternator (voltage regulator) should be putting out about 14.3 volts. If you check the battery voltage with the car not running even a weak battery could show close to 12 volts because there is no draw on it. Like already suggested it could be a loose belt on the alternator, or a weak battery. You can get the battery checked at a auto parts store like Autozone. They can put a load on it and tell you if it's OK.

Good luck
__________________
Reply With Quote
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > Z Series > E85 / E86 Z4 (2003-2008)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 03:02 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms