Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > X Series > X6 E71 / E72 (2008 - current)

X6 E71 / E72 (2008 - current)
The newest sport activity vehicle from BMW is a crossover-coupe style and is expected to appear sometime in 2008!

 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
  #1  
Old 01-26-2013, 05:22 PM
dba777 dba777 is offline
Registered User
Location: Midwest
 
Join Date: Dec 2012
Posts: 4
Mein Auto: 2010 BMW X6 xDrive35i
Angry Escort 9500ix shuts off - directwire

Hey all,

I am in need of a good advice from the knowledgeable forum here.

I had an Escort 9500ix hardwired to my BMW X6 connecting into the fuse circuit box using an Add-a-Circuit kit. Radar seems to operate as designed. I start the car, radar goes on. As the vehicle turned off, radar also shuts off.

I drove the car with the radar on. After 10-15 minutes, radar screen turned black and I heard a soft chirping sound from the radar. It sounded something like a Morse code. I unplugged radar, plugged it back in. Screen did not turn on, and sound repeated. Tried to plug radar in again after few minutes, it still did not work, heard the same chirping sound.

Next day, I restarted the car, plugged radar and it came up fine. Problem repeated again same day…

Radar connected via Escort Direct Wire Power Cord to the open slot in the fuse box with the Add-a-Circuit kit 2AMP fuse.

Please advise on how can I fix the problem?

As a side note, if I connect radar with the standard power cord to the cigarette lighter adapter, then radar works fine. It rules out that radar unit is defective.
Reply With Quote
Ads by Google
 

Bookmarks

Tags
escort radat 9500ix


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > X Series > X6 E71 / E72 (2008 - current)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 02:49 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms