Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > X Series > X3 E83 (2004 - 2010)

X3 E83 (2004 - 2010)
Talk about the E83 BMW X3 in this forum!

Reply
 
Thread Tools Display Modes
  #1  
Old 01-21-2013, 01:43 PM
Jkoshy01 Jkoshy01 is offline
Registered User
Location: philadelphia
 
Join Date: Jan 2013
Posts: 10
Mein Auto: 2007 BMW X3
Is the Expansion tank leaking or something else?

Hello,
Last week my 2007 X3s Low Coolant light came on when driving with the heat on. I looked under the hood and saw that the coolant was low. I added coolant and am noticing that it leaks as soon as I turn the car off after a drive. It does not leak if I leave the car on and also once it gets Low it does not leak. It only leaks when I fill it up and it seems it leaks everything I filled up but does not leak after a certain point. The low coolant sign has not come back on even with the Heat on. Also the car seems to shake just a little when waiting at a stop light.
Any suggestions on what it could be?

Any help is appreciated.

Thank You
Reply With Quote
Ads by Google
  #2  
Old 01-26-2013, 09:49 PM
silentbob silentbob is offline
Registered User
Location: Bay Area, CA
 
Join Date: Jan 2012
Posts: 54
Mein Auto: X3
Try taking off the splash shield under the car to pinpoint where the leak is coming from. Without that, it's really hard to say. If it's the expansion tank, you will probably see drips coming down from drain screw.
Reply With Quote
  #3  
Old 01-27-2013, 06:17 PM
mama_jo's mama_jo's is offline
Registered User
Location: St Louis
 
Join Date: Jan 2013
Posts: 18
Mein Auto: 2013 X-3 35
i had low coolant light coming on occasionally with an '08 X-3 and finally saw signs of a small leak on the garage floor. took it in and ended up with an $800 radiator! at about 53,xxx miles. Very surprised as this car is well-maintained, garaged, driven by my wife and I carefully. Just a fluke according to service folks at the dealer. i had hoped it might have been the expansion tank because it would have been cheaper.
Reply With Quote
  #4  
Old 01-28-2013, 10:22 PM
Gee3 Gee3 is offline
Registered User
Location: SF, CA
 
Join Date: Sep 2004
Posts: 20
Mein Auto: Integra and X3
I had a similar issue after I replaced the radiator that had a hole in the fins.

I thought it was the expansion tank but it turned out to be the transmission thermostat that connects to the bottom of the expansion tank. It's made of plastic, like most BMW parts, and the housing that held the spring in place on the thermostat failed. So the spring was pushing against the bottom of the expansion tank and creating a space for coolant to leak out. I was at a little over 100k miles when this occurred. So check out under there and see if the coolant is leaking there.

Generally if the expansion tank is leaking you can see the white coolant residue on the sides of the tank leaking at the lip on the top part of the tank. Mine didn't have that but I replaced it anyway to avoid the pain later on.

Good luck!
Reply With Quote
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > X Series > X3 E83 (2004 - 2010)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 04:52 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms