Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 7 Series / 8 Series > 7 Series - E38 (1995 - 2001)

7 Series - E38 (1995 - 2001)

Reply
 
Thread Tools Display Modes
  #1  
Old 01-29-2013, 06:16 PM
First740i First740i is offline
Officially Welcomed to the 'Fest
Location: michigan
 
Join Date: Mar 2011
Posts: 291
Mein Auto: 740i
T-stat

My upper radiator hose blew off today. I put it back on drove my car home. Temp gage was past hot. (Only for a sec). I get home thinking my hose came off again. Not the case. I touch the upper hose its hot as hell. Touch the lower and its cold at the Thermos stat. I'm going to guess its a t-stat. I have not done one, my car has 160000 on it. But I got it used so I don't know if the past owner had it done.

Sent from my DROID4 using Bimmer App
Reply With Quote
Advertisement
  #2  
Old 01-29-2013, 06:54 PM
Espresso Espresso is offline
Coffee Extraordinaire
Location: Panama City, Panama
 
Join Date: Oct 2005
Posts: 131
Mein Auto: 2001 740i Sport
Is there a question?
Reply With Quote
  #3  
Old 01-29-2013, 06:56 PM
First740i First740i is offline
Officially Welcomed to the 'Fest
Location: michigan
 
Join Date: Mar 2011
Posts: 291
Mein Auto: 740i
Yes is it sound like t-stat you think?

Sent from my DROID4 using Bimmer App
Reply With Quote
  #4  
Old 01-29-2013, 10:37 PM
JasonSC540ia JasonSC540ia is offline
Officially Welcomed to the 'Fest
Location: Alamogetto NM
 
Join Date: Aug 2009
Posts: 676
Mein Auto: 1999 740i
Could be a number of things. Im sure there is air in the system and it needs a good bleed. This accounts for the hotness on your drive home. I would make sure your hose clip is in good working order and perform a good system bleed.
Reply With Quote
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 7 Series / 8 Series > 7 Series - E38 (1995 - 2001)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



Forum Jump


All times are GMT -7. The time now is 09:00 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms