Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 7 Series / 8 Series > 7 Series - E65 / E66 (2002 - 2008)

7 Series - E65 / E66 (2002 - 2008)
Discussion pertaining to the flagship BMW here.

Reply
 
Thread Tools Display Modes
  #1  
Old 01-29-2013, 04:41 PM
gmcclintock's Avatar
gmcclintock gmcclintock is offline
Maintainin'
Location: Alabama
 
Join Date: Aug 2009
Posts: 923
Mein Auto: 2006 750Li
Daynamic Drive Inactive

I was getting this error and the dealer said I needed a new ASR Module, I am wondering if a bad battery will produce this error. Keep in mind that this is an isolated error it comes up on its own, no other errors are present just this one. It use to come and go very frequently but I recently changed my battery and had the SA reset the error and it has been about a week since I saw it so I'm wondering if the batter is the cause of it.

Also when I make sharp right hand turns I feel like the car will roll over so I'm kinda thinking that the module is in fact defective. What do you guys think?
__________________
<div align=center>
85 Honda Accord(Sold), 93 Lexus GS 300(Gave to lil Bro), 96 Lexus LS 400(Sold)
03 BMW 525i(Traded/Sold), 06 BMW 750Li(daily driver), 07 BMW 530i(My Baby's daily dirver)
Reply With Quote
Advertisement
  #2  
Old 01-29-2013, 04:56 PM
BMW7_CEO's Avatar
BMW7_CEO BMW7_CEO is offline
BMW7_CEO
Location: Belleville
 
Join Date: Aug 2012
Posts: 208
Mein Auto: 05 745LI 06 650i 06 330xi
Quote:
Originally Posted by gmcclintock View Post
I was getting this error and the dealer said I needed a new ASR Module, I am wondering if a bad battery will produce this error. Keep in mind that this is an isolated error it comes up on its own, no other errors are present just this one. It use to come and go very frequently but I recently changed my battery and had the SA reset the error and it has been about a week since I saw it so I'm wondering if the batter is the cause of it.

Also when I make sharp right hand turns I feel like the car will roll over so I'm kinda thinking that the module is in fact defective. What do you guys think?
Well bro it could be your sway bar because the thing happen to me and I had to replace it and What it could be is ether the battery or the Alternator that has to replace but since you change the battery already get your alternator check by the dealer
__________________
Reply With Quote
  #3  
Old 01-29-2013, 06:12 PM
gmcclintock's Avatar
gmcclintock gmcclintock is offline
Maintainin'
Location: Alabama
 
Join Date: Aug 2009
Posts: 923
Mein Auto: 2006 750Li
I was thinking shocks/struts/springs but ill get all of those looked at to include what you mentioned thanks.
__________________
<div align=center>
85 Honda Accord(Sold), 93 Lexus GS 300(Gave to lil Bro), 96 Lexus LS 400(Sold)
03 BMW 525i(Traded/Sold), 06 BMW 750Li(daily driver), 07 BMW 530i(My Baby's daily dirver)
Reply With Quote
  #4  
Old 01-29-2013, 06:47 PM
BMW7_CEO's Avatar
BMW7_CEO BMW7_CEO is offline
BMW7_CEO
Location: Belleville
 
Join Date: Aug 2012
Posts: 208
Mein Auto: 05 745LI 06 650i 06 330xi
Quote:
Originally Posted by gmcclintock View Post
I was thinking shocks/struts/springs but ill get all of those looked at to include what you mentioned thanks.
Yeah get it checked and I bet it's that and no problem man
__________________
Reply With Quote
  #5  
Old 01-30-2013, 01:33 AM
Piers1989 Piers1989 is offline
Officially Welcomed to the 'Fest
Location: Newcastle, UK
 
Join Date: Mar 2012
Posts: 302
Mein Auto: E65 745i
I was sometimes getting this error after cornering hard and a strange "pop" sound.

I read that it is the valve block for dynamic drive and can be fixed by removing the old block from the car (front wheel well i believe), taking the ball bearing things out (after noting where they go!, and cleaning the block out thoroughly.

Never had it done on my car as it was written off before I got round to it.

The new one doesn't do this.
Reply With Quote
  #6  
Old 01-30-2013, 04:47 AM
gmcclintock's Avatar
gmcclintock gmcclintock is offline
Maintainin'
Location: Alabama
 
Join Date: Aug 2009
Posts: 923
Mein Auto: 2006 750Li
Quote:
Originally Posted by Piers1989 View Post
I was sometimes getting this error after cornering hard and a strange "pop" sound.

I read that it is the valve block for dynamic drive and can be fixed by removing the old block from the car (front wheel well i believe), taking the ball bearing things out (after noting where they go!, and cleaning the block out thoroughly.

Never had it done on my car as it was written off before I got round to it.

The new one doesn't do this.
Thanks for the info, I purchased a block and was going ot replace it, but after not getting the error for a few days now I figured it might have been the battery causing this and I held off on it. So I think I'll go ahead and change it out and rebuild/clean the old one and see what happens thanks for the info.
__________________
<div align=center>
85 Honda Accord(Sold), 93 Lexus GS 300(Gave to lil Bro), 96 Lexus LS 400(Sold)
03 BMW 525i(Traded/Sold), 06 BMW 750Li(daily driver), 07 BMW 530i(My Baby's daily dirver)
Reply With Quote
  #7  
Old 03-18-2013, 05:38 AM
First_745Li's Avatar
First_745Li First_745Li is offline
Officially Welcomed to the 'Fest
Location: South FL
 
Join Date: Jun 2012
Posts: 2,269
Mein Auto: '03 745Li
GMC,
Did your DDI issue get resolved? If so, what was your solution? I got that error this morning on the way to work.
__________________


'11 328i
'07 Audi A8 (w/ 20,000 miles)
'03 745Li (sold)
'03 Acura TL-S
'02 Infiniti QX4 (sold )

For those like that love INK checkout join
Myinkedspace.com with my referral code and enjoy

http://myinkedspace.com/?ref=REF65900
Reply With Quote
  #8  
Old 03-18-2013, 05:43 AM
Ultimate745i Ultimate745i is offline
Ultimate745i
Location: Jacksonville, Florida
 
Join Date: Jan 2013
Posts: 509
Mein Auto: 2004 745i
First745Li, when I recieved my Dynamic Drive warning out of nowhere it was my Battery and alternator going bad. Replaced both and all was well afterwards.
__________________
Fun Doesnt Come Cheap!
Reply With Quote
  #9  
Old 03-18-2013, 05:52 AM
Ultimate745i Ultimate745i is offline
Ultimate745i
Location: Jacksonville, Florida
 
Join Date: Jan 2013
Posts: 509
Mein Auto: 2004 745i
never could understand why our cars just cant be more specific when there's an issue. Bummer!
__________________
Fun Doesnt Come Cheap!
Reply With Quote
  #10  
Old 03-18-2013, 05:53 AM
745iguy's Avatar
745iguy 745iguy is offline
Besessen Deutsch Autos
Location: Massachusetts
 
Join Date: Apr 2012
Posts: 1,133
Mein Auto: 2006 X5 3.0
Another thing you might want to inspect on the front pass side there is a sensor with a linkage attached to that sensor from the LCA that aids in keeping your cornering flat. Mines had seized and broke causing DD inactive messages on fast corners. So if you get a sensor error(i don't know if you have Inpa) check that out first, if i recall correctly there is one in the back on the same side as well. (Upon checking my dealers part site this linkage has a revised part that superseded the original)
Other things that may cause this include but is not limited to bad battery, alternator going/gone, bad sensor, low fluid, bad dd valve block, bad ps pump or bad active sway bar.
__________________

06 X5 3.0 Toledo Blue Metallic/Light Beige 2:
Adaptive Xenon Headlamps, Panoramic Sunroof, Rear Sunshades,
+Factory Aux Input in Ashtray, Bluetooth, Rear PDC Sensors, Rear Electronic Adjustable Seat Backs,
+White Angel Eye LEDs, +5000k LED H11 Foglights, +Blacked Out Chrome Grill Surround, +Puddle Light Logo Projector
.. more updates to come

PREVIOUS 2002 745i

Last edited by 745iguy; 03-18-2013 at 05:59 AM.
Reply With Quote
  #11  
Old 03-18-2013, 05:54 AM
Ultimate745i Ultimate745i is offline
Ultimate745i
Location: Jacksonville, Florida
 
Join Date: Jan 2013
Posts: 509
Mein Auto: 2004 745i
^^^ yes I forgot about the only other time was when my steering fluid was low.
__________________
Fun Doesnt Come Cheap!
Reply With Quote
  #12  
Old 03-18-2013, 09:29 AM
Punisher745Li's Avatar
Punisher745Li Punisher745Li is offline
BMW Enthusiast
Location: Westchester CA
 
Join Date: May 2012
Posts: 332
Mein Auto: 2004 745LI
Quote:
Originally Posted by Ultimate745i View Post
never could understand why our cars just cant be more specific when there's an issue. Bummer!
totally true! mine did the same thing, took it to the shop and it was the Mass Air Control Sensor....after that my car has the power back, I wonder if that's the only thing on the dashboard that light up to show bad issues...lol
__________________
Bayerische Motoren Werke

Reply With Quote
  #13  
Old 03-18-2013, 09:33 AM
Ultimate745i Ultimate745i is offline
Ultimate745i
Location: Jacksonville, Florida
 
Join Date: Jan 2013
Posts: 509
Mein Auto: 2004 745i
Quote:
Originally Posted by Punisher745Li View Post
I wonder if that's the only thing on the dashboard that light up to show bad issues...lol
LOL! Agreed. Maybe it's BMW's way of getting you to change out several parts before actually repairing the correct one.
__________________
Fun Doesnt Come Cheap!
Reply With Quote
  #14  
Old 03-18-2013, 09:40 AM
Punisher745Li's Avatar
Punisher745Li Punisher745Li is offline
BMW Enthusiast
Location: Westchester CA
 
Join Date: May 2012
Posts: 332
Mein Auto: 2004 745LI
Quote:
Originally Posted by Ultimate745i View Post
LOL! Agreed. Maybe it's BMW's way of getting you to change out several parts before actually repairing the correct one.
Well we cant complaint, we have 7 or 6 year old cars I bet you the new models even talk saying "Don't forget to change my oil"....

Its funny because our cars been having the Push to Start long time ago, and companies like Ford, Nissan and Toyota they just included in new 2013 cars saying is the last technology!!!
__________________
Bayerische Motoren Werke

Reply With Quote
  #15  
Old 03-18-2013, 09:48 AM
Ultimate745i Ultimate745i is offline
Ultimate745i
Location: Jacksonville, Florida
 
Join Date: Jan 2013
Posts: 509
Mein Auto: 2004 745i
Quote:
Originally Posted by Punisher745Li View Post

Its funny because our cars been having the Push to Start long time ago, and companies like Ford, Nissan and Toyota they just included in new 2013 cars saying is the last technology!!!
I believe BMW is very well versed in technology advancements, I just dont think they're sorting their issues out or modifying them before the next year's models come out.
Example: all 02-05 model 7's basically have the same issues. It shouldnt take that long to rectify the problems from the past year's model. Feel me?
__________________
Fun Doesnt Come Cheap!
Reply With Quote
  #16  
Old 03-18-2013, 10:39 AM
First_745Li's Avatar
First_745Li First_745Li is offline
Officially Welcomed to the 'Fest
Location: South FL
 
Join Date: Jun 2012
Posts: 2,269
Mein Auto: '03 745Li
Quote:
Originally Posted by Ultimate745i View Post
never could understand why our cars just cant be more specific when there's an issue. Bummer!
The car gets it trait from its owner...
__________________


'11 328i
'07 Audi A8 (w/ 20,000 miles)
'03 745Li (sold)
'03 Acura TL-S
'02 Infiniti QX4 (sold )

For those like that love INK checkout join
Myinkedspace.com with my referral code and enjoy

http://myinkedspace.com/?ref=REF65900
Reply With Quote
  #17  
Old 03-18-2013, 10:42 AM
Ultimate745i Ultimate745i is offline
Ultimate745i
Location: Jacksonville, Florida
 
Join Date: Jan 2013
Posts: 509
Mein Auto: 2004 745i
Quote:
Originally Posted by First_745Li View Post
The car gets it trait from its owner...
I was gonna let you slide,..but...since we're friends...Click image for larger version

Name:	pimp-slap.jpg
Views:	32
Size:	45.3 KB
ID:	367032
__________________
Fun Doesnt Come Cheap!
Reply With Quote
  #18  
Old 03-18-2013, 10:55 AM
First_745Li's Avatar
First_745Li First_745Li is offline
Officially Welcomed to the 'Fest
Location: South FL
 
Join Date: Jun 2012
Posts: 2,269
Mein Auto: '03 745Li
Quote:
Originally Posted by Ultimate745i View Post
First745Li, when I recieved my Dynamic Drive warning out of nowhere it was my Battery and alternator going bad. Replaced both and all was well afterwards.
I replaced the battery about 6 months ago, from the SEARCH I did on here, (SEARCH)... I found that its common to replace both.. thanks again Bro..!
__________________


'11 328i
'07 Audi A8 (w/ 20,000 miles)
'03 745Li (sold)
'03 Acura TL-S
'02 Infiniti QX4 (sold )

For those like that love INK checkout join
Myinkedspace.com with my referral code and enjoy

http://myinkedspace.com/?ref=REF65900
Reply With Quote
  #19  
Old 03-18-2013, 10:59 AM
Ultimate745i Ultimate745i is offline
Ultimate745i
Location: Jacksonville, Florida
 
Join Date: Jan 2013
Posts: 509
Mein Auto: 2004 745i
Quote:
Originally Posted by First_745Li View Post
I replaced the battery about 6 months ago, from the SEARCH I did on here, (SEARCH)... I found that its common to replace both.. thanks again Bro..!
Hope you dont have the Water Cooled type alternator though. They cost a GRIP!
__________________
Fun Doesnt Come Cheap!
Reply With Quote
  #20  
Old 03-18-2013, 11:05 AM
First_745Li's Avatar
First_745Li First_745Li is offline
Officially Welcomed to the 'Fest
Location: South FL
 
Join Date: Jun 2012
Posts: 2,269
Mein Auto: '03 745Li
Quote:
Originally Posted by 745iguy View Post
Another thing you might want to inspect on the front pass side there is a sensor with a linkage attached to that sensor from the LCA that aids in keeping your cornering flat. Mines had seized and broke causing DD inactive messages on fast corners. So if you get a sensor error(i don't know if you have Inpa) check that out first, if i recall correctly there is one in the back on the same side as well. (Upon checking my dealers part site this linkage has a revised part that superseded the original)
Other things that may cause this include but is not limited to bad battery, alternator going/gone, bad sensor, low fluid, bad dd valve block, bad ps pump or bad active sway bar.
I have INPA, will it show that this sensor is bad? I'll check it this afternoon. Thanks Bro
__________________


'11 328i
'07 Audi A8 (w/ 20,000 miles)
'03 745Li (sold)
'03 Acura TL-S
'02 Infiniti QX4 (sold )

For those like that love INK checkout join
Myinkedspace.com with my referral code and enjoy

http://myinkedspace.com/?ref=REF65900
Reply With Quote
  #21  
Old 03-18-2013, 11:07 AM
First_745Li's Avatar
First_745Li First_745Li is offline
Officially Welcomed to the 'Fest
Location: South FL
 
Join Date: Jun 2012
Posts: 2,269
Mein Auto: '03 745Li
Quote:
Originally Posted by Ultimate745i View Post
I was gonna let you slide,..but...since we're friends...Attachment 367032
.. Look at the threads.."my car is broke, need help"..

It's like their cars won't start so they decided to ride in on the short bus...
__________________


'11 328i
'07 Audi A8 (w/ 20,000 miles)
'03 745Li (sold)
'03 Acura TL-S
'02 Infiniti QX4 (sold )

For those like that love INK checkout join
Myinkedspace.com with my referral code and enjoy

http://myinkedspace.com/?ref=REF65900
Reply With Quote
  #22  
Old 03-18-2013, 11:08 AM
First_745Li's Avatar
First_745Li First_745Li is offline
Officially Welcomed to the 'Fest
Location: South FL
 
Join Date: Jun 2012
Posts: 2,269
Mein Auto: '03 745Li
Quote:
Originally Posted by Ultimate745i View Post
Hope you dont have the Water Cooled type alternator though. They cost a GRIP!
oh and Bro... I have the watercooler version...yay me
__________________


'11 328i
'07 Audi A8 (w/ 20,000 miles)
'03 745Li (sold)
'03 Acura TL-S
'02 Infiniti QX4 (sold )

For those like that love INK checkout join
Myinkedspace.com with my referral code and enjoy

http://myinkedspace.com/?ref=REF65900
Reply With Quote
  #23  
Old 03-18-2013, 11:10 AM
First_745Li's Avatar
First_745Li First_745Li is offline
Officially Welcomed to the 'Fest
Location: South FL
 
Join Date: Jun 2012
Posts: 2,269
Mein Auto: '03 745Li
Quote:
Originally Posted by Punisher745Li View Post
Well we cant complaint, we have 7 or 6 year old cars I bet you the new models even talk saying "Don't forget to change my oil"....

Its funny because our cars been having the Push to Start long time ago, and companies like Ford, Nissan and Toyota they just included in new 2013 cars saying is the last technology!!!
Very true!
__________________


'11 328i
'07 Audi A8 (w/ 20,000 miles)
'03 745Li (sold)
'03 Acura TL-S
'02 Infiniti QX4 (sold )

For those like that love INK checkout join
Myinkedspace.com with my referral code and enjoy

http://myinkedspace.com/?ref=REF65900
Reply With Quote
  #24  
Old 03-18-2013, 11:59 AM
Punisher745Li's Avatar
Punisher745Li Punisher745Li is offline
BMW Enthusiast
Location: Westchester CA
 
Join Date: May 2012
Posts: 332
Mein Auto: 2004 745LI
Quote:
Originally Posted by Ultimate745i View Post
Hope you dont have the Water Cooled type alternator though. They cost a GRIP!
I just check mine!! not that version just in case lol
__________________
Bayerische Motoren Werke

Reply With Quote
  #25  
Old 03-18-2013, 12:28 PM
745iguy's Avatar
745iguy 745iguy is offline
Besessen Deutsch Autos
Location: Massachusetts
 
Join Date: Apr 2012
Posts: 1,133
Mein Auto: 2006 X5 3.0
Quote:
Originally Posted by First_745Li View Post
I have INPA, will it show that this sensor is bad? I'll check it this afternoon. Thanks Bro
It will give an error i forgot what the hell it said when mine was doing this.. Some kind of implausible signal. I will try and find it for ya. (Error code that is)
__________________

06 X5 3.0 Toledo Blue Metallic/Light Beige 2:
Adaptive Xenon Headlamps, Panoramic Sunroof, Rear Sunshades,
+Factory Aux Input in Ashtray, Bluetooth, Rear PDC Sensors, Rear Electronic Adjustable Seat Backs,
+White Angel Eye LEDs, +5000k LED H11 Foglights, +Blacked Out Chrome Grill Surround, +Puddle Light Logo Projector
.. more updates to come

PREVIOUS 2002 745i
Reply With Quote
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 7 Series / 8 Series > 7 Series - E65 / E66 (2002 - 2008)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 07:37 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms