Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > The Best of Bimmerfest! > Do-It-Yourself H.Q.

Do-It-Yourself H.Q.
Share your DIY projects or ask questions about how to fix something on your own. Help fellow Bimmerfest members improve your wrench turning skills! All BMW DIY tips, tales, and projects discussed inside. Learn to work on your car and know the right BMW parts you will need!

Reply
 
Thread Tools Display Modes
  #1  
Old 01-30-2013, 09:19 AM
squeaky3 squeaky3 is offline
Registered User
Location: illinois
 
Join Date: Jan 2013
Posts: 7
Mein Auto: nothing
03 bmw 330xi hesitates on take off

im working on a bmw for a customer, originally came in for no start and smokes badly, searched around here and other places and found the ccv system at fault, so removed the intake replaced the ccv system and hoses (except hose to dipstick from bottom of valve)

also replaced spark plugs and valve cover gasket

now car has a hesitation when you take off from a stop, driving down the road car drives great, but when leaving a stop it hesitates for a second then takes off, sometimes it will even hesitate enough to kill the engine

first thing was checked fuel pressure, has constant 35 psi at all times

could a vacuum line have gotten switched around or swapped and cause that or am i looking for something else?
Reply With Quote
Advertisement
  #2  
Old 01-30-2013, 10:01 AM
squeaky3 squeaky3 is offline
Registered User
Location: illinois
 
Join Date: Jan 2013
Posts: 7
Mein Auto: nothing
well nevermind, found a connector not plugged into that "wirebox" that box with the wires and hoses coming off of it under the intake

plugged that in and drives just fine now
Reply With Quote
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > The Best of Bimmerfest! > Do-It-Yourself H.Q.
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 03:20 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms