Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 5 Series > E39 (1997 - 2003)

E39 (1997 - 2003)
The BMW 5-Series (E39 chassis) was introduced in the United States as a 1997 model year car and lasted until the 2004 when the E60 chassis was released. The United States saw several variations including the 525i, 528i, 530i and 540i. -- View the E39 Wiki

Reply
 
Thread Tools Display Modes
  #26  
Old 01-31-2013, 04:59 PM
GreenTiger GreenTiger is online now
Officially Welcomed to the 'Fest
Location: SoCal
 
Join Date: Jun 2009
Posts: 639
Mein Auto: 7/98 NonVanos 540iA
Good thread.

I have a high HC count in smog checks. Can running rich be the MAF? My problem is that there are no codes so I don't know for sure. However, I do sometimes get the bouncing RPMs while I am in gear at a stoplight. Could it be my MAF on its way out? Also, I believe my fuel trim levels tell me they are running rich, by 3-4% IIRC.
Reply With Quote
  #27  
Old 01-31-2013, 05:09 PM
iceman4169 iceman4169 is offline
Officially Welcomed to the 'Fest
Location: San Diego California
 
Join Date: Oct 2012
Posts: 270
Mein Auto: 1999 540i
Thats how it started. My rpms started acting funny. Right about around 101k miles. My gas mileage started going down the drain. Here and there the car would stutter and if i floor it it wasnt smooth and like half the power. It continued to get worse. I unplugged it and it was way better so I ordered one in the mail. Installed it this morning and my car feels brand new. No codes? Did you try cleaning it? Others can help more then me on this. But thats what i felt on mine before it started to bail out. Cleaned it it was good for about a week then that was it.
Reply With Quote
  #28  
Old 01-31-2013, 11:13 PM
GreenTiger GreenTiger is online now
Officially Welcomed to the 'Fest
Location: SoCal
 
Join Date: Jun 2009
Posts: 639
Mein Auto: 7/98 NonVanos 540iA
Thanks for the answer iceman. Yah, I cleaned it last, didn't really notice a difference. I have had the car for 4.5 years (about 27k miles) and have been pretty much getting the same mpg since I got it. And yes, there are NO codes. Which is killing me, because I am BARELY passing smog for the HC count. It is maxing out 33/33 (with a couple of failures) with everything else being very well in range.
Reply With Quote
  #29  
Old 02-01-2013, 01:50 AM
iceman4169 iceman4169 is offline
Officially Welcomed to the 'Fest
Location: San Diego California
 
Join Date: Oct 2012
Posts: 270
Mein Auto: 1999 540i
How many miles are on the car? People told me those o2 sensors should be changed out as well. But I haven't done that yet. That's strange no codes. I mean as long as you pass smog you should be fine for awhile. You wont have to deal with it for awhile. Any mods? Ive been told by this old man once that the oil on my intake would ruin my maf. I think he was right. But thats weird. As long as it passes your cool but its strange not having any codes or cel on.
Reply With Quote
  #30  
Old 02-01-2013, 02:45 AM
Reuvers Reuvers is offline
Officially Welcomed to the 'Fest
Location: The Netherlands
 
Join Date: Apr 2011
Posts: 139
Mein Auto: BMW e39 540i '97
Quote:
Originally Posted by King540i View Post
Good thread.

I have a high HC count in smog checks. Can running rich be the MAF? My problem is that there are no codes so I don't know for sure. However, I do sometimes get the bouncing RPMs while I am in gear at a stoplight. Could it be my MAF on its way out? Also, I believe my fuel trim levels tell me they are running rich, by 3-4% IIRC.
have you looked for vac leaks?
Reply With Quote
  #31  
Old 02-01-2013, 06:25 PM
GreenTiger GreenTiger is online now
Officially Welcomed to the 'Fest
Location: SoCal
 
Join Date: Jun 2009
Posts: 639
Mein Auto: 7/98 NonVanos 540iA
155k miles. Have not checked for vac leaks. I will probably take it in for a smoke check soon. I have a stock intake.

Thanks guys.
Reply With Quote
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 5 Series > E39 (1997 - 2003)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 01:14 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms