Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 7 Series / 8 Series > 7 Series - E38 (1995 - 2001)

7 Series - E38 (1995 - 2001)

Reply
 
Thread Tools Display Modes
  #1  
Old 02-02-2013, 04:56 PM
PatSmalls89 PatSmalls89 is offline
Registered User
Location: California
 
Join Date: Jan 2013
Posts: 2
Mein Auto: 2001 BMW 740IL
Exclamation 2001 740il ABS and traction control light

Hello everyone,

I know there is a good amount of threads about this issue but my situation is a bit different. Please help me. I have all three lights on (brake, ABS and traction control) but the brake light I'd because my brake pads are so low. the dash also says check brake lining, but this also because of brake pad wear sensor. My concern is the traction control and ABS light, they have been on for a good amount of time now.

Here's the interesting part... a couple of weeks ago my crankshaft sensor went out and killed my battery while trying to start. I trickle charged the battery and ordered the crankshaft sensor. one week later I replaced the crankshaft sensor and plugged the charged battery back in. Started the car and no ABS or traction control light!!! (red brake light still on)I tested the traction control on the road and it had full function.

1 hour later both the ABS and traction control turned on and stayed on. Speedometer is fully functioning. What could this be? I know traction control works because I felt it work. I know the lights turned off because the battery was unplugged for such a long time and is not connected to crankshaft. what could this be? wheel speed sensor? I doubt it because my traction control wouldn't have worked. please help!
Reply With Quote
Ads by Google
  #2  
Old 02-04-2013, 01:29 PM
mikejenkins mikejenkins is offline
Mikej
Location: Rugby, U.K.
 
Join Date: Jan 2012
Posts: 24
Mein Auto: E38 750i, E34 540 Touring
Check my post! Very similar problems on 750 after removing batteries for repair to instrument cluster. Haven't had much of a respone myself. Fortunately I have the diagnostic tools, but I was hoping for suggestions.
Mike
Reply With Quote
Reply

Bookmarks

Tags
abs fault, brake light, traction control light


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 7 Series / 8 Series > 7 Series - E38 (1995 - 2001)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



Forum Jump


All times are GMT -7. The time now is 08:43 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms